Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
Hello,
this patch adds 'utest.h' [1] under the name 'utest-h'.
From a458a9a406ad4b4b4758b293e648965591c5fbd0 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Thu, 23 Jun 2022 22:07:05 +0300
Subject: [PATCH] gnu: Add utest-h
* gnu/packages/c.scm (utest-h): New variable.
---
gnu/packages/c.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3e49539473..69797df8b3 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1134,3 +1135,39 @@ performance concurrent systems developed in C99+.")
C and C++. The functions it provides are like those from the C header
string.h, but with a utf8* prefix instead of the str* prefix.")
(license license:unlicense))))
+
+(define-public utest-h
+ ;; The latest tag is used as there is no release.
+ (let ((commit "54458e248f875f1a51f0af8bec8ca6ae7761b9d1") (revision "0"))
+ (package
+ (name "utest-h")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sheredom/utest.h")
+ (commit commit)))
+ (file-name (git-file-name "utest.h" version))
+ (sha256
+ (base32
+ "1ikl5jwmjdw1mblqyl2kvnqwkjgaz78c1h7mjcfmzjc0d3h8kh44"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "test"
+ (invoke "cmake" ".")
+ (invoke "make")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "utest.h"
+ (string-append out "/include"))))))))
+ (home-page "https://www.duskborn.com/utest_h/")
+ (synopsis "Single header unit testing framework for C and C++")
+ (description "A simple one header solution to unit testing for C/C++.")
+ (license license:unlicense))))
--
2.25.1
Thanks,
- Artyom
References:
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmK0un8ACgkQ6cWi2QiY
oC8xoAf9GjjqucdsKfwE5OLaQDqxaFgaD9mo/MiCkm1sOEONQE6jVIIjLBNIALE1
RmK3hGJCE9Nflg5QEfrKYKqHYcHA1Ovn9sRY0CK9GOnDqEylJw40BSyHsHi9L6rC
AKJm1iO8bnzl6VcUT1S4TMSWTwKJ5hD3zvVWWYPEWm6d7/URtVMm9Sib+ckX0rFF
XOxOeJAo/vjUFV6Rc1+lTtu6Sc6lyn4B/cg5TTf3Zx2kKlpGz3BukjjJC8ycR6pc
ywTaP8kIn3E71dAo7tc2LiEeLNgb2mAhFr+wvV1tA8X+qu1Sf133ib6eUGQJlArp
cTiBrDOfHhGdrXa6uW5kFEkXS4BEUA==
=+ESi
-----END PGP SIGNATURE-----