[PATCH] gnu: Add r-awst.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220623124454.28787-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-awst): New variable.
---
gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..fa9c728a44 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,32 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-awst
+ (package
+ (name "r-awst")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "awst" version))
+ (sha256
+ (base32
+ "0iw3zycmj95rmdx7f2w0j4yxkzd90y87lrzgdn9cyvvzi5avflav"))))
+ (properties `((upstream-name . "awst")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/drisso/awst")
+ (synopsis "Asymmetric within-sample transformation")
+ (description
+ "This package @dfn{awst} (Asymmetric Within-Sample Transformation) that
+regularizes RNA-seq read counts and reduces the effect of noise on the
+classification of samples. @code{AWST} comprises two main steps: standardization
+and smoothing. These steps transform gene expression data to reduce the noise
+of the lowly expressed features, which suffer from background effects and low
+signal-to-noise ratio, and the influence of the highly expressed features, which
+may be the result of amplification bias and other experimental artifacts.")
+ (license license:expat)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56167-done@debbugs.gnu.org)
87v8nzd912.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56167@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56167
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help