[PATCH] gnu: Add r-atena.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220623102520.24412-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-atena): New variable.
---
gnu/packages/bioconductor.scm | 41 +++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..5ec69365d1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,47 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-atena
+ (package
+ (name "r-atena")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "atena" version))
+ (sha256
+ (base32
+ "1jbnlxrk8npflym008cgrazamlsh6y624g1d6x648kcjd8zwvj6n"))))
+ (properties `((upstream-name . "atena")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-annotationhub
+ r-biocgenerics
+ r-biocparallel
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicranges
+ r-iranges
+ r-matrix
+ r-rsamtools
+ r-s4vectors
+ r-scales
+ r-sparsematrixstats
+ r-squarem
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/functionalgenomics/atena")
+ (synopsis "Analysis of transposable elements")
+ (description
+ "The @code{atena} package quantifies expression of @dfn{TEs} (transposable
+elements) from RNA-seq data through different methods, including @code{ERVmap},
+@code{TEtranscripts} and @code{Telescope}. A common interface is provided to
+use each of these methods, which consists of building a parameter object, calling
+the quantification function with this object and getting a
+@code{SummarizedExperiment} object as an output container of the quantified
+expression profiles. The implementation allows quantifing TEs and gene
+transcripts in an integrated manner.")
+ (license license:artistic2.0)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56161-done@debbugs.gnu.org)
87edund8v1.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56161@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56161
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help