[PATCH] gnu: Add r-aspli.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220622144612.19605-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-aspli): New variable.
---
gnu/packages/bioconductor.scm | 48 +++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..0136d268b3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,54 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-aspli
+ (package
+ (name "r-aspli")
+ (version "2.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ASpli" version))
+ (sha256
+ (base32
+ "1frlcwa8m4imfx6ncav8r8yskyaf4ibha177mfnp9y84w6mphynz"))))
+ (properties `((upstream-name . "ASpli")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-annotationdbi
+ r-biocgenerics
+ r-biocstyle
+ r-data-table
+ r-dt
+ r-edger
+ r-genomicalignments
+ r-genomicfeatures
+ r-genomicranges
+ r-gviz
+ r-htmltools
+ r-igraph
+ r-iranges
+ r-limma
+ r-mass
+ r-pbmcapply
+ r-rsamtools
+ r-s4vectors
+ r-tidyr
+ r-upsetr))
+ (home-page "https://bioconductor.org/packages/ASpli")
+ (synopsis "Analysis of alternative splicing using RNA-Seq")
+ (description
+ "@dfn{AS} (alternative splicing) is a common mechanism of post-transcriptional
+gene regulation in eukaryotic organisms that expands the functional and regulatory
+diversity of a single gene by generating multiple mRNA isoforms that encode
+structurally and functionally distinct proteins. @code{ASpli} is an integrative
+pipeline and user-friendly @code{R} package that facilitates the analysis of changes
+in both annotated and novel AS events. @code{ASpli} integrates several independent
+signals in order to deal with the complexity that might arise in splicing
+patterns.")
+ ;; The authors didn't specify any GPL version in description or in the
+ ;; sources.
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56147-done@debbugs.gnu.org)
871qqnd8sv.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56147@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56147
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help