[PATCH] gnu: Add r-aseb.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220622135741.16618-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-aseb): New variable.
---
gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..f961d201d2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,32 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-aseb
+ (package
+ (name "r-aseb")
+ (version "1.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ASEB" version))
+ (sha256
+ (base32
+ "1i0r4vimk6is4j4rr14ajp8papznpmmr0bhwd96s8w53cqdqph7p"))))
+ (properties `((upstream-name . "ASEB")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/ASEB")
+ (synopsis "Predict acetylated lysine sites")
+ (description
+ "@code{ASEB} is an R package to predict lysine sites that can be acetylated
+by a specific @dfn{KAT}-family (K-acetyl-transferases). Lysine acetylation is
+a well-studied posttranslational modification on kinds of proteins. About four
+thousand lysine acetylation sites and over 20 lysine KATs have been identified.
+However, which KAT is responsible for a given protein or lysine site acetylation
+is mostly unknown. In this package, we use a @dfn{GSEA}-like (Gene Set Enrichment
+Analysis) method to make predictions. GSEA method was developed and successfully
+used to detect coordinated expression changes and find the putative functions
+of the long non-coding RNAs.")
+ (license license:gpl3+)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56142-done@debbugs.gnu.org)
87sfj3bu2b.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56142@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56142
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help