[Patches] Add and update music packages

  • Open
  • quality assurance status badge
Details
5 participants
  • Sughosha
  • Alice BRENON
  • Maxime Devos
  • Ricardo Wurmus
  • Thorsten Wilms
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 22 Jun 2022 14:36
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
o8Acm5cfOaqtnIzq2115gx9xgJ2jE0FcDoyhmSHDnUyYRqrMF8zeNDErpYpVcjmuokpGtGw__RkbqGW5xetv_xl_kkmC88mofx2bh08OU4Q=@proton.me
Empty Message
Attachment: file
From f8fd8c894b62080da31982431550946296e61407 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:32:28 +0200
Subject: [PATCH 4/4] gnu: Add fabla

* gnu/packages/music.scm: add fabla
---
gnu/packages/music.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a3710adf3a..9f992706b7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5081,6 +5081,30 @@ (define-public luppp
"Luppp is a music creation tool, intended for live use. The focus is on real time processing and a fast and intuitive workflow with MIDI mapping support.")
(license license:gpl3))))
+(define-public fabla
+ (let ((revision "18") (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
+ (package
+ (name "fabla")
+ (version (git-version "1.2.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Fabla")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ybbzb86j1n5dfhzc6aa3cibkwi6q3x0c18b1w3anyibanmr1wmc"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs `(("pkg-config" ,pkg-config) ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (inputs (list ntk cairomm libsndfile))
+ (home-page "http://openavproductions.com/fabla")
+ (synopsis "Drum sampler LV2 plugin")
+ (description "Fabla is a drum sampler LV2 plugin.")
+ (license license:gpl3))))
+
(define-public sorcer
(let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
(package
--
2.36.1
From 98d2fde325564c4a004613546d00a1c6e75502a8 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:31:39 +0200
Subject: [PATCH 2/4] gnu: Add distrho-ports

* gnu/packages/music.scm: add distrho-ports
---
gnu/packages/music.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 449d4ab250..e691d43d12 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5938,6 +5938,37 @@ (define-public mamba
ones.")
(license license:bsd-0)))
+(define-public distrho-ports
+ (let ((revision "602") (commit "5907a18cb50dd63d84d37776dfd8e8dcc7f3e378"))
+ (package
+ (name "distrho-ports")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DISTRHO/DISTRHO-Ports")
+ (commit commit)))
+ (sha256
+ (base32
+ "1ggl3piwb18gkz3glbqx5h1dcjcc5b9kpssd54fpxddaxagc4pwz"))))
+ (build-system meson-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config) ("cmake" ,cmake-minimal)))
+ (inputs (list fftwf
+ alsa-lib
+ freetype
+ libx11
+ libxrender
+ libxext
+ libxcursor
+ mesa))
+ (home-page "https://github.com/DISTRHO/DISTRHO-Ports")
+ (synopsis "Linux audio plugins and LV2 ports")
+ (description
+ "This package contains GNU/Linux and LV2 ports of the following plugins: The Function, The Pilgrim, Dexed, dRowAudio plugins (Distortion, Distortion Shaper, Flanger, Reverb, Tremolo), DrumSynth, EasySSP, EQinox, HiReSam, JuceOPL, KlangFalter, LUFS Meter, LUFS Meter (Multichannel), Luftikus, Obxd, PitchedDelay, ReFine, StereoSourceSeperation, Swanky Amp, TAL plugins (Dub-3, Filter, Filter-2, Noize Mak3r, Reverb, Reverb-II, Reverb-III, Vocoder-II), Temper, Vex, Vitalium and Wolpertinger")
+ ;; This package consists of several plugins.
+ ;; Different copyrights and licenses apply to different plugins.
+ (license (list license:gpl2 license:lgpl3)))))
+
(define-public dpf-plugins
(package
(name "dpf-plugins")
--
2.36.1
From ba87d4713da9cc26cc7279c56d287f385bf696bc Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:30:17 +0200
Subject: [PATCH 1/4] gnu: Update sorcer

* gnu/packages/music.scm: updating sorcer to its latest commit fixes its building
---
gnu/packages/music.scm | 59 ++++++++++++++++--------------------------
1 file changed, 22 insertions(+), 37 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cb176320..449d4ab250 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5055,44 +5055,29 @@ (define-public patchmatrix
(license license:artistic2.0)))
(define-public sorcer
- (package
- (name "sorcer")
- (version "1.1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openAVproductions/"
- "openAV-Sorcer/archive/release-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "07iyqj28wm0xc4arrq893bm12xjpz65db7ynrlmf6w8krg8wjmd0"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-architecture-specific-flags
- (lambda _
- (substitute* "CMakeLists.txt"
- (("-msse2 -mfpmath=sse") ""))
- #t))
- (add-after 'unpack 'build-faust-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "faust"
- (delete-file "main.cpp")
- (invoke "faust" "-i"
- "-a" "lv2synth.cpp"
- "-o" "main.cpp" "main.dsp")))))))
- (inputs
- (list boost lv2 ntk))
- (native-inputs
- (list faust pkg-config))
- (home-page "http://openavproductions.com/sorcer/")
- (synopsis "Wavetable LV2 plugin synth")
- (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
+ (let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
+ (package
+ (name "sorcer")
+ (version (git-version "1.1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/openAVproductions/openAV-Sorcer")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ryaglp2pzln2bm0pwc5p9lb2nk0x4wmrs4c4cp6d2m2hhk82yk7"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests included
+ (inputs (list boost lv2 ntk))
+ (native-inputs (list faust pkg-config))
+ (home-page "http://openavproductions.com/sorcer/")
+ (synopsis "Wavetable LV2 plugin synth")
+ (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
the electronic or dubstep genre.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public sonivox-eas
(package
--
2.36.1
From e695d37744c81963f22e93af9aafbadd38983b5a Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:32:11 +0200
Subject: [PATCH 3/4] gnu: Add luppp

* gnu/packages/music.scm: add luppp
---
gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e691d43d12..a3710adf3a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5054,6 +5054,33 @@ (define-public patchmatrix
OSC connections.")
(license license:artistic2.0)))
+(define-public luppp
+ (let ((revision "29") (commit "23da1497f80dbace48b7807afd3570c57a4d5994"))
+ (package
+ (name "luppp")
+ (version (git-version "1.2.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Luppp")
+ (commit commit)))
+ (sha256
+ (base32
+ "1rjl7fwnqq1gxa3haw1z0p1mld23i194sc43m03h9isagkwxrx9d"))))
+ (build-system meson-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config) ("cmake-minimal" ,cmake-minimal)))
+ (inputs (list cairo
+ ntk
+ liblo
+ jack-1
+ libsndfile
+ libsamplerate))
+ (home-page "http://openavproductions.com/luppp")
+ (synopsis "Live performance tool")
+ (description
+ "Luppp is a music creation tool, intended for live use. The focus is on real time processing and a fast and intuitive workflow with MIDI mapping support.")
+ (license license:gpl3))))
+
(define-public sorcer
(let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
(package
--
2.36.1
S
S
Sughosha wrote on 24 Jun 2022 10:54
Resending the patches with correcting mistakes.
(name . 56140@debbugs.gnu.org)(address . 56140@debbugs.gnu.org)
M3Kpy3tN6sr5H8t8jPVJm_WF2406N46zIybIJI-BeaXVVBkqf-JtyXWrj8c4Z18jHjgJY0lHZImE4mqsuECY9y0fBPn1gTHEcKbXQRHBCqs=@proton.me
Sorry that I have not used full sentenses in change log. I came to know about it later. I am sending all the patches again.
Attachment: file
From ba87d4713da9cc26cc7279c56d287f385bf696bc Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:30:17 +0200
Subject: [PATCH 1/4] gnu: Update sorcer

* gnu/packages/music.scm: Update sorcer to its latest commit which fixes its building.
---
gnu/packages/music.scm | 59 ++++++++++++++++--------------------------
1 file changed, 22 insertions(+), 37 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cb176320..449d4ab250 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5055,44 +5055,29 @@ (define-public patchmatrix
(license license:artistic2.0)))
(define-public sorcer
- (package
- (name "sorcer")
- (version "1.1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openAVproductions/"
- "openAV-Sorcer/archive/release-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "07iyqj28wm0xc4arrq893bm12xjpz65db7ynrlmf6w8krg8wjmd0"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-architecture-specific-flags
- (lambda _
- (substitute* "CMakeLists.txt"
- (("-msse2 -mfpmath=sse") ""))
- #t))
- (add-after 'unpack 'build-faust-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "faust"
- (delete-file "main.cpp")
- (invoke "faust" "-i"
- "-a" "lv2synth.cpp"
- "-o" "main.cpp" "main.dsp")))))))
- (inputs
- (list boost lv2 ntk))
- (native-inputs
- (list faust pkg-config))
- (home-page "http://openavproductions.com/sorcer/")
- (synopsis "Wavetable LV2 plugin synth")
- (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
+ (let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
+ (package
+ (name "sorcer")
+ (version (git-version "1.1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/openAVproductions/openAV-Sorcer")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ryaglp2pzln2bm0pwc5p9lb2nk0x4wmrs4c4cp6d2m2hhk82yk7"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests included
+ (inputs (list boost lv2 ntk))
+ (native-inputs (list faust pkg-config))
+ (home-page "http://openavproductions.com/sorcer/")
+ (synopsis "Wavetable LV2 plugin synth")
+ (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
the electronic or dubstep genre.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public sonivox-eas
(package
--
2.36.1
From 98d2fde325564c4a004613546d00a1c6e75502a8 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:31:39 +0200
Subject: [PATCH 2/4] gnu: Add distrho-ports

* gnu/packages/music.scm: Add distrho-ports.
---
gnu/packages/music.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 449d4ab250..e691d43d12 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5938,6 +5938,37 @@ (define-public mamba
ones.")
(license license:bsd-0)))
+(define-public distrho-ports
+ (let ((revision "602") (commit "5907a18cb50dd63d84d37776dfd8e8dcc7f3e378"))
+ (package
+ (name "distrho-ports")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DISTRHO/DISTRHO-Ports")
+ (commit commit)))
+ (sha256
+ (base32
+ "1ggl3piwb18gkz3glbqx5h1dcjcc5b9kpssd54fpxddaxagc4pwz"))))
+ (build-system meson-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config) ("cmake" ,cmake-minimal)))
+ (inputs (list fftwf
+ alsa-lib
+ freetype
+ libx11
+ libxrender
+ libxext
+ libxcursor
+ mesa))
+ (home-page "https://github.com/DISTRHO/DISTRHO-Ports")
+ (synopsis "Linux audio plugins and LV2 ports")
+ (description
+ "This package contains GNU/Linux and LV2 ports of the following plugins: The Function, The Pilgrim, Dexed, dRowAudio plugins (Distortion, Distortion Shaper, Flanger, Reverb, Tremolo), DrumSynth, EasySSP, EQinox, HiReSam, JuceOPL, KlangFalter, LUFS Meter, LUFS Meter (Multichannel), Luftikus, Obxd, PitchedDelay, ReFine, StereoSourceSeperation, Swanky Amp, TAL plugins (Dub-3, Filter, Filter-2, Noize Mak3r, Reverb, Reverb-II, Reverb-III, Vocoder-II), Temper, Vex, Vitalium and Wolpertinger")
+ ;; This package consists of several plugins.
+ ;; Different copyrights and licenses apply to different plugins.
+ (license (list license:gpl2 license:lgpl3)))))
+
(define-public dpf-plugins
(package
(name "dpf-plugins")
--
2.36.1
From e695d37744c81963f22e93af9aafbadd38983b5a Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:32:11 +0200
Subject: [PATCH 3/4] gnu: Add luppp

* gnu/packages/music.scm: Add luppp.
---
gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e691d43d12..a3710adf3a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5054,6 +5054,33 @@ (define-public patchmatrix
OSC connections.")
(license license:artistic2.0)))
+(define-public luppp
+ (let ((revision "29") (commit "23da1497f80dbace48b7807afd3570c57a4d5994"))
+ (package
+ (name "luppp")
+ (version (git-version "1.2.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Luppp")
+ (commit commit)))
+ (sha256
+ (base32
+ "1rjl7fwnqq1gxa3haw1z0p1mld23i194sc43m03h9isagkwxrx9d"))))
+ (build-system meson-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config) ("cmake-minimal" ,cmake-minimal)))
+ (inputs (list cairo
+ ntk
+ liblo
+ jack-1
+ libsndfile
+ libsamplerate))
+ (home-page "http://openavproductions.com/luppp")
+ (synopsis "Live performance tool")
+ (description
+ "Luppp is a music creation tool, intended for live use. The focus is on real time processing and a fast and intuitive workflow with MIDI mapping support.")
+ (license license:gpl3))))
+
(define-public sorcer
(let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
(package
--
2.36.1
From f8fd8c894b62080da31982431550946296e61407 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:32:28 +0200
Subject: [PATCH 4/4] gnu: Add fabla

* gnu/packages/music.scm: Add fabla.
---
gnu/packages/music.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a3710adf3a..9f992706b7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5081,6 +5081,30 @@ (define-public luppp
"Luppp is a music creation tool, intended for live use. The focus is on real time processing and a fast and intuitive workflow with MIDI mapping support.")
(license license:gpl3))))
+(define-public fabla
+ (let ((revision "18") (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
+ (package
+ (name "fabla")
+ (version (git-version "1.2.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Fabla")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ybbzb86j1n5dfhzc6aa3cibkwi6q3x0c18b1w3anyibanmr1wmc"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs `(("pkg-config" ,pkg-config) ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (inputs (list ntk cairomm libsndfile))
+ (home-page "http://openavproductions.com/fabla")
+ (synopsis "Drum sampler LV2 plugin")
+ (description "Fabla is a drum sampler LV2 plugin.")
+ (license license:gpl3))))
+
(define-public sorcer
(let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
(package
--
2.36.1
A
A
Alice BRENON wrote on 28 Jun 2022 09:45
[Patches] Add and update music packages
(address . 56140@debbugs.gnu.org)
20220628094526.7ca71999@ens-lyon.fr
Hi !

Thanks for submitting this patch ! I'm in no position to provide
a definitive answer to accept or reject this but here are some immediate
things that could be improved.

- your description of Fabla doesn't add much information compared to
the synopsis. What makes it special ? How is it different from the
other similar tools ? (see
for inspiration)
- the other packages seem to have more extensive description, but they
make very long lines, have you tried formatting your package using
the `guix style` command ?
- you seem to consistently use the "old" syntax for
packages in native-inputs, as opposed to inputs, is there a good
reason for that or have you maybe only found examples where the
native-inputs haven't been modernized ? While it makes sense to
rename `cmake-minimal` to `cmake` in the definition of
`distrho-ports` (though I wonder `luppp` didn't require the same
renaming and keeps the key "cmake-minimal" for `cmake-minimal`, all
the others occurrences (`("pkg-config" ,pkg-config)`, `("lv2" ,lv2)`…)
are totally unneeded for as far as I understand and could be
simplified as `(list pkg-config lv2 mesa)`.

I'm also a bit curious as to why tests need to be explicitly
deactivated in `sorcer`, does running the default cmake command to test
the project result in a failure, not just a NOP ?

I hope some other people will take it over from there because I don't
have much more to contribute : )

Cheers,

Alice
S
S
Sughosha wrote on 28 Jun 2022 10:30
(name . 56140@debbugs.gnu.org)(address . 56140@debbugs.gnu.org)
Z8L4RCkILD0i9nHmkMLlEQeeVbIEYmiyK8jU1QfvjrcE1eGY__aa3HIvQ8UecnjT8SrqnOdaRP3PDiS6EmQmqGrmWGB4DJnkKhcL-BvNVZs=@proton.me
Hi Alice,

First of all, thanks for reviewing my patches :)
Toggle quote (1 lines)
> - your description of Fabla doesn't add much information compared to the synopsis. What makes it special ? How is it different from the other similar tools ? (see https://guix.gnu.org/fr/manual/devel/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptionsfor inspiration)
I will improve the descriptions.
Toggle quote (1 lines)
> - the other packages seem to have more extensive description, but they make very long lines, have you tried formatting your package using the `guix style` command ? (https://guix.gnu.org/fr/manual/devel/en/html_node/Formatting-Code.html#Formatting-Code)
Sorry that I have forgot this step. I will do it.
Toggle quote (1 lines)
> - you seem to consistently use the "old" syntax for packages in native-inputs, as opposed to inputs, is there a good reason for that or have you maybe only found examples where the native-inputs haven't been modernized ? While it makes sense to rename `cmake-minimal` to `cmake` in the definition of `distrho-ports` (though I wonder `luppp` didn't require the same renaming and keeps the key "cmake-minimal" for `cmake-minimal`, all the others occurrences (`("pkg-config" ,pkg config)`, `("lv2" ,lv2)`…) are totally unneeded for as far as I understand and could be simplified as `(list pkg-config lv2 mesa)`.
It's just that I practiced to use the old way for native-inputs. Many packages require to do so, for example `("glib:bin" ,glib "bin")` cannot be declared as somethig like `(list glib)` (as far as I know). It's just that mejority of the packages I defined had required such type of native-inputs, so I practiced it that way.
Toggle quote (1 lines)
> I'm also a bit curious as to why tests need to be explicitly deactivated in `sorcer`, does running the default cmake command to test the project result in a failure, not just a NOP ?
`sorcer` was initially not packaged by me. It was failing to build, so I updated it to the most recent commit and removed the commands in the arguments which are no longer required in this commit. Disabling the tests is as it was before, as in the comment it says that tests are not defined in the git repository.

I will improve the patches, fixing mistakes, and then resend the patches.
Thank you.
Attachment: file
M
M
Maxime Devos wrote on 28 Jun 2022 14:40
e1c7ff8c626d843f8e9a712a9d9a26ade1d55162.camel@telenet.be
Sughosha via Guix-patches via schreef op di 28-06-2022 om 08:30
[+0000]:
Toggle quote (3 lines)
> glib:bin" ,glib "bin")` cannot be declared as somethig like `(list
> glib)` (as far as I know).

You can do (list `(,glib "bin") hello other-package etc...) (untested).

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrr2pBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7nGPAQC+JNiphGL13sddUVprCPuWgRwb
yHoNGgILc/I9ayKt/QEAhKDreUGY/HBzWZWodl2YHcPrQBmx7mcV/LJ3OeTsnQw=
=Jobn
-----END PGP SIGNATURE-----


S
S
Sughosha wrote on 1 Jul 2022 18:04
(name . 56140@debbugs.gnu.org)(address . 56140@debbugs.gnu.org)
13jWUzKYzvnNJSPT4j4sLXsTfHTy3h0nSlS818C5tx7EJH34exAm52jwTNPXl6wYWNvGemYmXfsNxgS0CNaJfuaUdlVAkBpePK8dlT8TfIA=@proton.me
Fixed mistakes and improved.
From d096d031893b8c1bfcf2450cbbbb76f8d73d16e4 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Fri, 1 Jul 2022 17:53:18 +0200
Subject: [PATCH 1/4] gnu: sorcer: Update to 1.1.3-6.cc7f6f5.

* gnu/packages/music.scm (sorcer): Update to 1.1.3-6.cc7f6f5.

This update fixes the building of the package.
---
gnu/packages/music.scm | 65 ++++++++++++++++++------------------------
1 file changed, 28 insertions(+), 37 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e0522e40f5..4e5c8bd081 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5056,44 +5056,35 @@ (define-public patchmatrix
(license license:artistic2.0)))
(define-public sorcer
- (package
- (name "sorcer")
- (version "1.1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openAVproductions/"
- "openAV-Sorcer/archive/release-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "07iyqj28wm0xc4arrq893bm12xjpz65db7ynrlmf6w8krg8wjmd0"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-architecture-specific-flags
- (lambda _
- (substitute* "CMakeLists.txt"
- (("-msse2 -mfpmath=sse") ""))
- #t))
- (add-after 'unpack 'build-faust-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "faust"
- (delete-file "main.cpp")
- (invoke "faust" "-i"
- "-a" "lv2synth.cpp"
- "-o" "main.cpp" "main.dsp")))))))
- (inputs
- (list boost lv2 ntk))
- (native-inputs
- (list faust pkg-config))
- (home-page "http://openavproductions.com/sorcer/")
- (synopsis "Wavetable LV2 plugin synth")
- (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
+ (let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
+ (package
+ (name "sorcer")
+ (version (git-version "1.1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/openAVproductions/openAV-Sorcer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ryaglp2pzln2bm0pwc5p9lb2nk0x4wmrs4c4cp6d2m2hhk82yk7"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'remove-architecture-specific-flags
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("-msse2 -mfpmath=sse") "")) #t))))) ;no tests included
+ (inputs (list boost lv2 ntk))
+ (native-inputs (list faust pkg-config))
+ (home-page "http://openavproductions.com/sorcer/")
+ (synopsis "Wavetable LV2 plugin synth")
+ (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
the electronic or dubstep genre.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public sonivox-eas
(package
--
2.36.1
From 89d254e0655754f72ef41660f063e8aafe9ac0ad Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Fri, 1 Jul 2022 17:53:59 +0200
Subject: [PATCH 2/4] gnu: Add fabla.

* gnu/packages/music.scm (fabla): New variable.
---
gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4e5c8bd081..1b87675a4a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5055,6 +5055,33 @@ (define-public patchmatrix
OSC connections.")
(license license:artistic2.0)))
+(define-public fabla
+ (let ((revision "17") (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
+ (package
+ (name "fabla")
+ (version (git-version "1.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Fabla")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ybbzb86j1n5dfhzc6aa3cibkwi6q3x0c18b1w3anyibanmr1wmc"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs (list pkg-config lv2 mesa))
+ (inputs (list ntk cairomm libsndfile))
+ (home-page "http://openavproductions.com/fabla/")
+ (synopsis "Sampler LV2 plugin")
+ (description
+ "Fabla is an LV2 drum sampler plugin instrument. It is ideal for
+loading up your favorite sampled sounds and bashing away on a MIDI
+controller.")
+ (license license:gpl3))))
+
(define-public sorcer
(let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
(package
--
2.36.1
From 9ce850f5b65a6e49352f63c11443bc7090647e85 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Fri, 1 Jul 2022 17:54:41 +0200
Subject: [PATCH 3/4] gnu: Add luppp.

* gnu/packages/music.scm (luppp): New variable.
---
gnu/packages/music.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1b87675a4a..320a87f2c5 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5055,6 +5055,36 @@ (define-public patchmatrix
OSC connections.")
(license license:artistic2.0)))
+(define-public luppp
+ (let ((revision "29") (commit "23da1497f80dbace48b7807afd3570c57a4d5994"))
+ (package
+ (name "luppp")
+ (version (git-version "1.2.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Luppp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rjl7fwnqq1gxa3haw1z0p1mld23i194sc43m03h9isagkwxrx9d"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config cmake-minimal))
+ (inputs (list cairo
+ ntk
+ liblo
+ jack-1
+ libsndfile
+ libsamplerate))
+ (home-page "http://openavproductions.com/luppp/")
+ (synopsis "Live performance tool")
+ (description
+ "Luppp is a music creation tool, intended for live use. The focus is on
+real time processing and a fast and intuitive workflow. With extensive MIDI
+mapping support, you can get looping just how you like!")
+ (license license:gpl3))))
+
(define-public fabla
(let ((revision "17") (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
(package
--
2.36.1
From 30e44861906ce8fc7c4213948234cf6334641307 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Fri, 1 Jul 2022 17:55:37 +0200
Subject: [PATCH 4/4] gnu: Add distrho-ports.

* gnu/packages/music.scm (distrho-ports): New variable.
---
gnu/packages/music.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 320a87f2c5..351b5760b3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6002,6 +6002,44 @@ (define-public mamba
ones.")
(license license:bsd-0)))
+(define-public distrho-ports
+ (let ((revision "611") (commit "d500be0794bba5dfa734806d8b0b1e6894ec04be"))
+ (package
+ (name "distrho-ports")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DISTRHO/DISTRHO-Ports")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a0i5ajqww8zpgrgpr1n4r2418l2sakvdz9y7pjwnx8168kmlmpl"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config cmake-minimal))
+ (inputs (list fftwf
+ alsa-lib
+ freetype
+ libx11
+ libxrender
+ libxext
+ libxcursor
+ mesa))
+ (home-page "https://github.com/DISTRHO/DISTRHO-Ports")
+ (synopsis "Linux audio plugins and LV2 ports")
+ (description
+ "This package contains GNU/Linux and LV2 ports of the following plugins:
+The Function, The Pilgrim, Dexed, dRowAudio plugins (Distortion, Distortion
+Shaper, Flanger, Reverb, Tremolo), DrumSynth, EasySSP, EQinox, HiReSam,
+JuceOPL, KlangFalter, LUFS Meter, LUFS Meter (Multichannel), Luftikus, Obxd,
+PitchedDelay, ReFine, StereoSourceSeperation, Swanky Amp, TAL plugins (Dub-3,
+Filter, Filter-2, Noize Mak3r, Reverb, Reverb-II, Reverb-III, Vocoder-II),
+Temper, Vex, Vitalium and Wolpertinger")
+ ;; This package consists of several plugins.
+ ;; Different copyrights and licenses apply to different plugins.
+ (license (list license:gpl2 license:lgpl3)))))
+
(define-public dpf-plugins
(package
(name "dpf-plugins")
--
2.36.1
R
R
Ricardo Wurmus wrote on 1 Jul 2022 19:29
[Patches] Add and update music packages
(address . 56140@debbugs.gnu.org)
87ilog68o3.fsf@elephly.net
Hi,

I slightly modified the patches as discussed on IRC.

I’m not sure about what to do with the last patch of the series, the one
adding distrho-ports. This package bundles a bunch of other libraries
and the license situation is not clear. I just spot checked one or two
plugins and their licenses do not appear in the license field so I’d
prefer to have some more eyes on this and see if things can be unbundled
some more.

Below is my modified package definition.

--
Ricardo
From be138ba5b9898654cf935f6828ae53a8211ff634 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Fri, 1 Jul 2022 17:55:37 +0200
Subject: [PATCH] gnu: Add distrho-ports.

* gnu/packages/music.scm (distrho-ports): New variable.
---
gnu/packages/music.scm | 63 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 63 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cc9bae5612..297748e39e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6019,6 +6019,69 @@ (define-public mamba
ones.")
(license license:bsd-0)))
+(define-public distrho-ports
+ (package
+ (name "distrho-ports")
+ (version "0.2021-03-15")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DISTRHO/DISTRHO-Ports")
+ ;; This commit corresponds to tag 2021-03-15
+ (commit "fe5bf2e87dd440ba98d3e8ac647b8518e2851f74")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a0i5ajqww8zpgrgpr1n4r2418l2sakvdz9y7pjwnx8168kmlmpl"))))
+ (build-system meson-build-system)
+ (inputs
+ (list fftwf
+ alsa-lib
+ freetype
+ libx11
+ libxrender
+ libxext
+ libxcursor
+ mesa))
+ (native-inputs
+ (list pkg-config
+ cmake-minimal))
+ (home-page "https://github.com/DISTRHO/DISTRHO-Ports")
+ (synopsis "Audio plugins and LV2 ports")
+ (description
+ "This package contains LV2 ports of the following plugins:
+@itemize
+@item The Function,
+@item The Pilgrim,
+@item Dexed,
+@item dRowAudio plugins (Distortion, Distortion Shaper, Flanger, Reverb,
+ Tremolo),
+@item DrumSynth,
+@item EasySSP,
+@item EQinox,
+@item HiReSam,
+@item JuceOPL,
+@item KlangFalter,
+@item LUFS Meter,
+@item LUFS Meter (Multichannel),
+@item Luftikus,
+@item Obxd,
+@item PitchedDelay,
+@item ReFine,
+@item StereoSourceSeperation,
+@item Swanky Amp,
+@item TAL plugins (Dub-3, Filter, Filter-2, Noize Mak3r, Reverb, Reverb-II,
+ Reverb-III, Vocoder-II),
+@item Temper,
+@item Vex,
+@item Vitalium, and
+@item Wolpertinger.
+@end itemize
+")
+ ;; This package consists of several plugins.
+ ;; Different copyrights and licenses apply to different plugins.
+ (license (list license:gpl2 license:lgpl3))))
+
(define-public dpf-plugins
(package
(name "dpf-plugins")
--
2.36.1
T
T
Thorsten Wilms wrote on 1 Jul 2022 20:05
(name . Ricardo Wurmus)(address . rekado@elephly.net)
20220701200505.9269398860c6390af3fd29d3@freenet.de
On Fri, 01 Jul 2022 19:29:17 +0200
Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (7 lines)
> I’m not sure about what to do with the last patch of the series, the one
> adding distrho-ports. This package bundles a bunch of other libraries
> and the license situation is not clear. I just spot checked one or two
> plugins and their licenses do not appear in the license field so I’d
> prefer to have some more eyes on this and see if things can be unbundled
> some more.

When I had a go at packaging distrho-ports, I took notes about the
licensing situation and asked about it on the list. Issues include
total lack of licensing information, licensing info only upstream,
upstream unavailable due to DMCA takedwon.


---
non-copyleft for drow (MIT). agpl3 for HiReSam.

Just no license info for arctican-function, artican-pilgrim and vex.

No license info found in the repo, but found by following the URL
given in each source/JucePluginCharacteristics.h:
- ports-legacy/HiReSam ->
GPL3
- ports-legacy/drowaudio-common ->
included Soundtouch, which I found no mention of in DISTRHO-Ports
sources. Also mentions separate license for FFTReal, which I also
see no mention of in DISTRHO-Ports sources.
- ports-legacy/easySSP ->
- ports/legacyluftikus ->
- ports-legacy/pitchedDelay ->
MIT. Strangely, this repo also includes PitchedDelay and Luftikus,
presented elsewhere as GPL2.
- ports-legacy/stereosourceseparation ->
unavailable due to DMCA takedown. According to falkTX, this is due
Steinberg having something against distribution of the VST2 SDK,
which is not included in the DISTRHO-Ports version.
GPL3.
- ports-legacy/wolpertinger -> https://tumbetoene.tuxfamily.org/
-> download readme: GPL2+.
---


--
Thorsten Wilms <t_w_@freenet.de>
?