[Patches] Add and update music packages
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Empty Message
From f8fd8c894b62080da31982431550946296e61407 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:32:28 +0200
Subject: [PATCH 4/4] gnu: Add fabla
* gnu/packages/music.scm: add fabla
---
gnu/packages/music.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a3710adf3a..9f992706b7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5081,6 +5081,30 @@ (define-public luppp
"Luppp is a music creation tool, intended for live use. The focus is on real time processing and a fast and intuitive workflow with MIDI mapping support.")
(license license:gpl3))))
+(define-public fabla
+ (let ((revision "18") (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
+ (package
+ (name "fabla")
+ (version (git-version "1.2.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Fabla")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ybbzb86j1n5dfhzc6aa3cibkwi6q3x0c18b1w3anyibanmr1wmc"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs `(("pkg-config" ,pkg-config) ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (inputs (list ntk cairomm libsndfile))
+ (home-page "http://openavproductions.com/fabla")
+ (synopsis "Drum sampler LV2 plugin")
+ (description "Fabla is a drum sampler LV2 plugin.")
+ (license license:gpl3))))
+
(define-public sorcer
(let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
(package
--
2.36.1
From 98d2fde325564c4a004613546d00a1c6e75502a8 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:31:39 +0200
Subject: [PATCH 2/4] gnu: Add distrho-ports
* gnu/packages/music.scm: add distrho-ports
---
gnu/packages/music.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 449d4ab250..e691d43d12 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5938,6 +5938,37 @@ (define-public mamba
ones.")
(license license:bsd-0)))
+(define-public distrho-ports
+ (let ((revision "602") (commit "5907a18cb50dd63d84d37776dfd8e8dcc7f3e378"))
+ (package
+ (name "distrho-ports")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DISTRHO/DISTRHO-Ports")
+ (commit commit)))
+ (sha256
+ (base32
+ "1ggl3piwb18gkz3glbqx5h1dcjcc5b9kpssd54fpxddaxagc4pwz"))))
+ (build-system meson-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config) ("cmake" ,cmake-minimal)))
+ (inputs (list fftwf
+ alsa-lib
+ freetype
+ libx11
+ libxrender
+ libxext
+ libxcursor
+ mesa))
+ (home-page "https://github.com/DISTRHO/DISTRHO-Ports")
+ (synopsis "Linux audio plugins and LV2 ports")
+ (description
+ "This package contains GNU/Linux and LV2 ports of the following plugins: The Function, The Pilgrim, Dexed, dRowAudio plugins (Distortion, Distortion Shaper, Flanger, Reverb, Tremolo), DrumSynth, EasySSP, EQinox, HiReSam, JuceOPL, KlangFalter, LUFS Meter, LUFS Meter (Multichannel), Luftikus, Obxd, PitchedDelay, ReFine, StereoSourceSeperation, Swanky Amp, TAL plugins (Dub-3, Filter, Filter-2, Noize Mak3r, Reverb, Reverb-II, Reverb-III, Vocoder-II), Temper, Vex, Vitalium and Wolpertinger")
+ ;; This package consists of several plugins.
+ ;; Different copyrights and licenses apply to different plugins.
+ (license (list license:gpl2 license:lgpl3)))))
+
(define-public dpf-plugins
(package
(name "dpf-plugins")
--
2.36.1
From ba87d4713da9cc26cc7279c56d287f385bf696bc Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:30:17 +0200
Subject: [PATCH 1/4] gnu: Update sorcer
* gnu/packages/music.scm: updating sorcer to its latest commit fixes its building
---
gnu/packages/music.scm | 59 ++++++++++++++++--------------------------
1 file changed, 22 insertions(+), 37 deletions(-)
Toggle diff (73 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cb176320..449d4ab250 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5055,44 +5055,29 @@ (define-public patchmatrix
(license license:artistic2.0)))
(define-public sorcer
- (package
- (name "sorcer")
- (version "1.1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openAVproductions/"
- "openAV-Sorcer/archive/release-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "07iyqj28wm0xc4arrq893bm12xjpz65db7ynrlmf6w8krg8wjmd0"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-architecture-specific-flags
- (lambda _
- (substitute* "CMakeLists.txt"
- (("-msse2 -mfpmath=sse") ""))
- #t))
- (add-after 'unpack 'build-faust-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "faust"
- (delete-file "main.cpp")
- (invoke "faust" "-i"
- "-a" "lv2synth.cpp"
- "-o" "main.cpp" "main.dsp")))))))
- (inputs
- (list boost lv2 ntk))
- (native-inputs
- (list faust pkg-config))
- (home-page "http://openavproductions.com/sorcer/")
- (synopsis "Wavetable LV2 plugin synth")
- (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
+ (let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
+ (package
+ (name "sorcer")
+ (version (git-version "1.1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/openAVproductions/openAV-Sorcer")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ryaglp2pzln2bm0pwc5p9lb2nk0x4wmrs4c4cp6d2m2hhk82yk7"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests included
+ (inputs (list boost lv2 ntk))
+ (native-inputs (list faust pkg-config))
+ (home-page "http://openavproductions.com/sorcer/")
+ (synopsis "Wavetable LV2 plugin synth")
+ (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
the electronic or dubstep genre.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public sonivox-eas
(package
--
2.36.1
From e695d37744c81963f22e93af9aafbadd38983b5a Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:32:11 +0200
Subject: [PATCH 3/4] gnu: Add luppp
* gnu/packages/music.scm: add luppp
---
gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e691d43d12..a3710adf3a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5054,6 +5054,33 @@ (define-public patchmatrix
OSC connections.")
(license license:artistic2.0)))
+(define-public luppp
+ (let ((revision "29") (commit "23da1497f80dbace48b7807afd3570c57a4d5994"))
+ (package
+ (name "luppp")
+ (version (git-version "1.2.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Luppp")
+ (commit commit)))
+ (sha256
+ (base32
+ "1rjl7fwnqq1gxa3haw1z0p1mld23i194sc43m03h9isagkwxrx9d"))))
+ (build-system meson-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config) ("cmake-minimal" ,cmake-minimal)))
+ (inputs (list cairo
+ ntk
+ liblo
+ jack-1
+ libsndfile
+ libsamplerate))
+ (home-page "http://openavproductions.com/luppp")
+ (synopsis "Live performance tool")
+ (description
+ "Luppp is a music creation tool, intended for live use. The focus is on real time processing and a fast and intuitive workflow with MIDI mapping support.")
+ (license license:gpl3))))
+
(define-public sorcer
(let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
(package
--
2.36.1