[PATCH] gnu: Add java-lambdatest

  • Open
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 20 Jun 2022 21:26
(address . guix-patches@gnu.org)
87r13j3zn1.fsf@gmail.com
Hello,

this patch adds "LambdaTest" under the name "java-lambdatest". [1]

"LambdaTest" package is required to pack "java-cmdoption" [2] package
properly.
Thanks,

- Artyom

References:
1. LambdaTest - Lambda-enabled functional testing API on top of JUnit
and TestNG
2. CmdOption is a simple annotation-driven command line parser toolkit
for Java 6+ applications that is configured through annotations.

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKwydIACgkQ6cWi2QiY
oC+Pbwf/U0VkLth9bQFarQGW8MIbWJ/XGbaNDfHy3G39t+hDcCxjY1SbJ1uFuZaF
tOi4tHv0XwA225spHWhjTdDyryXDscYjF9SzMg3ivK5V5il9f9t4h97Rk/BobYe7
psRJWN1qJF9ZaCyb6P0J9Oo1MyuV1OXFiqO+NvLWXCRQ3yok0P19Y55e2REa0OMB
229feREwdl8letEAlvLRR7p51DkJFKORSJ3I9JhZznTwbgN8pZhJhCaPb4KC63mf
4Kmkd0m55mmH5GCT3u/mtbHifNhQW2QKlViMaucERr+QdWZnxMiUpjGH5aPrHGTx
ErTYUoqpscjNIQHJFil/6PfSCbRVLw==
=Aahl
-----END PGP SIGNATURE-----

J
J
Julien Lepiller wrote on 3 Jul 2022 14:42
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 56112@debbugs.gnu.org)
20220703144237.211b3833@sybil.lepiller.eu
Thanks for the patch, and sorry for the late reply.

Here are a few remarks:

Le Mon, 20 Jun 2022 22:26:10 +0300,
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> a écrit :

Toggle quote (9 lines)
> From 2eff8e7fc79336f6eb7795fd942daeb07da63f00 Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Mon, 20 Jun 2022 22:06:28 +0300
> Subject: [PATCH] gnu: Add java-lambdatest
>
> * gnu/packages/java.scm (java-lambdatest): New variable.
> * gnu/packages/patches/java-lambdatest-fix.patch: Add to the
> repository.

that should be "New file."

Toggle quote (2 lines)
> * gnu/local.mk (dist_patch_DATA): Add 'java-lambdatest-fix.patch'.

and here: "Add it."

Toggle quote (39 lines)
> ---
> gnu/local.mk | 1 +
> gnu/packages/java.scm | 56
> +++++++++++++++++++ .../patches/java-lambdatest-fix.patch |
> 29 ++++++++++ 3 files changed, 86 insertions(+)
> create mode 100644 gnu/packages/patches/java-lambdatest-fix.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 197c8679eb..2f0a187125 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1321,6 +1321,7 @@ dist_patch_DATA =
> \
> %D%/packages/patches/java-commons-collections-fix-java8.patch \
> %D%/packages/patches/java-commons-lang-fix-dependency.patch \
> %D%/packages/patches/java-jeromq-fix-tests.patch \
> + %D%/packages/patches/java-lambdatest-fix.patch \
> %D%/packages/patches/java-openjfx-build-jdk_version.patch \
> %D%/packages/patches/java-powermock-fix-java-files.patch
> \ %D%/packages/patches/java-simple-xml-fix-tests.patch
> \ diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
> index 7b0507d93c..794ccf22f7 100644
> --- a/gnu/packages/java.scm
> +++ b/gnu/packages/java.scm
> @@ -14282,3 +14282,59 @@ The following TLA+ tools are available in
> this distribution: @item The PlusCal translator.
> @end itemize")
> (license license:expat))))
> +
> +(define-public java-lambdatest
> + (package
> + (name "java-lambdatest")
> + (version "0.7.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/lefou/LambdaTest")
> + (commit version)))

When adding a git source, you need to add this from to the origin
record:

(file-name (git-file-name name version))

This ensures that the source name is correlated with the package. So
when you change the version and forget to update the hash, it will fail
instead of successfully using the old version's source.

Toggle quote (10 lines)
> + (patches
> + (search-patches "java-lambdatest-fix.patch"))
> + (sha256
> + (base32
> +
> "172wz2cxrwganx0xwx395z627ph9b20hj8mw21fygq8hwcvmy94m"))))
> + (build-system ant-build-system)
> + (native-inputs (list openjdk11 java-logback-classic
> java-logback-core))

You don't need openjdk11 here. It's already added implicitely by #:jdk
below, and openjdk11 contains only the Java runtime, not the compiler.
You'd need (list openjdk11 "jdk").

Toggle quote (9 lines)
> + (inputs (list java-junit
> + java-slf4j-api
> + java-testng))
> + (arguments
> + `(#:jar-name "lambdatest.jar"
> + #:source-dir "src/main"
> + #:test-dir "src/test"
> + #:jdk ,openjdk11

Using openjdk11 here will create warnings in dependents I think. Are
you sure we really need to use it?

Toggle quote (13 lines)
> + #:phases (modify-phases %standard-phases
> + (replace 'check
> + (lambda _
> + (invoke "ant" "compile-tests")
> + (let ((tests (filter
> + (lambda (file-name)
> + ;; Remove non-working tests.
> + (not (string-contains file-name
> +
> "RuntimeTest")))
> + (find-files "build"
> ".*Test.class")))

This is not very encouraging. We're supposed to build the runtimes, yet
we remove all runtime tests? Do you know what's happening and why they
are failing? Did you still manage to run tests that use this package?

Toggle quote (11 lines)
> + (classpath (string-append
> + (getenv "CLASSPATH")
> + ":build/classes"
> + ":build/test-classes")))
> + (catch #t
> + (lambda _
> + (invoke "java"
> + "-cp" classpath
> + "org.testng.TestNG" "-testclass"
> + (string-join tests ",")))

I think TestNG will use an xml file if you provide it, though I don't
see one in the repo. Do you know how upstream runs their tests?

Toggle quote (9 lines)
> + (lambda (exception c)
> + ;; XXX: TestNG exits with exit code 2
> when some
> + ;; tests are skipped. Just ignore this.
> + (unless (= (invoke-error-exit-status c)
> 2)
> + (throw exception c))
> + #t))))))))

No need to end the phase in #t.

Toggle quote (5 lines)
> + (synopsis "Functional testing API on top of JUnit and TestNG")
> + (description "Lambda-enabled functional testing on top of JUnit
> and +TestNG.")

Description should contain full sentences.

Toggle quote (41 lines)
> + (license license:asl2.0)))
> diff --git a/gnu/packages/patches/java-lambdatest-fix.patch
> b/gnu/packages/patches/java-lambdatest-fix.patch new file mode 100644
> index 0000000000..e04ff0471f
> --- /dev/null
> +++ b/gnu/packages/patches/java-lambdatest-fix.patch
> @@ -0,0 +1,29 @@
> +From 49645c94fc8bdbea342d6f96d46e0405b81b874c Mon Sep 17 00:00:00
> 2001 +From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> +Date: Sun, 19 Jun 2022 23:11:42 +0300
> +Subject: [PATCH] test: Fix tests
> +
> +* src/test/java/de/tobiasroeser/lambdatest/AssertTest.java
> + (testAssertEqualsInteger): Fix a regex so it will match the actual
> test
> + output.
> +
> +---
> + src/test/java/de/tobiasroeser/lambdatest/AssertTest.java | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git
> a/src/test/java/de/tobiasroeser/lambdatest/AssertTest.java
> b/src/test/java/de/tobiasroeser/lambdatest/AssertTest.java +index
> fe2db12..5ef5ab3 100644 +---
> a/src/test/java/de/tobiasroeser/lambdatest/AssertTest.java ++++
> b/src/test/java/de/tobiasroeser/lambdatest/AssertTest.java +@@ -51,7
> +51,7 @@ public class AssertTest {
> + Assert.assertEquals(0, 0);
> + Assert.assertEquals(Integer.valueOf(0), 0);
> + Assert.assertEquals(0, Integer.valueOf(0));
> +- intercept(AssertionError.class, "\\QActual 0 is not
> equal to 1.\\E", () -> { ++
> intercept(AssertionError.class, "\\QActual false is not equal to
> true\\E", () -> {
> + Assert.assertEquals(0, 1);
> + });
> + intercept(AssertionError.class, "\\QActual 0 is not
> equal to 1.\\E", () -> { +--
> +2.25.1
> +
A
A
Artyom V. Poptsov wrote on 24 Jul 2022 10:22
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 56112@debbugs.gnu.org)
87k082ncm5.fsf@gmail.com
Hello.

Toggle quote (3 lines)
> Using openjdk11 here will create warnings in dependents I think. Are
> you sure we really need to use it?

Unfortunately when the JDK version is not specified I get errors like
this one during the "check" phase:

Toggle snippet (15 lines)
starting phase `check'
Buildfile: /tmp/guix-build-java-lambdatest-0.7.1.drv-0/source/build.xml

compile-tests:
[mkdir] Created dir: /tmp/guix-build-java-lambdatest-0.7.1.drv-0/source/build/test-classes
[javac] Compiling 13 source files to /tmp/guix-build-java-lambdatest-0.7.1.drv-0/source/build/test-classes
[javac] Note: Some input files use unchecked or unsafe operations.
[javac] Note: Recompile with -Xlint:unchecked for details.

BUILD SUCCESSFUL
Total time: 0 seconds
[TestNG] [ERROR]
An error occurred while instantiating class de.tobiasroeser.lambdatest.ExpectCollectionTest: org/slf4j/impl/StaticLoggerBinder has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0

- Artyom

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmLdAWIZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL/6JCACI8RlkQJKL4O6WRhQiOJdA
DpvBmtxMc67i7y7aRHBZisMRJG+d+BiNgX0hWHnzTpff3aKg0yCZh/nkh3ZL6iwF
+x79OSpO1ruSJLH2PFL67B/TLcz0GPS/89Ap6IfsB7/5tCXriIIls6MQne0mEHW8
a64DMO7nn2zdwJDj/04aDTILd/sN/6/+aDLWr8Xq3LRbUyHxOW2Oa6I/TXck7INA
n7XdaZcARzDhFp8LVuU64OsjFqq4kjx4zzHNC3CH4VGYC5obwM2iR7MHRhftZ2B8
sDyyNXy5TxOVK4IZggRYQlvpI2hsMWeQ5T5IKiwe1DcUk2vQ6XGV+lsaP3IM9CYz
=ZZry
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 24 Jan 13:49 +0100
[PATCH] gnu: Add java-lambdatest
(address . 56112@debbugs.gnu.org)
874jf2nbf9.fsf@gmail.com
Hi Artyom,

Is it still actual, let's prepare v2 for the next review round?

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmWxB2oACgkQdtcnv/Ys
0rXhuA//fniso/2zuZlWKYW1RqhHcdRPJlUbYM+FD+SQrDhqHooRgMjGB0RSog3H
gWdK1tQrJOvh8rFxbV0/JxZG0cdhA5g5kWHg0UstbdC+DiNhIe011zQwR9eeJjzt
fFUH2v/eyU/Ug2dnVEu1wDNYSMeAFR3tmodXzrUwDwuWRdL8VYPJPsRWoifvrYfE
vNw77f98gobGypcmx80F4mAbrK0QjPlcG0A5RpjGzypeAgUgSzphA3qyx6IamtFu
hxHrMSAlyDHeZKdAwZITIfhg8a1DOURGXcE4PwqT80G00HUFEF8R93cEVeuyE4zg
DQonDM4GEt5tnh2VX/rXN1at1AlG1Ys9c/mGM2e7dle+zUMC9oIkJam7D45BjzXa
xz838MuiT6/GOOExct4HX+H11tvLVbRN0t3/sFrSpuuVERdbceShubr/EqkC6wTt
JFhNjE+aaxjUuujsYedECcXvOkccTDcjDndqCL34fIvUjgU+Jry96zLbZRqC2qZM
JTMSYzK/7zwin2ZQiMjI+Ndm5DIFsIiKBpq0Qz+JzwtSYJHYye33b7G1uRufTRRH
5H9eY3xTTde8I5IcG10zvdmFUSZi+Jieyi5drL2+mdYPI997K2WwWb8I5pPouQBT
mqtbuvie9w0eku30zHKWyDE+fzwU22hfrWu0rLw45YVFDmbzUr0=
=nLSM
-----END PGP SIGNATURE-----

?