[PATCH] gnu: playerctl: update to 2.4.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jose G Perez Taveras
  • Christopher Baines
Owner
unassigned
Submitted by
Jose G Perez Taveras
Severity
normal
J
J
Jose G Perez Taveras wrote on 20 Jun 2022 19:05
(address . guix-patches@gnu.org)(name . Jose G Perez Taveras)(address . josegpt27@gmail.com)
20220620170517.18322-1-josegpt27@gmail.com
Hello,

Here is an update to playerctl to 2.4.1 and fixed dependencies.
It uses `dbus-launch' to start a new daemon.

This is my first time sending a patch, I would be very happy if you
could point me out to anything I should know.

Thank you,
josegpt

---
gnu/packages/music.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cb176320..86a1d64ff9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5562,7 +5563,7 @@ (define-public pragha
(define-public playerctl
(package
(name "playerctl")
- (version "2.2.1")
+ (version "2.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5571,14 +5572,15 @@ (define-public playerctl
(file-name (git-file-name name version))
(sha256
(base32
- "17hi33sw3663qz5v54bqqil31sgkrlxkb2l5bgqk87pac6x2wnbz"))))
+ "0ij065blj3h5v6iivvpmgh1095vicj1nc7hp1nhlhpqagd98l89s"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dintrospection=false" "-Dgtk-doc=false")))
- (inputs (list python-pygobject))
+ `(#:configure-flags '("-Dgtk-doc=false")))
(native-inputs
`(("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("gobject-introspection" ,gobject-introspection)))
+ (propagated-inputs (list dbus))
(synopsis "Control MPRIS-supporting media player applications")
(description
"Playerctl is a command-line utility and library for controlling media
--
2.36.1
C
C
Christopher Baines wrote on 21 Jun 2022 13:29
(name . Jose G Perez Taveras)(address . josegpt27@gmail.com)
87v8su1cd4.fsf@cbaines.net
Jose G Perez Taveras <josegpt27@gmail.com> writes:

Toggle quote (8 lines)
> Hello,
>
> Here is an update to playerctl to 2.4.1 and fixed dependencies.
> It uses `dbus-launch' to start a new daemon.
>
> This is my first time sending a patch, I would be very happy if you
> could point me out to anything I should know.

Hi Jose,

Thanks for the patch.

Toggle quote (2 lines)
> + (propagated-inputs (list dbus))

The addition of dbus as a propagated input was the only thing that stood
out to me.

If playerctl does call out to dbus-launch, then patching the source to
refer to the specific /gnu/store/...-dbus/.../dbus-launch binary would
be the nicest approach, since that would avoid propagating dbus.

Is it necessary to propagate the dbus package, and if so, what doesn't
work if you don't?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmKxrCdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xeo4xAAl744k19cl/7DYycLOQ5O5fPbGb5duDU7
LksXyKyFHQ8BtJpVOLd1nk0Bkfi56mHgMUdMl5ruhuzlAtvr+/zakiP1Bky5URvo
9+zdDI5XNyDd9Ty9d69x+0bv6HjvResVQ5ETG1wABPjgZOg84Mhcd5209fPhkXKK
je7loIfyMbF1wElcUi7JkhSkJYZaaG+zSL3e46G6yc1WTHbg0Qwt0WqliFBkM1rz
XEuzBCsLZxi8njlHp88F2QKLVvnyy2NQFpcIY6rSVpEwtPQ8AmOyBsZjhP4gabDz
A7SBzAUMiY6AX/ktuzwqdVkRe7ZvmC+iZg86vUwr0peqzteyjgYTNHF1qTnCI+SV
+UCRGsglS8dtR5zo4O9x50K92VVql9706/7ScCp89P5nsxiQDxCnZ/qsvTbFm3eH
bMBBCZmZeLXqbCmnXt/9QU5RsLZfBEjzLLriCLhgrss0ToKPBI0g9zesEE4ZozmV
d65uLM3Cq/arhVpE2+hDKspssfqFc9T7eWFQLpEqEujggeQpMi5GAOlQ4XxXlOgh
Egw4w3Sh092QxLW//kpnegA0FK6/DLwOjKATvpJi7WZhgtCxOEzfjE7gzEr3JdHv
Xh1ye+7DM78n+AWw5eeRXzFDyz0Qq7i1k/88qiKJCYg+/1JXlyK1eOtCNnAT/mzm
n61CtttXTN4=
=jVoT
-----END PGP SIGNATURE-----

J
J
Jose G Perez Taveras wrote on 21 Jun 2022 16:02
(name . Christopher Baines)(address . mail@cbaines.net)
87h74ep06p.fsf@gmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (34 lines)
> [[PGP Signed Part:Undecided]]
>
> Jose G Perez Taveras <josegpt27@gmail.com> writes:
>
>> Hello,
>>
>> Here is an update to playerctl to 2.4.1 and fixed dependencies.
>> It uses `dbus-launch' to start a new daemon.
>>
>> This is my first time sending a patch, I would be very happy if you
>> could point me out to anything I should know.
>
> Hi Jose,
>
> Thanks for the patch.
>
>> + (propagated-inputs (list dbus))
>
> The addition of dbus as a propagated input was the only thing that stood
> out to me.
>
> If playerctl does call out to dbus-launch, then patching the source to
> refer to the specific /gnu/store/...-dbus/.../dbus-launch binary would
> be the nicest approach, since that would avoid propagating dbus.
>
> Is it necessary to propagate the dbus package, and if so, what doesn't
> work if you don't?
>
> Thanks,
>
> Chris
>
> [[End of PGP Signed Part]]

Hello Christopher,

I kept on testing the patch. As you mentioned, propagating dbus is not
necessary for the package to work correctly.

Thank you for the feedback.

Best,
josegpt

Here's an updated version of the patch.

---
gnu/packages/music.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cb176320..2d0d582e6c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5562,7 +5563,7 @@ (define-public pragha
(define-public playerctl
(package
(name "playerctl")
- (version "2.2.1")
+ (version "2.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5571,14 +5572,14 @@ (define-public playerctl
(file-name (git-file-name name version))
(sha256
(base32
- "17hi33sw3663qz5v54bqqil31sgkrlxkb2l5bgqk87pac6x2wnbz"))))
+ "0ij065blj3h5v6iivvpmgh1095vicj1nc7hp1nhlhpqagd98l89s"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dintrospection=false" "-Dgtk-doc=false")))
- (inputs (list python-pygobject))
+ `(#:configure-flags '("-Dgtk-doc=false")))
(native-inputs
`(("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("gobject-introspection" ,gobject-introspection)))
(synopsis "Control MPRIS-supporting media player applications")
(description
"Playerctl is a command-line utility and library for controlling media

base-commit: d13ffd1580ec2253b6e05fb6300c3629aee893e3
--
2.36.1
J
J
Jose G Perez Taveras wrote on 28 Jun 2022 15:19
(name . Christopher Baines)(address . mail@cbaines.net)
878rphsz6a.fsf@gmail.com
Hello,

I would like to know if there are any updates in regards to this patch?

--
Best,

josegpt

Jose G Perez Taveras <josegpt27@gmail.com> writes:

Toggle quote (96 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> [[PGP Signed Part:Undecided]]
>>
>> Jose G Perez Taveras <josegpt27@gmail.com> writes:
>>
>>> Hello,
>>>
>>> Here is an update to playerctl to 2.4.1 and fixed dependencies.
>>> It uses `dbus-launch' to start a new daemon.
>>>
>>> This is my first time sending a patch, I would be very happy if you
>>> could point me out to anything I should know.
>>
>> Hi Jose,
>>
>> Thanks for the patch.
>>
>>> + (propagated-inputs (list dbus))
>>
>> The addition of dbus as a propagated input was the only thing that stood
>> out to me.
>>
>> If playerctl does call out to dbus-launch, then patching the source to
>> refer to the specific /gnu/store/...-dbus/.../dbus-launch binary would
>> be the nicest approach, since that would avoid propagating dbus.
>>
>> Is it necessary to propagate the dbus package, and if so, what doesn't
>> work if you don't?
>>
>> Thanks,
>>
>> Chris
>>
>> [[End of PGP Signed Part]]
>
> Hello Christopher,
>
> I kept on testing the patch. As you mentioned, propagating dbus is not
> necessary for the package to work correctly.
>
> Thank you for the feedback.
>
> Best,
> josegpt
>
> Here's an updated version of the patch.
>
> ---
> gnu/packages/music.scm | 11 ++++++-----
> 1 file changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 60cb176320..2d0d582e6c 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -48,6 +48,7 @@
> ;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
> ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
> +;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -5562,7 +5563,7 @@ (define-public pragha
> (define-public playerctl
> (package
> (name "playerctl")
> - (version "2.2.1")
> + (version "2.4.1")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -5571,14 +5572,14 @@ (define-public playerctl
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "17hi33sw3663qz5v54bqqil31sgkrlxkb2l5bgqk87pac6x2wnbz"))))
> + "0ij065blj3h5v6iivvpmgh1095vicj1nc7hp1nhlhpqagd98l89s"))))
> (build-system meson-build-system)
> (arguments
> - `(#:configure-flags '("-Dintrospection=false" "-Dgtk-doc=false")))
> - (inputs (list python-pygobject))
> + `(#:configure-flags '("-Dgtk-doc=false")))
> (native-inputs
> `(("glib:bin" ,glib "bin")
> - ("pkg-config" ,pkg-config)))
> + ("pkg-config" ,pkg-config)
> + ("gobject-introspection" ,gobject-introspection)))
> (synopsis "Control MPRIS-supporting media player applications")
> (description
> "Playerctl is a command-line utility and library for controlling media
>
> base-commit: d13ffd1580ec2253b6e05fb6300c3629aee893e3
> --
> 2.36.1
C
C
Christopher Baines wrote on 29 Jun 2022 00:03
(name . Jose G Perez Taveras)(address . josegpt27@gmail.com)(address . 56111-done@debbugs.gnu.org)
87tu841m4r.fsf@cbaines.net
Jose G Perez Taveras <josegpt27@gmail.com> writes:

Toggle quote (4 lines)
> Hello,
>
> I would like to know if there are any updates in regards to this patch?

I've gone ahead and pushed the updated patch as
aa565e7a10a3d8690a4296f8edf12abaa3c215c5.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmK7erRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdrNhAAspx/2q0ub1nGVyrOvzxT/hVl++IKMN4q
Io0UdG16HjJ8Xpq4Z0BZny2IIPAJ99X8Niskyy5rAFgawiVq2n0CK4YEjOt1MMFQ
avmjQbJMat8yfobfg65CGZvl7aZiKhbas2YYj6uje7n3mseHKkBXis+eDvz94qP9
l5L6l18q8qYUeKUBcWZDlYL9viA6+Kl7esM2/KcdXq7WPoo4lz+hL88/tsW7YlJD
/LlZ0Xg72/dLYjzTlv18S/Mbne+fhM+GZVTy0PNn/IlAkwLapdZfHVOcIOcJnHUN
04aHxIx3patzvPfOPV4MWaGcPwBYkxDfggqFBlmGFp5e+ytHZhgHI+cuKxIdExXn
zSh8nCR/iSLjySjXuDsAQOshT8gPl2I2ShApenrJ3Ti4AYY7YQjpzutvTlRhV2+G
/Q3b6zfl/2QbxEUeRxw0sc9CHMigP3doZ7fPmbgK7WSq+EZJL3haMgP29Af1XgAI
njsDF0S1JA6jPuCuh9rEM0gauGm4k88X016WE9ZabomLt3rXIj4uTHdN0w/nFONb
EysFIRTl/OXt6+Pzszwnpetl6HYs7Zbhj4hQFApq0WD/P/mrlCwbdPEMg4HrSBm+
pdIrtKM9Fr5fxKvYp76vfafikfx0KZZsj5vjlxf7DSqXc936bPH0NELAhjgwesL3
OAPCFZsbV1w=
=WrXa
-----END PGP SIGNATURE-----

Closed
?