[PATCH] gnu: Add r-arrayexpress.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220619223346.26238-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-arrayexpress): New variable.
---
gnu/packages/bioconductor.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..af486561e0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,31 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-arrayexpress
+ (package
+ (name "r-arrayexpress")
+ (version "1.56.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ArrayExpress" version))
+ (sha256
+ (base32
+ "0v2v7v0gim0bsg34ciplapz6mjih68yqhcgzdlhcyj2d6vrgiad5"))))
+ (properties `((upstream-name . "ArrayExpress")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-limma
+ r-oligo
+ r-xml))
+ (home-page "https://bioconductor.org/packages/ArrayExpress")
+ (synopsis "Building R objects from ArrayExpress datasets")
+ (description
+ "This package offers the possibility to access the ArrayExpress repository
+at @dfn{EBI} (European Bioinformatics Institute) and build Bioconductor data
+structures: @code{ExpressionSet}, @code{AffyBatch}, @code{NChannelSet}.")
+ (license license:artistic2.0)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: 73761d8049f483e6685c2c736872d0366e03238a
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56100-done@debbugs.gnu.org)
87pmdco3k3.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56100@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56100
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help