gnu: Add r-microbiome, r-ancombc.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
f929ac3e2f3e45e0a6d512b14fac8452@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 1/2] gnu: Add r-microbiome.
(address . 56098@debbugs.gnu.org)
20220619204201.18713-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-microbiome): New variable.
---
gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..54280a26f6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8100,6 +8100,44 @@ (define-public r-bumphunter
studies.")
(license license:artistic2.0)))
+(define-public r-microbiome
+ (package
+ (name "r-microbiome")
+ (version "1.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "microbiome" version))
+ (sha256
+ (base32
+ "1z9arkjp5xszlg07mzb4p163i74jfbd9p4gbwv5syivnpl040k12"))))
+ (properties `((upstream-name . "microbiome")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biostrings
+ r-compositions
+ r-dplyr
+ r-ggplot2
+ r-phyloseq
+ r-reshape2
+ r-rtsne
+ r-scales
+ r-tibble
+ r-tidyr
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "https://microbiome.github.io/microbiome/")
+ (synopsis "Tools for microbiome analysis")
+ (description
+ "The @code{microbiome} facilitates @code{phyloseq} exploration and analysis
+of taxonomic profiling data. This package provides tools for the manipulation,
+statistical analysis, and visualization of taxonomic profiling data. In addition
+to targeted case-control studies, the @code{microbiome} facilitates scalable
+exploration of population cohorts. This package supports the independent
+@code{phyloseq} data format and expands the available toolkit in order to
+facilitate the standardization of the analyses and the development of best
+practices.")
+ (license license:bsd-2)))
+
(define-public r-minfi
(package
(name "r-minfi")

base-commit: d6bd483cd53cedc8da39fcc6c419f7241080ed21
--
2.36.1
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 2/2] gnu: Add r-ancombc.
(address . 56098@debbugs.gnu.org)
20220619204201.18713-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-ancombc): New variable.
---
gnu/packages/bioconductor.scm | 46 +++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 54280a26f6..a9b19bfadd 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,52 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-ancombc
+ (package
+ (name "r-ancombc")
+ (version "1.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ANCOMBC" version))
+ (sha256
+ (base32
+ "1p9yryv85qk7m3hbflmpdffd3azpsifcw54x1rp8sb67yjmq3whq"))))
+ (properties `((upstream-name . "ANCOMBC")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-desctools
+ r-doparallel
+ r-dorng
+ r-dplyr
+ r-energy
+ r-foreach
+ r-hmisc
+ r-magrittr
+ r-mass
+ r-microbiome
+ r-nlme
+ r-nloptr
+ r-phyloseq
+ r-rdpack
+ r-rlang
+ r-tibble
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/FrederickHuangLin/ANCOMBC")
+ (synopsis "Analysis of compositions of microbiomes with bias correction")
+ (description
+ "@code{ANCOMBC} is a package containing @dfn{DA} (differential abundance)
+and correlation analyses for microbiome data. Specifically, the package includes
+@dfn{ANCOM-BC} (Analysis of Compositions of Microbiomes with Bias Correction) and
+@dfn{ANCOM} (Analysis of Composition of Microbiomes) for DA analysis, and
+@dfn{SECOM} (Sparse Estimation of Correlations among Microbiomes) for correlation
+analysis. Microbiome data are typically subject to two sources of biases:
+unequal sampling fractions (sample-specific biases) and differential sequencing
+efficiencies (taxon-specific biases). Methodologies included in the @code{ANCOMBC}
+package were designed to correct these biases and construct statistically
+consistent estimators.")
+ (license license:artistic2.0)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")
--
2.36.1
Ricardo Wurmus wrote 2 years ago
gnu: Add r-microbiome, r-ancombc.
(address . 56098-done@debbugs.gnu.org)
87r0xsmgc5.fsf@elephly.net
Applied and upgraded. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56098@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56098
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help