[PATCH 0/3] SQL language server

  • Done
  • quality assurance status badge
Details
4 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
  • muradm
  • Maxime Devos
Owner
unassigned
Submitted by
muradm
Severity
normal
M
M
muradm wrote on 19 Jun 2022 17:28
(address . guix-patches@gnu.org)
20220619152833.5071-1-mail@muradm.net
Following patches adds necessary packages for sqls.

muradm (3):
gnu: golang: Add go-github-com-gorilla-websocket 1.5.0.
gnu: golang: Add go-github-com-sourcegraph-jsonrpc2 0.1.0.
gnu: databases: Add sqls 0.2.18.

gnu/packages/databases.scm | 34 +++++++++++++++++++++++++++
gnu/packages/golang.scm | 47 ++++++++++++++++++++++++++++++++++++++
2 files changed, 81 insertions(+)

--
2.36.1
M
M
muradm wrote on 19 Jun 2022 17:34
[PATCH 2/3] gnu: golang: Add go-github-com-sourcegraph-jsonrpc2 0.1.0.
(address . 56096@debbugs.gnu.org)
20220619153453.5273-2-mail@muradm.net
* gnu/packages/golang.scm (go-github-com-sourcegraph-jsonrpc2): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b6960f2a26..614751e727 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9865,3 +9865,28 @@ (define-public go-github-com-gorilla-websocket
(synopsis "A fast, well-tested and widely used WebSocket implementation for Go.")
(description "Gorilla WebSocket is a Go implementation of the WebSocket protocol.")
(license license:bsd-2)))
+
+(define-public go-github-com-sourcegraph-jsonrpc2
+ (package
+ (name "go-github-com-sourcegraph-jsonrpc2")
+ (version "0.1.0")
+ (home-page "https://github.com/sourcegraph/jsonrpc2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dk0w32k96vxrwnmm24wqx337dn8ylch65qwrbc3wh7whw2xx71q"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/sourcegraph/jsonrpc2"))
+ (propagated-inputs
+ `(("go-github-com-daviddengcn-go-colortext" ,go-github-com-daviddengcn-go-colortext)
+ ("go-github-com-motemen-go-colorine" ,go-github-com-motemen-go-colorine)
+ ("go-github-com-gorilla-websocket" ,go-github-com-gorilla-websocket)))
+ (synopsis "Provides a client and server implementation of JSON-RPC 2.0")
+ (description
+ "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
+ (license license:expat)))
--
2.36.1
M
M
muradm wrote on 19 Jun 2022 17:34
[PATCH 3/3] gnu: databases: Add sqls 0.2.18.
(address . 56096@debbugs.gnu.org)
20220619153453.5273-3-mail@muradm.net
* gnu/packages/databases (sqls): New variable.
---
gnu/packages/databases.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 92ab94f453..a61d1d7c9c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -146,6 +147,7 @@ (define-module (gnu packages databases)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages syncthing)
#:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
@@ -4788,3 +4790,35 @@ (define-public sqlitebrowser
;; dual license
(list license:gpl3+
license:mpl2.0))))
+
+(define-public sqls
+ (package
+ (name "sqls")
+ (version "0.2.18")
+ (home-page "https://github.com/lighttiger2505/sqls")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13837v27avdp2nls3vyy7ml12nj7rxragchwf92adn10ffp4aj6c"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/lighttiger2505/sqls"))
+ (native-inputs
+ `(("go-github-com-go-sql-driver-mysql" ,go-github-com-go-sql-driver-mysql)
+ ("go-github-com-lib-pq" ,go-github-com-lib-pq)
+ ("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
+ ("go-github-com-olekukonko-tablewriter" ,go-github-com-olekukonko-tablewriter)
+ ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+ ("go-github-com-sourcegraph-jsonrpc2" ,go-github-com-sourcegraph-jsonrpc2)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)
+ ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+ (synopsis "SQL language server written in Go.")
+ (description "An implementation of the Language Server Protocol for SQL")
+ (license license:expat)))
--
2.36.1
M
M
muradm wrote on 19 Jun 2022 17:34
[PATCH 1/3] gnu: golang: Add go-github-com-gorilla-websocket 1.5.0.
(address . 56096@debbugs.gnu.org)
20220619153453.5273-1-mail@muradm.net
* gnu/packages/golang.scm (go-github-com-gorilla-websocket): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 296f0b8b07..b6960f2a26 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9843,3 +9844,24 @@ (define-public go-github-com-google-go-jsonnet
production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
+
+(define-public go-github-com-gorilla-websocket
+ (package
+ (name "go-github-com-gorilla-websocket")
+ (version "1.5.0")
+ (home-page "https://github.com/gorilla/websocket")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xrr6snvs9g1nzxxg05w4i4pq6k1xjljl5mvavd838qc468n118i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gorilla/websocket"))
+ (synopsis "A fast, well-tested and widely used WebSocket implementation for Go.")
+ (description "Gorilla WebSocket is a Go implementation of the WebSocket protocol.")
+ (license license:bsd-2)))
--
2.36.1
M
M
Maxime Devos wrote on 19 Jun 2022 19:07
Re: [bug#56096] [PATCH 3/3] gnu: databases: Add sqls 0.2.18.
58f8d4a88989ed4fcb9617812fbb4de77ec35b5d.camel@telenet.be
muradm schreef op zo 19-06-2022 om 18:34 [+0300]:
Toggle quote (12 lines)
> +    (native-inputs
> +     `(("go-github-com-go-sql-driver-mysql" ,go-github-com-go-sql-driver-mysql)
> +       ("go-github-com-lib-pq" ,go-github-com-lib-pq)
> +       ("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
> +       ("go-github-com-olekukonko-tablewriter" ,go-github-com-olekukonko-tablewriter)
> +       ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
> +       ("go-github-com-sourcegraph-jsonrpc2" ,go-github-com-sourcegraph-jsonrpc2)
> +       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
> +       ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
> +       ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)
> +       ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))

What's the reason to put these 'native-inputs'? These don't look like
test-only inputs or such to me ...

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYq9XzRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7v2tAP9q0FRUfVSXICmZkHpDoY9irPP5
AiKZv1Fe/ODNt8DYRAD/QrBxTC8E2vs3sDIaDj/8bAUga7+hMzX3dMxexdC2ggo=
=9VAe
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 19 Jun 2022 19:07
5256ffbd6810ac43d26ec737ab2f090c773cf749.camel@telenet.be
muradm schreef op zo 19-06-2022 om 18:34 [+0300]:
Toggle quote (12 lines)
> +    (native-inputs
> +     `(("go-github-com-go-sql-driver-mysql" ,go-github-com-go-sql-driver-mysql)
> +       ("go-github-com-lib-pq" ,go-github-com-lib-pq)
> +       ("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
> +       ("go-github-com-olekukonko-tablewriter" ,go-github-com-olekukonko-tablewriter)
> +       ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
> +       ("go-github-com-sourcegraph-jsonrpc2" ,go-github-com-sourcegraph-jsonrpc2)
> +       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
> +       ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
> +       ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)
> +       ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))

Can be simplified to (native-inputs (list go-github-...-this-package
go-github-...-that-package ...)).

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYq9X7xccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7qBXAQD4y+04OmNdEGWQYmIl9YOnKrlj
NQdxmwUjyTBZhIQStgD7B7oaRgXqxk3DBeMs+5Yt0TOa48eAivDzbQF/RugRFAE=
=gGo6
-----END PGP SIGNATURE-----


M
M
muradm wrote on 20 Jun 2022 06:22
[PATCH v2 1/3] gnu: golang: Add go-github-com-gorilla-websocket 1.5.0.
(address . 56096@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220620042239.16958-2-mail@muradm.net
* gnu/packages/golang.scm (go-github-com-gorilla-websocket): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 296f0b8b07..b6960f2a26 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9843,3 +9844,24 @@ (define-public go-github-com-google-go-jsonnet
production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
+
+(define-public go-github-com-gorilla-websocket
+ (package
+ (name "go-github-com-gorilla-websocket")
+ (version "1.5.0")
+ (home-page "https://github.com/gorilla/websocket")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xrr6snvs9g1nzxxg05w4i4pq6k1xjljl5mvavd838qc468n118i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gorilla/websocket"))
+ (synopsis "A fast, well-tested and widely used WebSocket implementation for Go.")
+ (description "Gorilla WebSocket is a Go implementation of the WebSocket protocol.")
+ (license license:bsd-2)))
--
2.36.1
M
M
muradm wrote on 20 Jun 2022 06:22
[PATCH v2 2/3] gnu: golang: Add go-github-com-sourcegraph-jsonrpc2 0.1.0.
(address . 56096@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220620042239.16958-3-mail@muradm.net
* gnu/packages/golang.scm (go-github-com-sourcegraph-jsonrpc2): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b6960f2a26..933cf25f2e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9865,3 +9865,29 @@ (define-public go-github-com-gorilla-websocket
(synopsis "A fast, well-tested and widely used WebSocket implementation for Go.")
(description "Gorilla WebSocket is a Go implementation of the WebSocket protocol.")
(license license:bsd-2)))
+
+(define-public go-github-com-sourcegraph-jsonrpc2
+ (package
+ (name "go-github-com-sourcegraph-jsonrpc2")
+ (version "0.1.0")
+ (home-page "https://github.com/sourcegraph/jsonrpc2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dk0w32k96vxrwnmm24wqx337dn8ylch65qwrbc3wh7whw2xx71q"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/sourcegraph/jsonrpc2"))
+ (propagated-inputs
+ (list
+ go-github-com-daviddengcn-go-colortext
+ go-github-com-motemen-go-colorine
+ go-github-com-gorilla-websocket))
+ (synopsis "Provides a client and server implementation of JSON-RPC 2.0")
+ (description
+ "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
+ (license license:expat)))
--
2.36.1
M
M
muradm wrote on 20 Jun 2022 06:22
[PATCH v2 0/3] Re: [bug#56096] [PATCH 3/3] gnu: databases: Add sqls 0.2.18.
(address . 56096@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220620042239.16958-1-mail@muradm.net
* No particular reason for native-inputs, copy paste typo, fixed
* inputs simplified as well

muradm (3):
gnu: golang: Add go-github-com-gorilla-websocket 1.5.0.
gnu: golang: Add go-github-com-sourcegraph-jsonrpc2 0.1.0.
gnu: databases: Add sqls 0.2.18.

gnu/packages/databases.scm | 35 +++++++++++++++++++++++++++
gnu/packages/golang.scm | 48 ++++++++++++++++++++++++++++++++++++++
2 files changed, 83 insertions(+)

--
2.36.1
M
M
muradm wrote on 20 Jun 2022 06:22
[PATCH v2 3/3] gnu: databases: Add sqls 0.2.18.
(address . 56096@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220620042239.16958-4-mail@muradm.net
* gnu/packages/databases (sqls): New variable.
---
gnu/packages/databases.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 92ab94f453..1c44b0c63e 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -146,6 +147,7 @@ (define-module (gnu packages databases)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages syncthing)
#:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
@@ -4788,3 +4790,36 @@ (define-public sqlitebrowser
;; dual license
(list license:gpl3+
license:mpl2.0))))
+
+(define-public sqls
+ (package
+ (name "sqls")
+ (version "0.2.18")
+ (home-page "https://github.com/lighttiger2505/sqls")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13837v27avdp2nls3vyy7ml12nj7rxragchwf92adn10ffp4aj6c"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/lighttiger2505/sqls"))
+ (inputs
+ (list
+ go-github-com-go-sql-driver-mysql
+ go-github-com-lib-pq
+ go-github-com-mattn-go-sqlite3
+ go-github-com-olekukonko-tablewriter
+ go-github-com-pkg-errors
+ go-github-com-sourcegraph-jsonrpc2
+ go-golang-org-x-crypto
+ go-github.com-mattn-go-runewidth
+ go-golang-org-x-xerrors
+ go-gopkg-in-yaml-v2))
+ (synopsis "SQL language server written in Go.")
+ (description "An implementation of the Language Server Protocol for SQL")
+ (license license:expat)))
--
2.36.1
L
L
Liliana Marie Prikler wrote on 20 Jun 2022 11:39
(name . Maxime Devos)(address . maximedevos@telenet.be)
6519dc387ba09433f83787277e256fa704efdbed.camel@ist.tugraz.at
Hi

Am Montag, dem 20.06.2022 um 07:22 +0300 schrieb muradm:
Toggle quote (22 lines)
> * gnu/packages/databases (sqls): New variable.
> ---
>  gnu/packages/databases.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 92ab94f453..1c44b0c63e 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -57,6 +57,7 @@
>  ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
>  ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
>  ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
> +;;; Copyright © 2022 muradm <mail@muradm.net>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -146,6 +147,7 @@ (define-module (gnu packages databases)
>    #:use-module (gnu packages sphinx)
>    #:use-module (gnu packages ssh)
>    #:use-module (gnu packages sqlite)
> +  #:use-module (gnu packages syncthing)
Why do we need to use-module syncthing here? Can this contribute
towards a cycle? Should the relevant go package perhaps be moved?


Cheers
M
M
muradm wrote on 20 Jun 2022 13:25
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)
87mte7tw44.fsf@muradm.net
Hi,

go-github-com-lib-pq originated from there.

--
muradm

Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> writes:

Toggle quote (34 lines)
> Hi
>
> Am Montag, dem 20.06.2022 um 07:22 +0300 schrieb muradm:
>> * gnu/packages/databases (sqls): New variable.
>> ---
>>  gnu/packages/databases.scm | 35
>> +++++++++++++++++++++++++++++++++++
>>  1 file changed, 35 insertions(+)
>>
>> diff --git a/gnu/packages/databases.scm
>> b/gnu/packages/databases.scm
>> index 92ab94f453..1c44b0c63e 100644
>> --- a/gnu/packages/databases.scm
>> +++ b/gnu/packages/databases.scm
>> @@ -57,6 +57,7 @@
>>  ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
>>  ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
>>  ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
>> +;;; Copyright © 2022 muradm <mail@muradm.net>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -146,6 +147,7 @@ (define-module (gnu packages databases)
>>    #:use-module (gnu packages sphinx)
>>    #:use-module (gnu packages ssh)
>>    #:use-module (gnu packages sqlite)
>> +  #:use-module (gnu packages syncthing)
> Why do we need to use-module syncthing here? Can this
> contribute
> towards a cycle? Should the relevant go package perhaps be
> moved?
>
>
> Cheers
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEESPY5lma9A9l5HGLP6M7O0mLOBeIFAmKwWSsACgkQ6M7O0mLO
BeKIKhAAzvJwqOogLNw2BtN1be90KucOIhqqIO0cG4DcYy4Zqfwj1rng7L+OhJCY
i0KhuS6SUS3tLpqblaxv/gNWzhSppw49rg++43rwd50/dgG55MuPE1wCVaN1g/j0
tOqPCRitmkzhrND6n0+AlW81pnlc/Zugu3xz8Ow/FWHJaDhK22lvrX9jaGd1EoPW
tbxQ21j9cwLjpMa3b0YA70jaeaFw2d7sKHb4SnxvdxUBPpbTagmJII5Uik5Tqw7T
+iGoAuCn3Y3RHq125zMJhrxR7lNdrkbSs+9/jCUjeAczPG+oNnkKDpVFY39c9ZPE
idvDm+U77HQpAz5+2/uMLYbXkYcpvMdghYuO6in7+t0F1iHwiYz7UF9FnbbBL05n
VVJ7Znda4ClcjEjmZ86pgj6rlze+lKDPmY3AUCd0hCMAmburysfq5rMvaQIlvwlX
ont1u4zjWHC3a16xDFGAW8Ase17+dwmkWF0sEhoIZGbtAswWc1x5wSodhkE4POIP
wMrzhg4cf+YykGRh3MIXVx59BhEnWt2EYmmd0UWmJE1WClGCG5ba1Eskc6NLovMJ
OS8g5ABJD9+WAe6mpCiIc+KYc2790g8GrkfTzIOaCNMeqqrpNdJ21AEltzCQOmdF
fGI55l265EaeClamytXOgcV6zy0yAosPL4zpbcrCJwH9WnPD3Hw=
=pAJY
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 2 Jul 2022 23:05
Re: bug#56096: [PATCH 0/3] SQL language server
(name . muradm)(address . mail@muradm.net)
87o7y71aza.fsf_-_@gnu.org
Hi,

muradm <mail@muradm.net> skribis:

Toggle quote (4 lines)
> gnu: golang: Add go-github-com-gorilla-websocket 1.5.0.
> gnu: golang: Add go-github-com-sourcegraph-jsonrpc2 0.1.0.
> gnu: databases: Add sqls 0.2.18.

I tweaked the synopsis and description as per our guidelines and ‘guix
lint’ warnings and applied them.

Thanks!

Ludo’.
Closed
?