(address . bug-guix@gnu.org)
I am using guix shell to create an isolated container, but using a
persistent home directory to preserve configuration and state for the
program in the container. Specifically, I am using (lightly
simplified; note that the user is elb and the manifest contains ONLY
syncthing):
CONTAINER_HOME=/path/to/persistent/home
MANIFEST=/path/to/manifest.scm
guix shell --container --network --no-cwd -P \
--share=$CONTAINER_HOME=/home/elb -- \
/bin/sh -c 'SSL_CERT_DIR="$HOME/.guix-profile/etc/ssl/certs" syncthing'
Because syncthing requires a certificate store, the easiest way to
configure that seemed to be through the profile /etc dir, which meant
using -P. The above command works, and works correctly, but only the
first time the profile is started.
On subsequent starts, guix complains that:
guix shell: error: cannot link profile: '/home/elb/.guix-profile' already exists within container
This is easily worked around by removing .guix-profile from the
--share-bound home directory before invoking guix shell.
It is not clear to me that this is a bug, but it was surprising. It
was also surprising that there was not an obvious way to simply
declare a persistent home directory for a container, although now that
I understand the `guix shell` command better, I find this less
surprising than I did when I was first exploring.
Ethan