[PATCH] gnu: grip: Update to 4.6.1 and use gexps.

  • Done
  • quality assurance status badge
Details
2 participants
  • Luis Henrique Gomes Higino
  • Christopher Baines
Owner
unassigned
Submitted by
Luis Henrique Gomes Higino
Severity
normal

Debbugs page

Luis Henrique Gomes Higino wrote 3 years ago
(address . guix-patches@gnu.org)(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)
20220617203334.16172-1-luishenriquegh2701@gmail.com
* gnu/packages/python-web.scm (grip): Update to 4.6.1 and use gexps.
---
Hi guix,

this patch fixes the build of the grip package by updating it and also rewrites its arguments using gexps.

gnu/packages/python-web.scm | 76 ++++++++++++++++++-------------------
1 file changed, 36 insertions(+), 40 deletions(-)

Toggle diff (93 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b4500c6d2f..7b07cb72d6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5176,50 +5176,46 @@ (define-public python-path-and-address
(license license:expat)))
(define-public grip
- ;; No release by upstream for quite some time, some bugs fixed since. See:
- ;; https://github.com/joeyespo/grip/issues/304
- (let ((commit "27a4d6d87ea1d0ea7f7f120de55baabee3de73e3"))
- (package
- (name "grip")
- (version (git-version "4.5.2" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/joeyespo/grip")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0kx5hgb3q19i4l18a4vqdq9af390xgpk88lp2ay75qi96k0dc68w"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-docopt
- python-flask
- python-markdown
- python-path-and-address
- python-pygments
- python-requests))
- (native-inputs
- (list python-pytest python-responses))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (setenv "PATH" (string-append
- (getenv "PATH") ":"
- (assoc-ref %outputs "out") "/bin"))
- (invoke "py.test" "-m" "not assumption"))))))
- (home-page "https://github.com/joeyespo/grip")
- (synopsis "Preview Markdown files using the GitHub API")
- (description "Grip is a command-line server application written in Python
+ (package
+ (name "grip")
+ (version "4.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joeyespo/grip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vhimd99zw7s1fihwr6yfij6ywahv9gdrfcf5qljvzh75mvzcwh8"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-docopt
+ python-flask
+ python-markdown
+ python-path-and-address
+ python-pygments
+ python-requests))
+ (native-inputs (list python-pytest python-responses))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PATH"
+ (string-append (getenv "PATH") ":"
+ #$output "/bin"))
+ (invoke "py.test" "-m" "not assumption")))))))
+ (home-page "https://github.com/joeyespo/grip")
+ (synopsis "Preview Markdown files using the GitHub API")
+ (description
+ "Grip is a command-line server application written in Python
that uses the GitHub Markdown API to render a local Markdown file. The styles
and rendering come directly from GitHub, so you'll know exactly how it will
appear. Changes you make to the file will be instantly reflected in the browser
without requiring a page refresh.")
- (license license:expat))))
+ (license license:expat)))
(define-public python-port-for
(package
--
2.36.1
Luis Henrique Gomes Higino wrote 3 years ago
[PATCH v2] gnu: grip: Update to 4.6.1 and use gexps.
(address . 56043@debbugs.gnu.org)(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)
20220618201127.24684-1-luishenriquegh2701@gmail.com
* gnu/packages/python-web.scm (grip): Update to 4.6.1 and use gexps.
---
I had forgot to add a copyright line in the previous version 😓.
gnu/packages/python-web.scm | 77 ++++++++++++++++++-------------------
1 file changed, 37 insertions(+), 40 deletions(-)

Toggle diff (101 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b4500c6d2f..9284c4dc42 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5176,50 +5177,46 @@ (define-public python-path-and-address
(license license:expat)))
(define-public grip
- ;; No release by upstream for quite some time, some bugs fixed since. See:
- ;; https://github.com/joeyespo/grip/issues/304
- (let ((commit "27a4d6d87ea1d0ea7f7f120de55baabee3de73e3"))
- (package
- (name "grip")
- (version (git-version "4.5.2" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/joeyespo/grip")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0kx5hgb3q19i4l18a4vqdq9af390xgpk88lp2ay75qi96k0dc68w"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-docopt
- python-flask
- python-markdown
- python-path-and-address
- python-pygments
- python-requests))
- (native-inputs
- (list python-pytest python-responses))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (setenv "PATH" (string-append
- (getenv "PATH") ":"
- (assoc-ref %outputs "out") "/bin"))
- (invoke "py.test" "-m" "not assumption"))))))
- (home-page "https://github.com/joeyespo/grip")
- (synopsis "Preview Markdown files using the GitHub API")
- (description "Grip is a command-line server application written in Python
+ (package
+ (name "grip")
+ (version "4.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joeyespo/grip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vhimd99zw7s1fihwr6yfij6ywahv9gdrfcf5qljvzh75mvzcwh8"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-docopt
+ python-flask
+ python-markdown
+ python-path-and-address
+ python-pygments
+ python-requests))
+ (native-inputs (list python-pytest python-responses))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PATH"
+ (string-append (getenv "PATH") ":"
+ #$output "/bin"))
+ (invoke "py.test" "-m" "not assumption")))))))
+ (home-page "https://github.com/joeyespo/grip")
+ (synopsis "Preview Markdown files using the GitHub API")
+ (description
+ "Grip is a command-line server application written in Python
that uses the GitHub Markdown API to render a local Markdown file. The styles
and rendering come directly from GitHub, so you'll know exactly how it will
appear. Changes you make to the file will be instantly reflected in the browser
without requiring a page refresh.")
- (license license:expat))))
+ (license license:expat)))
(define-public python-port-for
(package
--
2.36.1
Christopher Baines wrote 3 years ago
(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)(address . 56043-done@debbugs.gnu.org)
87czep1ank.fsf@cbaines.net
Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:

Toggle quote (6 lines)
> * gnu/packages/python-web.scm (grip): Update to 4.6.1 and use gexps.
> ---
> I had forgot to add a copyright line in the previous version 😓.
> gnu/packages/python-web.scm | 77 ++++++++++++++++++-------------------
> 1 file changed, 37 insertions(+), 40 deletions(-)

Thanks Luis, I've pushed this as b5c6062bcec9530a9c4044a1bd1091fdebf9bc74.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmK+tM9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfkwxAAmMf11lWg8yMiqBxvvSPD7KaBaPAQITUB
rlDLK+iZoevVqqDpu2oim0ZrZA/imXr5tVB/k7IVmtsp7nUT2l8BMLrLFaFjNNCY
Ik2TYJNyTUbU4AelTkIW+4xYdy/7GqLgCm4BIaJFW3GMYQe3TvE9hX5W2XiytgdX
1VZVwQtg8Vg/HFs6Op4kV0a3BWlePHdTyylTXuD39nVgmH5z/LflYCvwO0m4Wgrx
7HY55J8ydCbG1nASfdTrPNooMSWRfGE+JSvDvxoMDed74RIuRnX4BjycK4mtLmU5
a5q66Xc0TcnKsMKHFydQgBU1cuiOlSAQSA/n2U7oKJAXLZCLBTP/GbPAehRS77OU
U2A7GHfw7qSn2pvrMTRQ0o9EMGqObwPlH5FZAf1XAz6945y1PpkGJuf7Lb5aKCVH
AImacNpdbBAxi9dIBjUiqYDHfdj+J3tMW5kWfkmdPRz+NmQwgEzhasvdKYy4mOlR
lhwwsznk24LRcsTqq8lvluXBDrIYQZ+pUlZ9quK1/5xJTt4jI5CTYR7eai28bM2i
Hyp6wE7lru3Ky6J9EZGnb5QoOAUTTolAMw7LwT86U7XtIXOWqBQfNkEv4N5Fgkqb
LR6zNqavxU+CGG4XpO0mYun3/169k4kL79QBKqp99dqH2oUUXOWajkAQc24r/7Mo
J0pzcVIZU18=
=8Svc
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56043@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56043
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help