[PATCH] gnu: Add r-antiprofiles.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220617142415.11554-1-madalinionel.patrascu@mdc-berlin.de
Toggle diff (41 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..1eacd863de 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,32 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-antiprofiles
+ (package
+ (name "r-antiprofiles")
+ (version "1.36.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "antiProfiles" version))
+ (sha256
+ (base32
+ "1277kg5xpyb2yriyjy18p437q5lj22h4al7z7pygkzxzywxv9g40"))))
+ (properties `((upstream-name . "antiProfiles")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-locfit
+ r-matrixstats))
+ (home-page "https://github.com/HCBravoLab/antiProfiles")
+ (synopsis "Implementation of gene expression anti-profiles")
+ (description
+ "This package implements the gene expression anti-profiles method.
+Anti-profiles are a new approach for developing cancer genomic signatures that
+specifically take advantage of gene expression heterogeneity. They explicitly
+model increased gene expression variability in cancer to define robust and
+reproducible gene expression signatures capable of accurately distinguishing
+tumor samples from healthy controls.")
+ (license license:artistic2.0)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: d6bd483cd53cedc8da39fcc6c419f7241080ed21
--
2.36.1
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56040-done@debbugs.gnu.org)
87wncx6xy1.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (10 lines)
> diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
> index 1e87b190c2..1eacd863de 100644
> --- a/gnu/packages/bioconductor.scm
> +++ b/gnu/packages/bioconductor.scm
> @@ -2029,6 +2029,32 @@ (define-public r-aneufinder
> sequencing data.")
> (license license:artistic2.0)))
>
> +(define-public r-antiprofiles

Thanks. I applied it with a commit message.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56040@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56040
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help