[PATCH] gnu: Add r-annmap.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220617140558.10555-1-madalinionel.patrascu@mdc-berlin.de
Toggle diff (49 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..5b74118974 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,40 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-annmap
+ (package
+ (name "r-annmap")
+ (version "1.38.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "annmap" version))
+ (sha256
+ (base32
+ "0ywqbb8jia7rrkzcsf6a11kqf8dnx96z8n8xw7067mahycykbixv"))))
+ (properties `((upstream-name . "annmap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-biocgenerics
+ r-dbi
+ r-digest
+ r-genefilter
+ r-genomicranges
+ r-iranges
+ r-lattice
+ r-rmysql
+ r-rsamtools))
+ (home-page "https://github.com/cruk-mi/annmap")
+ (synopsis
+ "Genome annotation and visualisation for Affymetrix arrays and NGS analysis")
+ (description
+ "This package @code{annmap} provides annotation mappings for Affymetrix exon
+arrays and coordinate based queries to support deep sequencing data analysis.
+Database access is hidden behind the API which provides a set of functions such
+as @code{genesInRange()}, @code{geneToExon()}, @code{exonDetails()}, etc.
+Functions to plot gene architecture and BAM file data are also provided.")
+ (license license:gpl2)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: d6bd483cd53cedc8da39fcc6c419f7241080ed21
--
2.36.1
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56039-done@debbugs.gnu.org)
871qv58cj4.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (10 lines)
> diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
> index 1e87b190c2..5b74118974 100644
> --- a/gnu/packages/bioconductor.scm
> +++ b/gnu/packages/bioconductor.scm
> @@ -2029,6 +2029,40 @@ (define-public r-aneufinder
> sequencing data.")
> (license license:artistic2.0)))
>
> +(define-public r-annmap

Thanks. I applied it with a commit message.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56039@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56039
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help