[PATCH] gnu: Add r-anaquin.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220617094201.2256-1-madalinionel.patrascu@mdc-berlin.de
Toggle diff (45 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..2b7f736dfa 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,36 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-anaquin
+ (package
+ (name "r-anaquin")
+ (version "2.20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Anaquin" version))
+ (sha256
+ (base32
+ "1jgpnls2djl1yzvnk64qc83mljmlci7wflwkza3wr0sv6r47b0dd"))))
+ (properties `((upstream-name . "Anaquin")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-deseq2
+ r-ggplot2
+ r-knitr
+ r-locfit
+ r-plyr
+ r-qvalue
+ r-rocr))
+ (native-inputs (list r-knitr))
+ (home-page "https://www.sequinstandards.com/")
+ (synopsis "Statistical analysis of sequins")
+ (description
+ "The project is intended to support the use of @dfn{sequins}(synthetic
+sequencing spike-in controls) owned and made available by the Garvan Institute
+of Medical Research. The goal is to provide a standard open source library for
+quantitative analysis, modelling and visualization of spike-in controls.")
+ (license license:bsd-3)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb
--
2.36.1
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56035-done@debbugs.gnu.org)
87a69t8cki.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (10 lines)
> diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
> index 1e87b190c2..2b7f736dfa 100644
> --- a/gnu/packages/bioconductor.scm
> +++ b/gnu/packages/bioconductor.scm
> @@ -1987,6 +1987,36 @@ (define-public r-agimicrorna
> objects are used so that other packages could be used as well.")
> (license license:gpl3)))
>
> +(define-public r-anaquin

Thanks. I applied it with a commit message.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56035@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56035
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help