[PATCH] gnu: Add r-amaretto.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220617092929.353-1-madalinionel.patrascu@mdc-berlin.de
Toggle diff (67 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..a78ceb2de5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,58 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-amaretto
+ (package
+ (name "r-amaretto")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AMARETTO" version))
+ (sha256
+ (base32
+ "111dk19b9910icksyr592cvhc5gwvgknr5q4887j9yxbajd7hcmx"))))
+ (properties `((upstream-name . "AMARETTO")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocfilecache
+ r-callr
+ r-circlize
+ r-complexheatmap
+ r-curatedtcgadata
+ r-doparallel
+ r-dplyr
+ r-dt
+ r-foreach
+ r-ggplot2
+ r-glmnet
+ r-gridextra
+ r-httr
+ r-impute
+ r-knitr
+ r-limma
+ r-matrix
+ r-matrixstats
+ r-multiassayexperiment
+ r-rcpp
+ r-readr
+ r-reshape2
+ r-rmarkdown
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AMARETTO")
+ (synopsis "Regulatory network inference and driver gene evaluation")
+ (description
+ "This package @code{AMARETTO} represents an algorithm that integrates copy
+number, DNA methylation and gene expression data to identify a set of driver
+genes by analyzing cancer samples and connects them to clusters of co-expressed
+genes, which we define as modules. @code{AMARETTO} can be applied in a pancancer
+setting to identify cancer driver genes and their modules on multiple cancer
+sites. @code{AMARETTO} captures modules enriched in angiogenesis, cell cycle
+and EMT, and modules that accurately predict survival and molecular subtypes.
+This allows @code{AMARETTO} to identify novel cancer driver genes directing
+canonical cancer pathways.")
+ (license license:asl2.0)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb
--
2.36.1
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56034-done@debbugs.gnu.org)
87mtdu8dk1.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (10 lines)
> diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
> index 1e87b190c2..a78ceb2de5 100644
> --- a/gnu/packages/bioconductor.scm
> +++ b/gnu/packages/bioconductor.scm
> @@ -1987,6 +1987,58 @@ (define-public r-agimicrorna
> objects are used so that other packages could be used as well.")
> (license license:gpl3)))
>
> +(define-public r-amaretto

Applied (with a new commit message).

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56034@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56034
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help