[PATCH] gnu: Add r-amountain.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220617090920.32056-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-amountain): New variable.
---
gnu/packages/bioconductor.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..4fc7949c75 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,30 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-amountain
+ (package
+ (name "r-amountain")
+ (version "1.22.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AMOUNTAIN" version))
+ (sha256
+ (base32
+ "0vdfabsrisdd7qq28f5ivd0v8zz49szqn677i5lhwnlaix220c54"))))
+ (properties `((upstream-name . "AMOUNTAIN")))
+ (build-system r-build-system)
+ (inputs (list gsl))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AMOUNTAIN")
+ (synopsis "Modules for multilayer weighted gene co-expression networks")
+ (description
+ "This package provides a pure data-driven gene network, @dfn{WGCN}(weighted
+gene co-expression network) could be constructed only from expression profile.
+Different layers in such networks may represent different time points, multiple
+conditions or various species. @code{AMOUNTAIN} aims to search active modules
+in multi-layer WGCN using a continuous optimization approach.")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb
--
2.36.1
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56033-done@debbugs.gnu.org)
87r1368ei8.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-amountain): New variable.

Applied. Thanks for the patch!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56033@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56033
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help