Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioconductor.scm (r-alpine): New variable.
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
Toggle diff (55 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..e0797206f1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,46 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-alpine
+ (package
+ (name "r-alpine")
+ (version "1.22.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "alpine" version))
+ (sha256
+ (base32
+ "1nl1hxwakh5m9rqm3ksn2jzknsj9xnwl51bmc30knknm4q35wdv9"))))
+ (properties `((upstream-name . "alpine")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biostrings
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicfeatures
+ r-genomicranges
+ r-graph
+ r-iranges
+ r-rbgl
+ r-rsamtools
+ r-s4vectors
+ r-speedglm
+ r-stringr
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/alpine")
+ (synopsis "Modeling and correcting fragment sequence bias")
+ (description
+ "The package @code{alpine} helps to model bias parameters and then using
+those parameters to estimate RNA-seq transcript abundance. @code{Alpine} is a
+package for estimating and visualizing many forms of sample-specific biases that
+can arise in RNA-seq, including fragment length distribution, positional bias on
+the transcript, read start bias (random hexamer priming), and fragment GC-content
+(amplification). It also offers bias-corrected estimates of transcript abundance
+in @dfn{FPKM}(Fragments Per Kilobase of transcript per Million mapped reads). It
+is currently designed for un-stranded paired-end RNA-seq data.")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")
base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb
--
2.36.1