[PATCH] gnu: Add r-alphabeta.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220616163502.27554-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-alphabeta): New variable.
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..cd9923a946 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,46 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-alphabeta
+ (package
+ (name "r-alphabeta")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AlphaBeta" version))
+ (sha256
+ (base32
+ "1ikdrigma02gnl6ggrc89bjsiqmd7knpb9kw7nqyrdnv3qjd9iag"))))
+ (properties `((upstream-name . "AlphaBeta")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-data-table
+ r-dplyr
+ r-expm
+ r-ggplot2
+ r-gtools
+ r-igraph
+ r-optimx
+ r-plotly
+ r-stringr))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AlphaBeta")
+ (synopsis
+ "Estimating epimutation rates and spectra from DNA methylations in plants")
+ (description
+ "The package @code{AlphaBeta} is a computational method for estimating
+epimutation rates and spectra from high-throughput DNA methylation data in plants.
+The method has been specifically designed to:
+@itemize
+@item
+analyze @emph{germline} epimutations in the context of multi-generational mutation
+accumulation lines;
+@item
+analyze @emph{somatic} epimutations in the context of plant development and aging.
+@end itemize")
+ (license license:gpl3)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56023-done@debbugs.gnu.org)
87h6yoo2lz.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56023@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56023
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help