Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioconductor.scm (r-alevinqc): New variable.
---
gnu/packages/bioconductor.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..f5057ff362 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,40 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-alevinqc
+ (package
+ (name "r-alevinqc")
+ (version "1.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "alevinQC" version))
+ (sha256
+ (base32
+ "0g75qnz7ah0widdjn99lhvnacz38vgl9j86n65wyswsf413hz3bb"))))
+ (properties `((upstream-name . "alevinQC")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-cowplot
+ r-dplyr
+ r-dt
+ r-ggally
+ r-ggplot2
+ r-rcpp
+ r-rjson
+ r-rlang
+ r-rmarkdown
+ r-shiny
+ r-shinydashboard
+ r-tximport))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/csoneson/alevinQC")
+ (synopsis "Quality control reports for @code{Alevin} output")
+ (description
+ "The package @code{r-alevinqc} generates quality control reports summarizing
+the output from an @code{alevin} run. The reports can be generated as html or
+pdf files, or as shiny applications.")
+ (license license:expat)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")
base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb
--
2.36.1