gnu: Add r-nada, r-zcompositions, r-aldex2.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
c88b9d89c0af48c5816bfcef153381f3@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 2/3] gnu: Add r-zcompositions.
(address . 56021@debbugs.gnu.org)
20220616155721.23547-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-zcompositions): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 28cd2e7fad..945cb5bdce 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -836,6 +836,37 @@ (define-public r-dlm
known as Dynamic Linear Models.")
(license license:gpl2+)))
+(define-public r-zcompositions
+ (package
+ (name "r-zcompositions")
+ (version "1.4.0-1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "zCompositions" version))
+ (sha256
+ (base32
+ "1rrhja9iaq123r2gqw1bzrn1ri0s3z4wzq8p0sfcr1yb6pv13vik"))))
+ (properties `((upstream-name . "zCompositions")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-mass
+ r-nada
+ r-truncnorm))
+ (home-page "https://github.com/Japal/zCompositions")
+ (synopsis
+ "Treatment of zeros, left-censored and missing values in compositional data")
+ (description
+ "This package @code{zCompositions} is an @code{R} package for the imputation
+of left-censored data under a compositional approach. The implemented methods
+consider aspects of relevance for a compositional approach such as scale
+invariance, subcompositional coherence or preserving the multivariate relative
+structure of the data. Based on solid statistical frameworks, it comprises the
+ability to deal with single and varying censoring thresholds, consistent treatment
+of closed and non-closed data, exploratory tools, multiple imputation, @dfn{MCMC}
+(Markov Chain Monte Carlo), robust and non-parametric alternatives, and recent
+proposals for count data.")
+ (license license:gpl2+)))
+
(define-public r-zoo
(package
(name "r-zoo")
--
2.36.1
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 3/3] gnu: Add r-aldex2.
(address . 56021@debbugs.gnu.org)
20220616155721.23547-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-aldex2): New variable.
---
gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..3abd57359d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,48 @@ (define-public r-agimicrorna
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-aldex2
+ (package
+ (name "r-aldex2")
+ (version "1.28.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ALDEx2" version))
+ (sha256
+ (base32
+ "0xppx52sllbz4pli174422i4kkf37v0yl844088nbj3j9r6pfbj9"))))
+ (properties `((upstream-name . "ALDEx2")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-genomicranges
+ r-iranges
+ r-multtest
+ r-rfast
+ r-s4vectors
+ r-summarizedexperiment
+ r-zcompositions))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ggloor/ALDEx_bioc")
+ (synopsis
+ "Analysis Of differential abundance taking sample variation into account")
+ (description
+ "This package provides a differential abundance analysis for the comparison
+of two or more conditions. Useful for analyzing data from standard RNA-seq or
+meta-RNA-seq assays as well as selected and unselected values from in-vitro
+sequence selections. Uses a Dirichlet-multinomial model to infer abundance from
+counts, optimized for three or more experimental replicates. The method infers
+biological and sampling variation to calculate the expected false discovery
+rate, given the variation, based on a Wilcoxon Rank Sum test and Welch's t-test
+(via aldex.ttest), a Kruskal-Wallis test (via aldex.kw), a generalized linear
+model (via aldex.glm), or a correlation test (via aldex.corr). All tests report
+p-values and Benjamini-Hochberg corrected p-values. ALDEx2 also calculates
+expected standardized effect sizes for paired or unpaired study designs.")
+ ;; The code for the function "rdirichlet" which is from the "R" package
+ ;; "mc2d_0.1-14.tar.gz", which is denoted as GPL>=2, and where the tar-ball
+ ;; LICENSE specifies GPL-3.
+ (license (list license:agpl3+ license:gpl2+ license:gpl3))))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")
--
2.36.1
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 1/3] gnu: Add r-nada.
(address . 56021@debbugs.gnu.org)
20220616155721.23547-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-nada): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b326332bf6..28cd2e7fad 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27881,6 +27881,26 @@ (define-public r-nabor
to speed up repeated queries of the same set of target points.")
(license license:bsd-3)))
+(define-public r-nada
+ (package
+ (name "r-nada")
+ (version "1.6-1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "NADA" version))
+ (sha256
+ (base32
+ "0jp4mqr77cx7q5lff84s6wb0dwjy9mi0jyhbjc5fsx50bdczc3v7"))))
+ (properties `((upstream-name . "NADA")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-survival))
+ (home-page "https://cran.r-project.org/package=NADA")
+ (synopsis "Nondetects and data analysis for environmental data")
+ (description
+ "This package contains methods described by Dennis Helsel in his book
+@emph{Nondetects and Data Analysis: Statistics for Censored Environmental Data}.")
+ (license license:gpl2+)))
+
(define-public r-naturalsort
(package
(name "r-naturalsort")

base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb
--
2.36.1
Ricardo Wurmus wrote 2 years ago
gnu: Add r-nada, r-zcompositions, r-aldex2.
(address . 56021-done@debbugs.gnu.org)
87bkpn53x3.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56021@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56021
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help