[PATCH 1/3] gnu: Add python-geomet.

  • Done
  • quality assurance status badge
Details
One participant
  • Hartmut Goebel
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 15 Jun 2022 13:42
(address . guix-patches@gnu.org)
b9b1f63a3588156d5e2819bf11901a824d9e6ce2.1655293324.git.h.goebel@crazy-compilers.com
* gnu/packages/python-xyz.scm (python-geomet): New variable.
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f37ca731d5..67e919b1b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29508,3 +29508,23 @@ with it, and it also implements recommendations from the
and names, built from Unicode CLDR and the IANA subtag registry, if you
install @code{python-language-data}.")
(license license:expat)))
+
+(define-public python-geomet
+ (package
+ (name "python-geomet")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "geomet" version))
+ (sha256
+ (base32
+ "06rfvadx5dr5xrgsc5bsmqil9c9kff6i13xl988gy0gfg0cl2lnb"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-click python-six))
+ (home-page "https://github.com/geomet/geomet")
+ (synopsis "Convert GeoJSON to WKT/WKB (Well-Known Text/Binary) or
+GeoPackage Binary")
+ (description "This package provides utilities and functions for converting
+GeoJSON to WKT/WKB (Well-Known Text/Binary) or GeoPackage Binary, and vice
+versa. Extended WKB/WKT are also supported.")
+ (license license:asl2.0)))
--
2.30.4
H
H
Hartmut Goebel wrote on 15 Jun 2022 13:44
[PATCH 2/3] gnu: Add trytond-gis.
(address . 55994@debbugs.gnu.org)
30c3c3d661129ccc9a7603e1ac283767f65fe99d.1655293324.git.h.goebel@crazy-compilers.com
* gnu/packages/tryton.scm (trytond-gis): New variable.
---
gnu/packages/tryton.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7cbcc8e518..c105d4fe2d 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1747,6 +1747,26 @@ from the UNECE. Supported formats are:
@end itemize")
(license license:gpl3+)))
+(define-public trytond-gis
+ (package
+ (name "trytond-gis")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_gis" version))
+ (sha256
+ (base32 "1z6rvwyzisd62bmzhh1g56as7xyvchdsgj52w9q5x908k2jr4pl4"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "trytond_gis"))
+ (native-inputs (%standard-trytond-native-inputs))
+ (propagated-inputs (list python-geomet trytond))
+ (home-page "https://docs.tryton.org/projects/backend-gis")
+ (synopsis "Geographic Information System support from Tryton")
+ (description "The @emph{Trytond GIS} Tryton module adds GIS (Geographic
+information system) support to Tryton.")
+ (license license:gpl3+)))
+
(define-public trytond-incoterm
(package
(name "trytond-incoterm")
--
2.30.4
H
H
Hartmut Goebel wrote on 15 Jun 2022 13:44
[PATCH 3/3] gnu: Add trytond-google-maps.
(address . 55994@debbugs.gnu.org)
56ea1fd3f0ddfe27f61b53512664a33fda7bec63.1655293324.git.h.goebel@crazy-compilers.com
* gnu/packages/tryton.scm (trytond-google-maps): New variable.
---
gnu/packages/tryton.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c105d4fe2d..32f38d0892 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1767,6 +1767,27 @@ from the UNECE. Supported formats are:
information system) support to Tryton.")
(license license:gpl3+)))
+(define-public trytond-google-maps
+ (package
+ (name "trytond-google-maps")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_google_maps" version))
+ (sha256
+ (base32 "1wgcnl3r1017vicbf7rkcwv2ffrhaah90hcajn3i78bywjdag6nj"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "trytond_google_maps"))
+ (native-inputs (%standard-trytond-native-inputs))
+ (propagated-inputs (list trytond trytond-party))
+ (home-page "https://docs.tryton.org/projects/modules-google-maps")
+ (synopsis "Tryton module to link addresses to Google Maps")
+ (description "The @emph{Trytond Google Maps} Tryton module adds a new URL
+field on the party addresses. This link open the Google Maps page on the
+default browser with the map centered on the selected address.")
+ (license license:gpl3+)))
+
(define-public trytond-incoterm
(package
(name "trytond-incoterm")
--
2.30.4
H
H
Hartmut Goebel wrote on 15 Jun 2022 13:46
Re: bug#55994: Acknowledgement ([PATCH 1/3] gnu: Add python-geomet.)
(address . 55994@debbugs.gnu.org)
3d23531a-8611-7190-5e4e-bc36c30791c1@crazy-compilers.com
This adds two in Tryton 6.0 packages missing in Guix. Update to 6.2 anf
6.4 for whole Tryton will come soon. This series is to allow users to
have a complete (well, one other package still missing) Tryton 6.0
available.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
H
H
Hartmut Goebel wrote on 18 Jun 2022 18:06
[PATCH 4/4] gnu: Add trytond-stock-package-shipping-dpd.
(address . 55994@debbugs.gnu.org)
a74f30c3609860debc8f1d39575650302c324f9d.1655568254.git.h.goebel@crazy-compilers.com
* gnu/packages/tryton.scm (trytond-stock-package-shipping-dpd): New variable.
---
gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 32f38d0892..9810a90d02 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages pdf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
@@ -3812,6 +3813,31 @@ packaging information about customer and supplier return shipments.")
interact with shipping service providers.")
(license license:gpl3+)))
+(define-public trytond-stock-package-shipping-dpd
+ (package
+ (name "trytond-stock-package-shipping-dpd")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_package_shipping_dpd" version))
+ (sha256
+ (base32 "11jn2i7gkxj4nck5fkp0j8n8r6vhsv26rcnmmmmdh1iqji7cv8yf"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_package_shipping_dpd"))
+ (native-inputs (%standard-trytond-native-inputs))
+ (propagated-inputs
+ (list python-pypdf2 trytond trytond-party trytond-product trytond-stock
+ trytond-stock-package trytond-stock-package-shipping
+ trytond-stock-shipment-measurements python-zeep))
+ (home-page
+ "https://docs.tryton.org/projects/modules-stock-package-shipping-dpd")
+ (synopsis "DPD connector for the Tryton application platform")
+ (description "The @emph{Stock Package Shipping DPD} Tryton module allows
+you to generate the DPD label using the DPD webservices. DPD has many
+different web services, the module supports:")
+ (license license:gpl3+)))
+
(define-public trytond-stock-package-shipping-ups
(package
(name "trytond-stock-package-shipping-ups")
--
2.30.4
H
H
Hartmut Goebel wrote on 18 Jun 2022 18:08
Re: bug#55994: Acknowledgement ([PATCH 1/3] gnu: Add python-geomet.)
(address . 55994@debbugs.gnu.org)
606492ad-f829-6071-7ec8-da469bfa7189@crazy-compilers.com
Patch 4 is the last missing package in Tryton 6.0.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
H
H
Hartmut Goebel wrote on 4 Jul 2022 16:14
(address . 55994@debbugs.gnu.org)
3a72f03d-ded7-179e-01a1-901ccd74033a@crazy-compilers.com
Pushed as fdcd0133b2e452ce6e8bfbfc185cf3123c06cbfa

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
H
H
Hartmut Goebel wrote on 4 Jul 2022 16:17
(address . 55994-close@debbugs.gnu.org)
74af5f87-9e20-4b64-5939-864a038537b4@crazy-compilers.com

?