(address . guix-patches@gnu.org)
* gnu/packages/python-science.scm (python-pydicom): New variable.
---
gnu/packages/python-science.scm | 37 +++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (61 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 0684826a6c..08359515d5 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Wiktor ?elazny <wzelazny@vurv.cz>
;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,7 @@ (define-module (gnu packages python-science)
#:use-module (gnu packages cpp)
#:use-module (gnu packages databases)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages image)
#:use-module (gnu packages image-processing)
#:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
@@ -1367,3 +1369,38 @@ (define-public python-gpy
Python, from the Sheffield machine learning group. GPy implements a range of
machine learning algorithms based on GPs.")
(license license:bsd-3)))
+
+(define-public python-pydicom
+ (package
+ (name "python-pydicom")
+ (version "2.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pydicom/pydicom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18l26s53yf5j9yh2zwq83n74qq4f2iq0cfblamsw4y9k35l1c108"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ ;; 181 failed, 2235 pass. Pulls test datasets off the web, no-go for Guix
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (chdir "pydicom/tests")
+ (invoke "python3" "-m" "pytest")))))))
+ (native-inputs (list python-pytest))
+ (inputs (list gdcm libjpeg-turbo))
+ (propagated-inputs (list python-numpy python-pillow))
+ (home-page "https://github.com/pydicom/pydicom")
+ (synopsis "Pure Python package for reading and writing DICOM data")
+ (description "pydicom provides a pure Python package for reading and
+writing DICOM medical imaging data. It lets developers read, modify and write
+DICOM data in a pythonic way.")
+ (license license:expat)))
--
2.36.1