Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
Hello,
here's the patch that adds 'java-commons-text'. [1]
Unfortunately I had to disable tests as they require JUnit5 (which is
missing from GNU Guix at the moment.)
Also many thanks to Julien Lepiller who helped me to update
'java-commons-lang3' to 3.12.0, which in turn was required to package
'java-commons-text'.
- Artyom
References:
From a3c835fb370930a6bc99ae872bc7f4c541587189 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 13 Jun 2022 06:54:25 +0300
Subject: [PATCH] gnu: Add java-commons-text
* gnu/packages/java.scm (java-commons-text): New variable.
---
gnu/packages/java.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d2fbf840a0..1750dc662b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7893,6 +7893,44 @@ Commons CLI supports different types of options:
@item long options with single hyphen (ie. ant -projecthelp)
@end itemize
+This is a part of the Apache Commons Project.")
+ (license license:asl2.0)))
+
+(define-public java-commons-text
+ (package
+ (name "java-commons-text")
+ (version "1.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/commons/text/source/"
+ "commons-text-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "1k99ib2dxlqxb5y94kpzf4ix8xgxz1j3n9kq3ddssqqcccsp5ik2"))))
+ (build-system ant-build-system)
+ (arguments
+ (list #:jar-name
+ "java-commons-text.jar"
+ #:source-dir
+ "src/main/java"
+ #:test-dir
+ "src/test"
+ ;; XXX: Tests require JUnit5, namely 'org.junit.jupiter.api' module
+ ;; from JUnit5.
+ #:tests?
+ #f))
+ (inputs (list java-commons-lang3 java-commons-io))
+ ;; XXX: These are dependencies required for running the tests (which are
+ ;; disable until JUnit5 is available.)
+ ;; (native-inputs
+ ;; (list java-assertj
+ ;; java-junit))
+ (propagated-inputs (list apache-commons-parent-pom-52))
+ (home-page "https://commons.apache.org/text/")
+ (synopsis "Library focused on algorithms working on strings")
+ (description "Apache Commons Text is a library focused on algorithms
+working on strings.
+
This is a part of the Apache Commons Project.")
(license license:asl2.0)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKo1wAACgkQ6cWi2QiY
oC+3Ogf/XxJCo23x5FtcMOA0ilHEemwuTAiDpYgeWejdjofjx5RnjCA6XzB+62or
USXwFrb3YDLD51gOu+Cp2+K2bRVZJaOXF9VpJTSGhZFBPvsH3Pz7rkIRKnfxpqsc
Gb3gOlfg4y4Uac9CSft4nYnYbXPMi6QyAAMg8GnQIlZcF2BU4ZkOtHMdBjuoE15Q
NRpmG+Heyc0AReyxz5PTd/T26ciRojIzIpWnC/76h/ZjdFpI9NtiE70dpa9A4OSY
f1SrZXLuH1M1oybXuxY9C5uWqrL5nPZW57KkF/UwChZ6c0ow5sPvwjnLKktLbcYT
2h2GFJdhPr4yz5ryB5XQPkqn1D8iAw==
=xvYy
-----END PGP SIGNATURE-----