Lowering an <operating-system> is sensitive to (%current-system)

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
important

Debbugs page

Ludovic Courtès wrote 3 years ago
(address . bug-guix@gnu.org)
87fsk8ntq5.fsf@inria.fr
Consider this file:

Toggle snippet (6 lines)
(use-modules (guix))

(lambda ()
(lower-object (load "overdrive1.scm") "aarch64-linux"))

When ran on x86_64-linux, these two commands return different
derivations, contrary to what one might expect:

guix build -f that-file.scm -d --no-grafts -s aarch64-linux
guix build -f that-file.scm -d --no-grafts

That demonstrates that the result depends on (%current-system), even
though it shouldn’t because we’re explicitly specifying the system.

This has implications on ‘guix deploy’: if you try to deploy
aarch64-linux boxes from x86_64-linux (say), some of the derivations are
going to be for x86_64-linux instead of aarch64-linux, which can lead to
unbootable systems, as Ricardo reported a while back.

In particular, /gnu/store/…-activate.scm.drv (a direct dependency
/gnu/store/…-system.drv) is one of those derivations sensitive to
(%current-system).

Ludo’.
Ludovic Courtès wrote 3 years ago
control message for bug #55951
(address . control@debbugs.gnu.org)
87edzrohv4.fsf@gnu.org
severity 55951 important
quit
Ludovic Courtès wrote 3 years ago
Re: bug#55951: Lowering an <operating-system> is sensitive to (%current-system)
(address . 55951-done@debbugs.gnu.org)
87sfo6vpt5.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (13 lines)
> Consider this file:
>
> (use-modules (guix))
>
> (lambda ()
> (lower-object (load "overdrive1.scm") "aarch64-linux"))
>
> When ran on x86_64-linux, these two commands return different
> derivations, contrary to what one might expect:
>
> guix build -f that-file.scm -d --no-grafts -s aarch64-linux
> guix build -f that-file.scm -d --no-grafts

Fixed in 7046e777212233b89df68379c270b448c45195ce.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help