[PATCH 1/1] gnu: Add casacore

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
CAO+9K5qbn-OGDas-tUiia2maSNkyL_sDu2wk6TtSyb0Q8s2CNQ@mail.gmail.com
Hi Guix team!
Here is one more core Astronomical library (peeped at
https://blends.debian.org/astro/tasks/,which I use as guidiing for
packing to Guix)
Sharlatan Hellseher (1):
gnu: Add casacore
gnu/packages/astronomy.scm | 102 +++++++++++++++++++++++++++++++++++--
1 file changed, 97 insertions(+), 5 deletions(-)
base-commit: 0006a9a83a568715f7f30fbb9abb4c78da06a886
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Ludovic Courtès wrote 3 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 55935-done@debbugs.gnu.org)
87edzfvzzj.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (11 lines)
> From 916bde255b94eab85c10e55104b0e088781ef943 Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Sun, 12 Jun 2022 22:25:07 +0100
> Subject: [PATCH 1/1] gnu: Add casacore
>
> * gnu/packages/astronomy.scm (casacore): New variable.
> Modules sorted alphabetically to easy maintannce.
> ---
> gnu/packages/astronomy.scm | 102 +++++++++++++++++++++++++++++++++++--
> 1 file changed, 97 insertions(+), 5 deletions(-)

Applied with the changes below:

• use ‘this-package-input’ to refer to the same Python package that
appears in ‘inputs’;

• use ‘search-input-file’ rather than ‘which’ for “rm”, which is more
correct if we ever want to cross-compile it (it makes sure we pick
“rm” among the inputs rather than among native inputs);

• remove now-unneeded trailing #t from build phases;

• change license to ‘gpl2+’ because source file headers explicitly say
“or any later version”.

Thanks!

Ludo’.
Toggle diff (79 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a0de5a617f..61c10c985f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -130,11 +130,11 @@ (define-public casacore
(build-system cmake-build-system)
(arguments
(list
- ;; NOTE: (Sharlatan-20220611T213043+0100): There are multiple fails in
+ ;; Note: There are multiple failures in
;; tests which require additional measures data. They are
;; distributed via FTP without any license:
;; ftp://ftp.astron.nl/outgoing/Measures/
- ;; Check how to fix tests.
+ ;; TODO: Check how to fix tests.
#:tests? #f
#:parallel-build? #t
#:configure-flags
@@ -145,25 +145,27 @@ (define-public casacore
"-DUSE_OPENMP=OFF"
"-DUSE_THREADS=ON"
(string-append "-DDATA_DIR=" #$output "/data")
- (string-append "-DPYTHON3_EXECUTABLE=" #$python "/bin")
- (string-append "-DPYTHON3_INCLUDE_DIR=" #$python "/include")
- (string-append "-DPYTHON3_LIBRARY=" #$python "/lib"))
+ (string-append "-DPYTHON3_EXECUTABLE="
+ #$(this-package-input "python") "/bin")
+ (string-append "-DPYTHON3_INCLUDE_DIR="
+ #$(this-package-input "python") "/include")
+ (string-append "-DPYTHON3_LIBRARY="
+ #$(this-package-input "python") "/lib"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'set-env
(lambda _
(setenv "HOME" "/tmp")))
(add-after 'unpack 'use-absolute-rm
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "casa/OS/test/tFile.run"
- (("/bin/rm") (which "rm")))
- #t))
+ (("/bin/rm")
+ (search-input-file inputs "/bin/rm")))))
(add-after 'unpack 'use-absolute-python3
(lambda _
(substitute* "build-tools/casacore_floatcheck"
(("#!/usr/bin/env python")
- (string-append "#!" #$python "/bin/python3")))
- #t))
+ (string-append "#!" (which "python3"))))))
;; NOTE: (Sharlatan-20220611T200837+0100): Workaround for casacore
;; tests stuck with missing "qsub" issue.
;; https://github.com/casacore/casacore/issues/1122
@@ -171,8 +173,7 @@ (define-public casacore
(lambda _
(substitute* "build-tools/casacore_assay"
(("QSUBP=.*$") "QSUBP=\n")
- (("YODP=.*$") "YODP=\n"))
- #t)))))
+ (("YODP=.*$") "YODP=\n")))))))
(native-inputs
(list bison
boost
@@ -194,10 +195,10 @@ (define-public casacore
(synopsis "Suite of C++ libraries for radio astronomy data processing")
(description
"The casacore package contains the core libraries of the old
-@code{AIPS++/CASA} (Common Astronomy Software Application) package. This split
-was made to get a better separation of core libraries and applications.
-(CASA @url{https://casa.nrao.edu/}) is now built on top of Casacore.")
- (license license:gpl2)))
+AIPS++/CASA (Common Astronomy Software Application) package. This split was
+made to get a better separation of core libraries and applications.
+@url{https://casa.nrao.edu/, CASA} is now built on top of Casacore.")
+ (license license:gpl2+)))
(define-public cfitsio
(package
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55935@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55935
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help