Toggle diff (79 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a0de5a617f..61c10c985f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -130,11 +130,11 @@ (define-public casacore
(build-system cmake-build-system)
(arguments
(list
- ;; NOTE: (Sharlatan-20220611T213043+0100): There are multiple fails in
+ ;; Note: There are multiple failures in
;; tests which require additional measures data. They are
;; distributed via FTP without any license:
;; ftp://ftp.astron.nl/outgoing/Measures/
- ;; Check how to fix tests.
+ ;; TODO: Check how to fix tests.
#:tests? #f
#:parallel-build? #t
#:configure-flags
@@ -145,25 +145,27 @@ (define-public casacore
"-DUSE_OPENMP=OFF"
"-DUSE_THREADS=ON"
(string-append "-DDATA_DIR=" #$output "/data")
- (string-append "-DPYTHON3_EXECUTABLE=" #$python "/bin")
- (string-append "-DPYTHON3_INCLUDE_DIR=" #$python "/include")
- (string-append "-DPYTHON3_LIBRARY=" #$python "/lib"))
+ (string-append "-DPYTHON3_EXECUTABLE="
+ #$(this-package-input "python") "/bin")
+ (string-append "-DPYTHON3_INCLUDE_DIR="
+ #$(this-package-input "python") "/include")
+ (string-append "-DPYTHON3_LIBRARY="
+ #$(this-package-input "python") "/lib"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'set-env
(lambda _
(setenv "HOME" "/tmp")))
(add-after 'unpack 'use-absolute-rm
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "casa/OS/test/tFile.run"
- (("/bin/rm") (which "rm")))
- #t))
+ (("/bin/rm")
+ (search-input-file inputs "/bin/rm")))))
(add-after 'unpack 'use-absolute-python3
(lambda _
(substitute* "build-tools/casacore_floatcheck"
(("#!/usr/bin/env python")
- (string-append "#!" #$python "/bin/python3")))
- #t))
+ (string-append "#!" (which "python3"))))))
;; NOTE: (Sharlatan-20220611T200837+0100): Workaround for casacore
;; tests stuck with missing "qsub" issue.
;; https://github.com/casacore/casacore/issues/1122
@@ -171,8 +173,7 @@ (define-public casacore
(lambda _
(substitute* "build-tools/casacore_assay"
(("QSUBP=.*$") "QSUBP=\n")
- (("YODP=.*$") "YODP=\n"))
- #t)))))
+ (("YODP=.*$") "YODP=\n")))))))
(native-inputs
(list bison
boost
@@ -194,10 +195,10 @@ (define-public casacore
(synopsis "Suite of C++ libraries for radio astronomy data processing")
(description
"The casacore package contains the core libraries of the old
-@code{AIPS++/CASA} (Common Astronomy Software Application) package. This split
-was made to get a better separation of core libraries and applications.
-(CASA @url{https://casa.nrao.edu/}) is now built on top of Casacore.")
- (license license:gpl2)))
+AIPS++/CASA (Common Astronomy Software Application) package. This split was
+made to get a better separation of core libraries and applications.
+@url{https://casa.nrao.edu/, CASA} is now built on top of Casacore.")
+ (license license:gpl2+)))
(define-public cfitsio
(package