[PATCH WIP] gnu: Add lis.

  • Open
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 11 Jun 2022 09:49
(address . guix-patches@gnu.org)
6f63db3d7bd7d727b41675fce60dc82b62009f7e.camel@gmail.com
* gnu/packages/maths.scm (lis): New variable.
---
gnu/packages/maths.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 83f0a1810b..551b58e3f6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -934,6 +934,46 @@ (define-public lapack
(license (license:non-copyleft "file://LICENSE"
"See LICENSE in the distribution."))))
+(define-public lis
+ (package
+ (name "lis")
+ (version "2.0.34")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ssisc.org/lis/dl/lis-"
+ version ".zip"))
+ (sha256
+ (base32 "0wnsvy75rcxgy0afckyr9bi4hfrk0wsqczw5az95afd9j8ymj5pj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "--enable-fortran"
+ "--enable-f90"
+ "--enable-openmp"
+ "--enable-complex"
+ "--disable-sse2" ;; XXX: tuning
+ "--enable-shared")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (docdir (string-append out "/share/doc/lis-" #$version))
+ (mandir (string-append out "/share/man")))
+
+ (copy-recursively "doc/man" mandir)
+ ;; TODO: Build the manuals ourselves
+ (install-file "doc/lis-ug-en.pdf" docdir)
+ (install-file "doc/lis-ug-ja.pdf" docdir)))))))
+ (inputs (list openmpi))
+ (native-inputs (list gfortran unzip))
+ (home-page "https://www.ssisc.org/lis")
+ (synopsis "Solve discretized linear equations and eigenvalue problems")
+ (description "Lis is a parallel software library for solving discretized
+linear equations and eigenvalue problems that arise in the numerical solution
+of partial differential equations using iterative methods.")
+ (license license:bsd-3)))
+
(define-public clapack
(package
(name "clapack")
--
2.36.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 55901@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55901
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch