(address . guix-patches@gnu.org)(name . Remco van 't Veer)(address . remco@remworks.net)
* gnu/packages/iec16022.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/iec16022.scm | 56 +++++++++++++++++++++++++++++++++++++++
2 files changed, 57 insertions(+)
create mode 100644 gnu/packages/iec16022.scm
Toggle diff (76 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index abd6a30d66..8b3ad229aa 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -313,6 +313,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/image-processing.scm \
%D%/packages/image-viewers.scm \
%D%/packages/imagemagick.scm \
+ %D%/packages/iec16022.scm \
%D%/packages/inklingreader.scm \
%D%/packages/inkscape.scm \
%D%/packages/installers.scm \
diff --git a/gnu/packages/iec16022.scm b/gnu/packages/iec16022.scm
new file mode 100644
index 0000000000..b8b0fe0176
--- /dev/null
+++ b/gnu/packages/iec16022.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages iec16022)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (guix gexp)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages popt))
+
+(define-public iec16022
+ (package
+ (name "iec16022")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rdoeffinger/iec16022")
+ (commit "c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k9hfcjcm64w0n20979k2bx5lmxqhsh6df11qxyjdy4aq0l6i62z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'bootstrap 'disable-autogen-configure
+ (lambda _
+ (substitute* "autogen.sh"
+ (("^\\./configure") "# nop")))))))
+ (inputs (list popt))
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Command-line tool for producing Data Matrix barcodes")
+ (description
+ "Iec16022 is a non-interactive software package for producing Data Matrix
+barcodes as specified by ISO/IEC 16022. It produces ASCII, UTF-8, EPS, Bin,
+Stamp and PNG images.")
+ (home-page "https://github.com/rdoeffinger/iec16022")
+ (license gpl2+)))
--
2.36.1