[PATCH] gnu: Add iec16022

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Remco van 't Veer
Owner
unassigned
Submitted by
Remco van 't Veer
Severity
normal
R
R
Remco van 't Veer wrote on 10 Jun 2022 17:04
(address . guix-patches@gnu.org)(name . Remco van 't Veer)(address . remco@remworks.net)
20220610150448.9513-1-remco@remworks.net
* gnu/packages/iec16022.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/iec16022.scm | 56 +++++++++++++++++++++++++++++++++++++++
2 files changed, 57 insertions(+)
create mode 100644 gnu/packages/iec16022.scm

Toggle diff (76 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index abd6a30d66..8b3ad229aa 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -313,6 +313,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/image-processing.scm \
%D%/packages/image-viewers.scm \
%D%/packages/imagemagick.scm \
+ %D%/packages/iec16022.scm \
%D%/packages/inklingreader.scm \
%D%/packages/inkscape.scm \
%D%/packages/installers.scm \
diff --git a/gnu/packages/iec16022.scm b/gnu/packages/iec16022.scm
new file mode 100644
index 0000000000..b8b0fe0176
--- /dev/null
+++ b/gnu/packages/iec16022.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages iec16022)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (guix gexp)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages popt))
+
+(define-public iec16022
+ (package
+ (name "iec16022")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rdoeffinger/iec16022")
+ (commit "c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k9hfcjcm64w0n20979k2bx5lmxqhsh6df11qxyjdy4aq0l6i62z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'bootstrap 'disable-autogen-configure
+ (lambda _
+ (substitute* "autogen.sh"
+ (("^\\./configure") "# nop")))))))
+ (inputs (list popt))
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Command-line tool for producing Data Matrix barcodes")
+ (description
+ "Iec16022 is a non-interactive software package for producing Data Matrix
+barcodes as specified by ISO/IEC 16022. It produces ASCII, UTF-8, EPS, Bin,
+Stamp and PNG images.")
+ (home-page "https://github.com/rdoeffinger/iec16022")
+ (license gpl2+)))
--
2.36.1
M
M
Maxime Devos wrote on 10 Jun 2022 17:42
c4edaf1c963750b987899350f8f0f5e1e85f0cf6.camel@telenet.be
Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
Toggle quote (7 lines)
> +    (arguments
> +     '(#:phases (modify-phases %standard-phases
> +                  (add-before 'bootstrap 'disable-autogen-configure
> +                    (lambda _
> +                      (substitute* "autogen.sh"
> +                        (("^\\./configure") "# nop")))))))

recommend doing eliminating the ' in favour of 'list':

(arguments
(list #:phases
#~(modify-phases [...])))

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNmXBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7oLRAP9x/WIqkFLvVka2c1lgC1TwyKC9
NPQWKg/2EoxoLHgU0QD/ROYNX+XppYk91PGYfcIDAMmxgI/dVvjH/D2ZIPTE5As=
=G9sm
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 10 Jun 2022 17:45
5b6855219004c67fad36e4632103da4d90a4a948.camel@telenet.be
Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
Toggle quote (2 lines)
> * gnu/packages/iec16022.scm: New file.

We usually don't do per-package modules in Guix, maybe it would fit
next to the barcode packages in (gnu packages aidc)?

Though aidc refers to a particular company, so maybe rename (gnu
packages aidc) to (gnu packages barcodes) first?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNm/hccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7n25AP0Zz8Du8322vZVuPbvedaXiJb54
Ro4RwQyCF+Hk0wnkSgD/blI1anbQtQApcmJ26NEjtpR36unUuxYdRkKS+9du2QA=
=zu+S
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 10 Jun 2022 17:47
5d1299e0a814bb28befab7a8da4c8607271b5dc8.camel@telenet.be
Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
Toggle quote (4 lines)
> +     "Iec16022 is a non-interactive software package for producing Data Matrix
> +barcodes as specified by ISO/IEC 16022.  It produces ASCII, UTF-8, EPS, Bin,
> +Stamp and PNG images.")

Can be improved by using the @acronym TeXinfo markup for ISO, IEC,
ASCII, UTF-8, EPS and PNG. Or maybe that would be TMI here, dunno.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNnkhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7ti6AP9NVZVWy0f9ePCY8Xi8kKT5KxJc
pZMqfjhAqDhDPWai0QEA3yeZIOJ9ZpT3LgbkiOzUb7M1ZYTmXnhBGjMlzmeqQgA=
=5Mq5
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 10 Jun 2022 17:55
2dfe4787038a3c9b6fe21982aea621c4447eca75.camel@telenet.be
Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
Toggle quote (8 lines)
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/rdoeffinger/iec16022")
> +                    (commit "c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51")))
> +              (file-name (git-file-name name version))
> +              (sha256

Contains a bug: on line


, it allocates a buffer, which can fail (by returning NULL).
It then passes the possibly NULL buffer to compress2.
Also, it writes files without checking for errors
(e.g. EIO, ENOSPC or EDQUOT).

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqNpgBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7pszAQCsYco3BUJDp8BY9JYVeeTAx7K5
FW3ZjFjHoEZsIV1b8QEA+BtXLL1xZD7ipqe2m+5YCDgpD5Scw8RU/WmzdGSj4AQ=
=f+rl
-----END PGP SIGNATURE-----


R
R
Remco van 't Veer wrote on 10 Jun 2022 19:35
[PATCH v2] gnu: Add iec16022.
(address . 55891@debbugs.gnu.org)(name . Remco van 't Veer)(address . remco@remworks.net)
20220610173530.29920-1-remco@remworks.net
* gnu/packages/aidc.scm (iec16022): New variable.
---

Changes in this v2:
* Improved (arguments ..) style
* Moved definition to aidc.scm

gnu/packages/aidc.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 5482261a59..90341320b3 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -26,6 +26,7 @@ (define-module (gnu packages aidc)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (gnu packages autotools)
#:use-module (gnu packages check)
@@ -36,6 +37,7 @@ (define-module (gnu packages aidc)
#:use-module (gnu packages image)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages popt)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages pretty-print)
@@ -257,3 +259,34 @@ (define-public qrcodegen-cpp
project also offers Java, Javascript, Python, C, and Rust implementations.")
(home-page "https://www.nayuki.io/page/qr-code-generator-library")
(license license:expat)))
+
+(define-public iec16022
+ (package
+ (name "iec16022")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rdoeffinger/iec16022")
+ (commit "c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k9hfcjcm64w0n20979k2bx5lmxqhsh6df11qxyjdy4aq0l6i62z"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'disable-autogen-configure
+ (lambda _
+ (substitute* "autogen.sh"
+ (("^\\./configure") "# nop")))))))
+ (inputs (list popt))
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Command-line tool for producing Data Matrix barcodes")
+ (description
+ "Iec16022 is a non-interactive software package for producing Data Matrix
+barcodes as specified by ISO/IEC 16022. It produces ASCII, UTF-8, EPS, Bin,
+Stamp and PNG images.")
+ (home-page "https://github.com/rdoeffinger/iec16022")
+ (license license:gpl2+)))
--
2.36.1
R
R
Remco van 't Veer wrote on 10 Jun 2022 19:36
Re: [bug#55891] [PATCH] gnu: Add iec16022
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55891@debbugs.gnu.org)
87k09opgiu.fsf@remworks.net
2022/06/10 17:42, Maxime Devos:
Toggle quote (14 lines)
> Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
>> +    (arguments
>> +     '(#:phases (modify-phases %standard-phases
>> +                  (add-before 'bootstrap 'disable-autogen-configure
>> +                    (lambda _
>> +                      (substitute* "autogen.sh"
>> +                        (("^\\./configure") "# nop")))))))
>
> As per <https://logs.guix.gnu.org/guix/2022-06-09.log#194339>, I
> recommend doing eliminating the ' in favour of 'list':
>
> (arguments
> (list #:phases
> #~(modify-phases [...])))
done
R
R
Remco van 't Veer wrote on 10 Jun 2022 19:37
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55891@debbugs.gnu.org)
87fskcpghn.fsf@remworks.net
2022/06/10 17:45, Maxime Devos:

Toggle quote (12 lines)
> Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
>> * gnu/packages/iec16022.scm: New file.
>
> We usually don't do per-package modules in Guix, maybe it would fit
> next to the barcode packages in (gnu packages aidc)?
>
> Though aidc refers to a particular company, so maybe rename (gnu
> packages aidc) to (gnu packages barcodes) first?
>
> Greetings,
> Maxime.

Done, minus rename, I don't feel comfortable doing that.
R
R
Remco van 't Veer wrote on 10 Jun 2022 19:38
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55891@debbugs.gnu.org)
87bkv0pgfy.fsf@remworks.net
2022/06/10 17:47, Maxime Devos:

Toggle quote (8 lines)
> Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
>> +     "Iec16022 is a non-interactive software package for producing Data Matrix
>> +barcodes as specified by ISO/IEC 16022.  It produces ASCII, UTF-8, EPS, Bin,
>> +Stamp and PNG images.")
>
> Can be improved by using the @acronym TeXinfo markup for ISO, IEC,
> ASCII, UTF-8, EPS and PNG. Or maybe that would be TMI here, dunno.

TMI IMHO. No other package descriptions bother to use @acronym for
thing like ASCII, PNG etc.
R
R
Remco van 't Veer wrote on 10 Jun 2022 19:39
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55891@debbugs.gnu.org)
877d5opgd4.fsf@remworks.net
2022/06/10 17:55, Maxime Devos:
Toggle quote (17 lines)
> Remco van 't Veer schreef op vr 10-06-2022 om 17:04 [+0200]:
>> +    (source (origin
>> +              (method git-fetch)
>> +              (uri (git-reference
>> +                    (url "https://github.com/rdoeffinger/iec16022")
>> +                    (commit "c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51")))
>> +              (file-name (git-file-name name version))
>> +              (sha256
>
> Contains a bug: on line
>
> https://github.com/rdoeffinger/iec16022/blob/c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51/image.c#L284
>
> , it allocates a buffer, which can fail (by returning NULL).
> It then passes the possibly NULL buffer to compress2.
> Also, it writes files without checking for errors
> (e.g. EIO, ENOSPC or EDQUOT).
Good catch! I'll need to brush up on my C skills to fix these.
Meanwhile I'd like to ship including bugs, WDYT?
R
R
Remco van 't Veer wrote on 10 Jun 2022 19:45
[PATCH v3] gnu: Add iec16022.
(address . 55891@debbugs.gnu.org)(name . Remco van 't Veer)(address . remco@remworks.net)
20220610174536.30933-1-remco@remworks.net
* gnu/packages/aidc.scm (iec16022): New variable.
---
Changes in this v3:
* Added copyright line

gnu/packages/aidc.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 5482261a59..2847b591ab 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@ (define-module (gnu packages aidc)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (gnu packages autotools)
#:use-module (gnu packages check)
@@ -36,6 +38,7 @@ (define-module (gnu packages aidc)
#:use-module (gnu packages image)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages popt)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages pretty-print)
@@ -257,3 +260,34 @@ (define-public qrcodegen-cpp
project also offers Java, Javascript, Python, C, and Rust implementations.")
(home-page "https://www.nayuki.io/page/qr-code-generator-library")
(license license:expat)))
+
+(define-public iec16022
+ (package
+ (name "iec16022")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rdoeffinger/iec16022")
+ (commit "c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k9hfcjcm64w0n20979k2bx5lmxqhsh6df11qxyjdy4aq0l6i62z"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'disable-autogen-configure
+ (lambda _
+ (substitute* "autogen.sh"
+ (("^\\./configure") "# nop")))))))
+ (inputs (list popt))
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Command-line tool for producing Data Matrix barcodes")
+ (description
+ "Iec16022 is a non-interactive software package for producing Data Matrix
+barcodes as specified by ISO/IEC 16022. It produces ASCII, UTF-8, EPS, Bin,
+Stamp and PNG images.")
+ (home-page "https://github.com/rdoeffinger/iec16022")
+ (license license:gpl2+)))
--
2.36.1
M
M
Maxime Devos wrote on 10 Jun 2022 23:47
Re: [bug#55891] [PATCH] gnu: Add iec16022
(name . Remco van 't Veer)(address . remco@remworks.net)(address . 55891@debbugs.gnu.org)
b8d5a6ab5ec7285beee4d508ba81a6b953575e51.camel@telenet.be
Remco van 't Veer schreef op vr 10-06-2022 om 19:39 [+0200]:
Toggle quote (12 lines)
> > Contains a bug: on line
> >
> > https://github.com/rdoeffinger/iec16022/blob/c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51/image.c#L284
> >
> > , it allocates a buffer, which can fail (by returning NULL).
> > It then passes the possibly NULL buffer to compress2.
> > Also, it writes files without checking for errors
> > (e.g. EIO, ENOSPC or EDQUOT).
>
> Good catch!  I'll need to brush up on my C skills to fix these.
> Meanwhile I'd like to ship including bugs, WDYT?

I think it's ok, _if_ the bugs are eventually at least reported
upstream if we (i.e., you) cannot fix them timely (needs some contrived
circumstances to trigger the bug).

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYqO71BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hhVAP0f1nWtgvlJxqKWhf/0zMFpZvLl
kkI55vY7owbCHk4MggD9GzeIQgNr2CXdnKBT6VDj8c1JJmSlhi2aaBnlYgxtVAc=
=3HbY
-----END PGP SIGNATURE-----


R
R
Remco van 't Veer wrote on 11 Jun 2022 09:09
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55891@debbugs.gnu.org)
87mtejhe1d.fsf@remworks.net
2022/06/10 23:47, Maxime Devos:

Toggle quote (17 lines)
> Remco van 't Veer schreef op vr 10-06-2022 om 19:39 [+0200]:
>> > Contains a bug: on line
>> >
>> > https://github.com/rdoeffinger/iec16022/blob/c9a9fd926fd1e6cca9782fe3f8c2bab66010ca51/image.c#L284
>> >
>> > , it allocates a buffer, which can fail (by returning NULL).
>> > It then passes the possibly NULL buffer to compress2.
>> > Also, it writes files without checking for errors
>> > (e.g. EIO, ENOSPC or EDQUOT).
>>
>> Good catch!  I'll need to brush up on my C skills to fix these.
>> Meanwhile I'd like to ship including bugs, WDYT?
>
> I think it's ok, _if_ the bugs are eventually at least reported
> upstream if we (i.e., you) cannot fix them timely (needs some contrived
> circumstances to trigger the bug).

R
R
Remco van 't Veer wrote on 25 Jun 2022 16:53
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55891@debbugs.gnu.org)
87edzceqw0.fsf@remworks.net
2022/06/10 23:47, Maxime Devos:

Toggle quote (4 lines)
> I think it's ok, _if_ the bugs are eventually at least reported
> upstream if we (i.e., you) cannot fix them timely (needs some
> contrived circumstances to trigger the bug).

The maintainer's stance on not checking malloc response (from

Toggle quote (8 lines)
> > I'll open an issue for the unchecked [mc]alloc and write calls
> > instead if you do and maybe have another stab at fixing these issues
> > when my C-programming skills have improved.
>
> I agree on the unchecked writes. For the unchecked [mc]alloc I am more
> tempted towards removing the existing checks, since I am not convinced
> checking won't always do more harm than good for those.

He elaborated on this at:


Boiling down to: when memory is that low exiting with a proper error
messages and doing cleanup probably won't work anyway and the OOM killer
will have swept in before the situation exists. Which makes sense,
IMHO, but I am no expert.

I've created an issue for the unchecked writes:


HTH,
Remco
R
R
Remco van 't Veer wrote on 1 Jul 2022 08:58
(address . 55891@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
87tu819v5v.fsf@remworks.net
Is there anything else I can do to keep this ticket moving? Bug about
unchecked IO is reported and discussion about unchecked malloc has
stalled.

Also note, this package is also being shipped by debian, archlinux,
fedora, and others. Not that it matters but just to point out it's a
widely spread utility.

Cheers,
Remco
M
M
Maxime Devos wrote on 31 Jul 2022 01:48
3e39fece-f6b2-b3c1-da19-e1c78fee2112@telenet.be
On 01-07-2022 08:58, Remco van 't Veer wrote:
Toggle quote (3 lines)
> Is there anything else I can do to keep this ticket moving? Bug about
> unchecked IO is reported and discussion about unchecked malloc has
> stalled.
You could search for an alternative solution that is acceptable to
upstream, or if upstream completely refuses bugfixes, add some patch to
the Guix package definition.  Also, I have not yet seen a v2 for
resolving the other (non-upstream-code) issues I noted.
Another method would be to help out with reviewing and fixing things
(with other packages), this frees up time and is seen as a good act,
hence making other people more inclined to help out with any remaining
issues in your patches (including fixing issues such as those of the
kind I have mentioned before, but also actually applying the patch and
committing it).
You could also perform _all_ the checks in (guix)Submitting Patches
(e.g., the bundling check, actually building it for other systems as
well with QEMU, reproducibility check).
Toggle quote (3 lines)
> Also note, this package is also being shipped by debian, archlinux,
> fedora, and others. Not that it matters but just to point out it's a
> widely spread utility.
I am not convinced by your implied method of persuasion by social
pressure / argumentum ad populum. If it doesn't matter, why use it as an
argument?
Greetings,
Maxime.
Attachment: OpenPGP_signature
R
R
Remco van 't Veer wrote on 14 Aug 2022 09:57
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55891@debbugs.gnu.org)
871qtjfea5.fsf@remworks.net
Hi Maxime,

Sorry for the late reply, I was out camping.

2022/07/31 01:48, Maxime Devos:

Toggle quote (11 lines)
> On 01-07-2022 08:58, Remco van 't Veer wrote:
>
>> Is there anything else I can do to keep this ticket moving? Bug about
>> unchecked IO is reported and discussion about unchecked malloc has
>> stalled.
>
> You could search for an alternative solution that is acceptable to
> upstream, or if upstream completely refuses bugfixes, add some patch
> to the Guix package definition.  Also, I have not yet seen a v2 for
> resolving the other (non-upstream-code) issues I noted.

The patches I did submit upstream were not accepted and I agree with the
arguments of the maintainer so I won't add these to this package
definition.


Also, I did make a v2 but forgot to cc you, sorry about that:


Also did a v3 because the copyright line was missing (and failed to cc
you again):


Toggle quote (7 lines)
> Another method would be to help out with reviewing and fixing things
> (with other packages), this frees up time and is seen as a good act,
> hence making other people more inclined to help out with any remaining
> issues in your patches (including fixing issues such as those of the
> kind I have mentioned before, but also actually applying the patch and
> committing it).

That's a great tip and I will try and leap over my newby/shyness
feelings to get into that. Getting feedback like yours has certainly
thought me a lot about what to look out for. Thank you for your
feedback so far, also on the other patches I've submitted!

Toggle quote (4 lines)
> You could also perform _all_ the checks in (guix)Submitting Patches
> (e.g., the bundling check, actually building it for other systems as
> well with QEMU, reproducibility check).

Just ran through them again and all seems to be fine. I am not sure how
to prove I did.

Toggle quote (8 lines)
>> Also note, this package is also being shipped by debian, archlinux,
>> fedora, and others. Not that it matters but just to point out it's a
>> widely spread utility.
>
> I am not convinced by your implied method of persuasion by social
> pressure / argumentum ad populum. If it doesn't matter, why use it as
> an argument?

What I should have written is I am moving and application from
ubuntu/debian to guix and am missing this package. We already use a
custom channel to make development possible but in doing to I was
tickled by (guix)Creating a Channel mentioning:

Before publishing a channel, please consider contributing your package
definitions to Guix proper (*note Contributing::). Guix as a project
is open to free software of all sorts, and packages in Guix proper are
readily available to all Guix users and benefit from the project’s
quality assurance process.

Cheers,
Remco
?