[PATCH] gnu: Add python-pandarallel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 8 Jun 2022 18:52
(address . guix-patches@gnu.org)(name . Wiktor ?elazny)(address . wz@freeshell.de)
20220608165257.1701-1-wz@freeshell.de
* gnu/packages/python-science.scm (python-pandarallel): New variable.
---
gnu/packages/python-science.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 855fe9a72c..b16ec5455d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1340,3 +1340,28 @@ (define-public python-gpy
Python, from the Sheffield machine learning group. GPy implements a range of
machine learning algorithms based on GPs.")
(license license:bsd-3)))
+
+(define-public python-pandarallel
+ (package
+ (name "python-pandarallel")
+ (version "1.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandarallel" version))
+ (sha256
+ (base32
+ "0fnfwq5j2748lj0fb2qdn4p3h7p0a352bvx6ygwjh5vs0pbicvz3"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-dill python-pandas python-psutil))
+ (native-inputs (list python-mkdocs-material python-numpy python-pytest
+ python-pytest-cov))
+ (home-page "https://nalepae.github.io/pandarallel/")
+ (synopsis "Simple and efficient tool to parallelize Pandas operations
+across CPUs")
+ (description
+ "With a one line code change, @code{pandarallel} allows any
+Pandas user to take advantage of their multi-core computer, while Pandas uses
+only one core. @code{pandarallel} also offers nice progress bars (available on
+Notebook and terminal) to get an rough idea of the remaining amount of
+computation to be done.")
+ (license license:bsd-3)))

base-commit: 0c5299200ffcd16370f047b7ccb187c60f30da34
--
2.36.1
S
S
Sharlatan Hellseher wrote on 1 Feb 22:18 +0100
(address . 55851-done@debbugs.gnu.org)
87eddvsx1q.fsf@gmail.com
Hi,

Modifications applied [7/7]
- [X] Use git checkout which has tests
- [X] Swap to pyproject-build-system
- [X] Fix inputs indention
- [X] Shorten synopsis
- [X] Simplify description
- [X] Run tests in parallel
- [X] Update to 1.6.5

Pushed as a879dd8b360adcf8f7d69c317dec8cae0f48270c to master.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmW8CrEACgkQdtcnv/Ys
0rUR7RAArvzXrCSzGELXeZ3ALQEskDwFYKVREIi3FhMo+qkDlQn78sduaiKDbj9q
/66NUFsDR9dn1i6qibZ8iTueiIBXwJPfC2gLSsBBvSupToNin2e3au8mLruHCYRR
LuZEu134Ub1xhzq3Wfp3EZqivIRl2QQK4a9W0XTfttUV7oTK2Wq0vKjqu/wWJTpl
n4TeWGca9sw2gfOAhn8aKyce2l6GJs1b97fXojrKJXkTc++fdDOk5jBCMB+Ei3Lv
8NwijUxO5LiW1Mjm6Zg4J0a0mVtdP+/msYrfpnYR0hxwbpZKuoT4bANwGP0Z+v8P
ieyD4/uHo8oY/rNsC1tF0fYCzmaTPwygk/dMt/bc6GuyBWVee+MwhkQFlYQbwufV
DXrqxZIs2o52atSxpblgzy2F+QKN6+vhzJLgPmG/XE2Tuf9ByoO4q+8km0VOBBlM
c6hm636UVWG3MGQuW3uaX66ijhnj3uWC4pRb4pdIiFhY1qKWfZmsTrewg/Om5PjV
rjnsQQzLyoHbWQWvCU2BBCX20SNCOE1UJNy5asZ4JGt3mIMSZzcnLlZ6qT7XjWNS
nVk7r78hhcJvdx7czxzPuY4FIrHy1tNFtBGpUljjRc9g+Nh1AXHv1KP22ZPRCu+9
VvJqTZZApz4swr+uUNYtGkBG9oy5BUIs32Gb0ZdgbXnlphQAwhY=
=HzwK
-----END PGP SIGNATURE-----

Closed
?