Add python-platformio and dependencies

  • Open
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Peter Polidoro
Owner
unassigned
Submitted by
Peter Polidoro
Severity
normal
P
P
Peter Polidoro wrote on 7 Jun 2022 16:27
(address . guix-patches@gnu.org)
868rq8zgxm.fsf@polidoro.io

P
P
peter wrote on 7 Jun 2022 16:35
[PATCH] gnu: Add python-starlette.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
c5d49b019d635d3bb4eecb5a02478b98dbda8c90.1654612301.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-starlette): New variable.
---
gnu/packages/python-web.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06a0d2593b..874ef73093 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1200,6 +1200,24 @@ (define-public python-h2
Python HTTP implementation.")
(license license:expat)))
+(define-public python-starlette
+ (package
+ (name "python-starlette")
+ (version "0.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "starlette" version))
+ (sha256
+ (base32
+ "1si8plb5lgwkcaqzccrrisiksdrxldq94kij73i0mizn7l42g0nx"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-anyio python-typing-extensions))
+ (home-page "https://github.com/encode/starlette")
+ (synopsis "Lightweight ASGI framework for building async web services in Python")
+ (description "This package is a lightweight Asynchronous Server Gateway Interface for
+building async web services in Python.")
+ (license license:bsd-3)))
+
(define-public python-sockjs-tornado
(package
(name "python-sockjs-tornado")
--
2.36.1
P
P
peter wrote on 7 Jun 2022 18:45
[PATCH] Add extra dependencies to python-starlette
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
840295f172b7d9e2cce45a5df38607280860bfe4.1654620158.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

---
gnu/packages/python-web.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 874ef73093..9a3a11c7d1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1211,7 +1211,13 @@ (define-public python-starlette
(base32
"1si8plb5lgwkcaqzccrrisiksdrxldq94kij73i0mizn7l42g0nx"))))
(build-system python-build-system)
- (propagated-inputs (list python-anyio python-typing-extensions))
+ (propagated-inputs (list python-anyio
+ python-typing-extensions
+ python-itsdangerous
+ python-jinja2
+ python-multipart
+ python-pyyaml
+ python-requests))
(home-page "https://github.com/encode/starlette")
(synopsis "Lightweight ASGI framework for building async web services in Python")
(description "This package is a lightweight Asynchronous Server Gateway Interface for
--
2.36.1
P
P
peter wrote on 7 Jun 2022 19:08
[PATCH] gnu: python-h11: Update to 0.13.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
c1f47f7a425ca608c68e5cdef720103946b5706c.1654621638.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-h11): Update to 0.13.0.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9a3a11c7d1..7486d6d08c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1141,13 +1141,13 @@ (define-public python-hpack
(define-public python-h11
(package
(name "python-h11")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h11" version))
(sha256
- (base32 "0hk0nll6qazsambp3kl8cxxsbl4gv5y9252qadyk0jky0sv2q8j7"))))
+ (base32 "01pzawwhr537ypm966hli0hspzw104d0xk1q9n528yh86l8kr0bh"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.36.1
P
P
peter wrote on 7 Jun 2022 19:13
[PATCH] gnu: python-wsproto: Update to 1.1.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
8c4ba8e1ae9b8c1ea8cee1118dff383003c0faf7.1654621970.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-wsproto): Update to 1.1.0.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7486d6d08c..58bdac622a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1935,13 +1935,13 @@ (define-public python-priority
(define-public python-wsproto
(package
(name "python-wsproto")
- (version "0.15.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "wsproto" version))
(sha256
- (base32 "17gsxlli4w8am1wwwl3k90hpdfa213ax40ycbbvb7hjx1v1rhiv1"))))
+ (base32 "1a5x27qyrq0n4vk6ca47fj5pjdvdrpn5yfyqd49krn3wbkynprd2"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.36.1
P
P
peter wrote on 7 Jun 2022 22:09
[PATCH] gnu: python-httpcore and python-httpx: Update to 0.15.0 and 0.23.0
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
accb1c1f8e8e9ebc5a815e9b8a9dd1694f634ed7.1654632468.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

These packages seem to have cyclic dependencies on each other so they may need
to be updated together.

* gnu/packages/python-web.scm (python-httpcore): Update to 0.15.0.
---
gnu/packages/python-web.scm | 27 ++++++++++++++++++++-------
1 file changed, 20 insertions(+), 7 deletions(-)

Toggle diff (80 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 58bdac622a..22c09af1ed 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5317,7 +5317,7 @@ (define-public python-vf-1
(define-public python-httpcore
(package
(name "python-httpcore")
- (version "0.14.7")
+ (version "0.15.0")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -5327,15 +5327,20 @@ (define-public python-httpcore
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0wdr28vf03l6yxhk8nrvhh7y7x18rqdcfzv1sb6jgzk9zmycrvc7"))))
+ (base32 "0skj8f85l52gl6x449wzaixcwsyayvn59iwn0df4b7ixlz6xhp8l"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("h11>=0\\.11,<0\\.13") "h11"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv" "tests")))))))
+ (invoke "pytest" "-vv" "tests"
+ "-o""asyncio_mode=auto")))))))
(native-inputs
(list python-pytest
python-pytest-asyncio
@@ -5376,13 +5381,17 @@ (define-public python-httpcore-bootstrap
(hidden-package
(package/inherit python-httpcore
(name "python-httpcore-bootstrap")
- (arguments (list #:tests? #f))
+ (arguments
+ '(#:tests? #f
+ ;; sanity check fails when arguments overridden
+ #:phases (modify-phases %standard-phases
+ (delete 'sanity-check))))
(native-inputs '()))))
(define-public python-httpx
(package
(name "python-httpx")
- (version "0.22.0")
+ (version "0.23.0")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -5392,7 +5401,7 @@ (define-public python-httpx
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1awr56488b66zyl3cx1f03lq2n07xdg5kb4l46vnsm59s6hr02c5"))))
+ (base32 "0bihm7ylq9ajxz8qyba0xp9qkwm7n06hk01ywkq2vpz65ix5hpdk"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -5478,7 +5487,11 @@ (define-public python-httpx-bootstrap
(hidden-package
(package/inherit python-httpx
(name "python-httpx-bootstrap")
- (arguments (list #:tests? #f))
+ (arguments
+ '(#:tests? #f
+ ;; sanity check fails when arguments overridden
+ #:phases (modify-phases %standard-phases
+ (delete 'sanity-check))))
(native-inputs '())
(propagated-inputs
(modify-inputs (package-propagated-inputs python-httpx)
--
2.36.1
P
P
peter wrote on 7 Jun 2022 22:26
[PATCH] gnu: python-sanic-testing: Update requirements.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
288c8ea389f3452c61bb11d89af92c68ada462ec.1654633492.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (): Update to .
---
gnu/packages/python-web.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 22c09af1ed..afa5473969 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6362,7 +6362,13 @@ (define-public python-sanic-testing
(arguments
;; PyPi sources does not contain tests, recursive dependency on
;; python-sanic.
- (list #:tests? #f))
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("httpx>=0\\.18,<0\\.23") "httpx")))))))
(propagated-inputs (list python-httpx python-sanic-bootstrap
python-websockets))
(home-page "https://github.com/sanic-org/sanic-testing/")
--
2.36.1
P
P
peter wrote on 7 Jun 2022 22:35
[PATCH] gnu: python-aiofiles: Update to 0.8.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
f02a60f4718f20ff18f7bd316715ff8f62b6e4f7.1654634085.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-aiofiles): Update to 0.8.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c76ff1922..94948fe4e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26254,14 +26254,14 @@ (define-public python-contextvars
(define-public python-aiofiles
(package
(name "python-aiofiles")
- (version "0.6.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aiofiles" version))
(sha256
(base32
- "14m01kjxm2j7zyljjj6xlhlgygcsriymbx730gc5jp9xglaina70"))))
+ "0n8yj2d4srlkrhk72fcnkfb3jkv74a5aghxjhcp3p2i46lrg4d43"))))
(build-system python-build-system)
(home-page "https://github.com/Tinche/aiofiles")
(synopsis "File support for @code{asyncio}")
--
2.36.1
P
P
peter wrote on 7 Jun 2022 23:02
[PATCH] gnu: python-semantic-version: Update to 2.10.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
f75f3e203859c05c55dd21744459e5534f156481.1654635675.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-semantic-version): Update to 2.10.0.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++--
1 file changed, 20 insertions(+), 2 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 94948fe4e2..3f19fb363f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1761,15 +1761,33 @@ (define-public python-filelock
(define-public python-semantic-version
(package
(name "python-semantic-version")
- (version "2.8.5")
+ (version "2.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "semantic_version" version))
(sha256
(base32
- "0m4avx8zdkzc7qglv5zlr54g8yna5vl098drg5396ql7aph2vjyj"))))
+ "0704smz9k6hdd6i5xh0xf0sk47kannjb77abilvvp34r6v9vdaxx"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; Skip the only failing test "test_django" because settings
+ ;; are not configured.
+ (invoke "pytest" "-vv" "-k" "not test_django")))))))
+ (native-inputs (list python-check-manifest
+ python-colorama
+ python-coverage
+ python-django
+ python-flake8
+ python-nose2
+ python-readme-renderer
+ python-tox
+ python-wheel))
(home-page "https://github.com/rbarrois/python-semanticversion")
(synopsis "Semantic versioning module for Python")
(description
--
2.36.1
P
P
peter wrote on 8 Jun 2022 02:43
[PATCH] gnu: Add python-platformio.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
aefeeafa8d187498206761248b8dfc7a7b9931f9.1654648968.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/embedded.scm (python-platformio): New variable.
---
gnu/packages/embedded.scm | 59 +++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 6a66fe4753..79605d8be5 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1556,6 +1557,64 @@ (define-public sdcc
license:public-domain
license:zlib))))
+(define-public python-platformio
+ (package
+ (name "python-platformio")
+ (version "6.0.2")
+ (source (origin
+ ;; PyPI does not include tox.ini
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/platformio/platformio-core")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0scb9z3rpkpdvpx6lcj51vqx1vzkxi2fdfqxk2ir9r9qwgvhbxf9"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Requirements refer to a specific version of dependencies,
+ ;; which are too old. So we patch to refer to any later version.
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("==") ">="))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "tox" "-e" "py39" "--sitepackages")))))))
+ (propagated-inputs (list python-aiofiles
+ python-ajsonrpc
+ python-bottle
+ python-click
+ python-colorama
+ python-marshmallow
+ python-pyelftools
+ python-pyserial
+ python-requests
+ python-semantic-version
+ python-service-identity
+ python-starlette
+ python-tabulate
+ python-twisted
+ python-uvicorn
+ python-wsproto
+ python-zeroconf))
+ (native-inputs (list python-black
+ python-isort
+ python-jsondiff
+ python-tox
+ python-pylint
+ python-pytest
+ python-pytest-xdist))
+ (home-page "https://platformio.org")
+ (synopsis "Platform for embedded development")
+ (description
+ "PlatformIO is a cross-platform, cross-architecture, multiple framework,
+tool for embedded systems development.")
+ (license license:asl2.0)))
+
(define-public python-psptool
(package
(name "python-psptool")
--
2.36.1
P
P
peter wrote on 8 Jun 2022 20:18
[PATCH] Rename python-platformio to platformio
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
1ad49e090b8c93be52f95a4a6af53f2961d99cc7.1654712272.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

---
gnu/packages/embedded.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 79605d8be5..5b5192c751 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1557,9 +1557,9 @@ (define-public sdcc
license:public-domain
license:zlib))))
-(define-public python-platformio
+(define-public platformio
(package
- (name "python-platformio")
+ (name "platformio")
(version "6.0.2")
(source (origin
;; PyPI does not include tox.ini
--
2.36.1
L
L
Liliana Marie Prikler wrote on 8 Jun 2022 20:56
47e0e0711f100b5b3c7a8e4feef28d5a58624102.camel@gmail.com
Am Mittwoch, dem 08.06.2022 um 14:18 -0400 schrieb peter@polidoro.io:
Toggle quote (1 lines)
> From: Peter Polidoro <peter@polidoro.io>
Provide ChangeLogs, also order your commits.

Toggle quote (17 lines)
> ---
>  gnu/packages/embedded.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
> index 79605d8be5..5b5192c751 100644
> --- a/gnu/packages/embedded.scm
> +++ b/gnu/packages/embedded.scm
> @@ -1557,9 +1557,9 @@ (define-public sdcc
>                     license:public-domain
>                     license:zlib))))
>  
> -(define-public python-platformio
> +(define-public platformio
>    (package
> -    (name "python-platformio")
> +    (name "platformio")
This change should probably be squashed onto the previous one :)
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 0/8] Add platformio and dependencies
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
cover.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>


Platformio is a python package that required adding some new packages and
updating others. Most of the updates were relatively straightforward, but
python-httpcore and python-httpx seem to have cyclic dependencies on each
other, so those updates are included as a single commit. Some of these updates
may affect packages not included in this patch series. For example, several
python packages specify a dependency on h11 less than 0.13.0. If necessary,
those guix packages can be updated to relax that requirement or version 0.12.0
could be added if that dependency restriction is indeed necessary.


Peter Polidoro (8):
gnu: Add python-starlette.
gnu: python-h11: Update to 0.13.0.
gnu: python-wsproto: Update to 1.1.0.
gnu: python-httpcore and python-httpx: Update to 0.15.0 and 0.23.0
gnu: python-sanic-testing: Update requirements.
gnu: python-aiofiles: Update to 0.8.0.
gnu: python-semantic-version: Update to 2.10.0.
gnu: Add platformio.

gnu/packages/embedded.scm | 59 ++++++++++++++++++++++++++++++++
gnu/packages/python-web.scm | 67 ++++++++++++++++++++++++++++++-------
gnu/packages/python-xyz.scm | 26 +++++++++++---
3 files changed, 136 insertions(+), 16 deletions(-)

--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 2/8] gnu: python-h11: Update to 0.13.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
991b227ceefd94e8d8477de3a159ca14186a6b40.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-h11): Update to 0.13.0.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9a3a11c7d1..7486d6d08c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1141,13 +1141,13 @@ (define-public python-hpack
(define-public python-h11
(package
(name "python-h11")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h11" version))
(sha256
- (base32 "0hk0nll6qazsambp3kl8cxxsbl4gv5y9252qadyk0jky0sv2q8j7"))))
+ (base32 "01pzawwhr537ypm966hli0hspzw104d0xk1q9n528yh86l8kr0bh"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 1/8] gnu: Add python-starlette.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
097ec178719a714171c095b0d584c57c833e4d6e.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-starlette): New variable.
---
gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06a0d2593b..9a3a11c7d1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1200,6 +1200,30 @@ (define-public python-h2
Python HTTP implementation.")
(license license:expat)))
+(define-public python-starlette
+ (package
+ (name "python-starlette")
+ (version "0.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "starlette" version))
+ (sha256
+ (base32
+ "1si8plb5lgwkcaqzccrrisiksdrxldq94kij73i0mizn7l42g0nx"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-anyio
+ python-typing-extensions
+ python-itsdangerous
+ python-jinja2
+ python-multipart
+ python-pyyaml
+ python-requests))
+ (home-page "https://github.com/encode/starlette")
+ (synopsis "Lightweight ASGI framework for building async web services in Python")
+ (description "This package is a lightweight Asynchronous Server Gateway Interface for
+building async web services in Python.")
+ (license license:bsd-3)))
+
(define-public python-sockjs-tornado
(package
(name "python-sockjs-tornado")
--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 6/8] gnu: python-aiofiles: Update to 0.8.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
335fa562b7a51b3d7ea712b649b26cd002af5534.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-aiofiles): Update to 0.8.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c76ff1922..94948fe4e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26254,14 +26254,14 @@ (define-public python-contextvars
(define-public python-aiofiles
(package
(name "python-aiofiles")
- (version "0.6.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aiofiles" version))
(sha256
(base32
- "14m01kjxm2j7zyljjj6xlhlgygcsriymbx730gc5jp9xglaina70"))))
+ "0n8yj2d4srlkrhk72fcnkfb3jkv74a5aghxjhcp3p2i46lrg4d43"))))
(build-system python-build-system)
(home-page "https://github.com/Tinche/aiofiles")
(synopsis "File support for @code{asyncio}")
--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 3/8] gnu: python-wsproto: Update to 1.1.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
a2fad39b4a3464abd1667b89cfc58c773c3b1a8f.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-wsproto): Update to 1.1.0.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7486d6d08c..58bdac622a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1935,13 +1935,13 @@ (define-public python-priority
(define-public python-wsproto
(package
(name "python-wsproto")
- (version "0.15.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "wsproto" version))
(sha256
- (base32 "17gsxlli4w8am1wwwl3k90hpdfa213ax40ycbbvb7hjx1v1rhiv1"))))
+ (base32 "1a5x27qyrq0n4vk6ca47fj5pjdvdrpn5yfyqd49krn3wbkynprd2"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 4/8] gnu: python-httpcore and python-httpx: Update to 0.15.0 and 0.23.0
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
94f4b1482a4976400edbddc3bd0d5a32f4fda3ee.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

These packages seem to have cyclic dependencies on each other so they may need
to be updated together.

* gnu/packages/python-web.scm (python-httpcore): Update to 0.15.0.
---
gnu/packages/python-web.scm | 27 ++++++++++++++++++++-------
1 file changed, 20 insertions(+), 7 deletions(-)

Toggle diff (80 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 58bdac622a..22c09af1ed 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5317,7 +5317,7 @@ (define-public python-vf-1
(define-public python-httpcore
(package
(name "python-httpcore")
- (version "0.14.7")
+ (version "0.15.0")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -5327,15 +5327,20 @@ (define-public python-httpcore
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0wdr28vf03l6yxhk8nrvhh7y7x18rqdcfzv1sb6jgzk9zmycrvc7"))))
+ (base32 "0skj8f85l52gl6x449wzaixcwsyayvn59iwn0df4b7ixlz6xhp8l"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("h11>=0\\.11,<0\\.13") "h11"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv" "tests")))))))
+ (invoke "pytest" "-vv" "tests"
+ "-o""asyncio_mode=auto")))))))
(native-inputs
(list python-pytest
python-pytest-asyncio
@@ -5376,13 +5381,17 @@ (define-public python-httpcore-bootstrap
(hidden-package
(package/inherit python-httpcore
(name "python-httpcore-bootstrap")
- (arguments (list #:tests? #f))
+ (arguments
+ '(#:tests? #f
+ ;; sanity check fails when arguments overridden
+ #:phases (modify-phases %standard-phases
+ (delete 'sanity-check))))
(native-inputs '()))))
(define-public python-httpx
(package
(name "python-httpx")
- (version "0.22.0")
+ (version "0.23.0")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -5392,7 +5401,7 @@ (define-public python-httpx
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1awr56488b66zyl3cx1f03lq2n07xdg5kb4l46vnsm59s6hr02c5"))))
+ (base32 "0bihm7ylq9ajxz8qyba0xp9qkwm7n06hk01ywkq2vpz65ix5hpdk"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -5478,7 +5487,11 @@ (define-public python-httpx-bootstrap
(hidden-package
(package/inherit python-httpx
(name "python-httpx-bootstrap")
- (arguments (list #:tests? #f))
+ (arguments
+ '(#:tests? #f
+ ;; sanity check fails when arguments overridden
+ #:phases (modify-phases %standard-phases
+ (delete 'sanity-check))))
(native-inputs '())
(propagated-inputs
(modify-inputs (package-propagated-inputs python-httpx)
--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 7/8] gnu: python-semantic-version: Update to 2.10.0.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
3366643273e11b1571db78ab2e0190fe2de13aff.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-semantic-version): Update to 2.10.0.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++--
1 file changed, 20 insertions(+), 2 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 94948fe4e2..3f19fb363f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1761,15 +1761,33 @@ (define-public python-filelock
(define-public python-semantic-version
(package
(name "python-semantic-version")
- (version "2.8.5")
+ (version "2.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "semantic_version" version))
(sha256
(base32
- "0m4avx8zdkzc7qglv5zlr54g8yna5vl098drg5396ql7aph2vjyj"))))
+ "0704smz9k6hdd6i5xh0xf0sk47kannjb77abilvvp34r6v9vdaxx"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; Skip the only failing test "test_django" because settings
+ ;; are not configured.
+ (invoke "pytest" "-vv" "-k" "not test_django")))))))
+ (native-inputs (list python-check-manifest
+ python-colorama
+ python-coverage
+ python-django
+ python-flake8
+ python-nose2
+ python-readme-renderer
+ python-tox
+ python-wheel))
(home-page "https://github.com/rbarrois/python-semanticversion")
(synopsis "Semantic versioning module for Python")
(description
--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 5/8] gnu: python-sanic-testing: Update requirements.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
9fde10030f83799b8282ec101c559af5b973ef5c.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (): Update to .
---
gnu/packages/python-web.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 22c09af1ed..afa5473969 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6362,7 +6362,13 @@ (define-public python-sanic-testing
(arguments
;; PyPi sources does not contain tests, recursive dependency on
;; python-sanic.
- (list #:tests? #f))
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("httpx>=0\\.18,<0\\.23") "httpx")))))))
(propagated-inputs (list python-httpx python-sanic-bootstrap
python-websockets))
(home-page "https://github.com/sanic-org/sanic-testing/")
--
2.36.1
P
P
peter wrote on 8 Jun 2022 22:55
[PATCH 8/8] gnu: Add platformio.
(address . 55831@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
f933348499c7bd2f9f552949f38b40222317123e.1654720996.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/embedded.scm (platformio): New variable.
---
gnu/packages/embedded.scm | 59 +++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 6a66fe4753..5b5192c751 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1556,6 +1557,64 @@ (define-public sdcc
license:public-domain
license:zlib))))
+(define-public platformio
+ (package
+ (name "platformio")
+ (version "6.0.2")
+ (source (origin
+ ;; PyPI does not include tox.ini
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/platformio/platformio-core")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0scb9z3rpkpdvpx6lcj51vqx1vzkxi2fdfqxk2ir9r9qwgvhbxf9"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Requirements refer to a specific version of dependencies,
+ ;; which are too old. So we patch to refer to any later version.
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("==") ">="))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "tox" "-e" "py39" "--sitepackages")))))))
+ (propagated-inputs (list python-aiofiles
+ python-ajsonrpc
+ python-bottle
+ python-click
+ python-colorama
+ python-marshmallow
+ python-pyelftools
+ python-pyserial
+ python-requests
+ python-semantic-version
+ python-service-identity
+ python-starlette
+ python-tabulate
+ python-twisted
+ python-uvicorn
+ python-wsproto
+ python-zeroconf))
+ (native-inputs (list python-black
+ python-isort
+ python-jsondiff
+ python-tox
+ python-pylint
+ python-pytest
+ python-pytest-xdist))
+ (home-page "https://platformio.org")
+ (synopsis "Platform for embedded development")
+ (description
+ "PlatformIO is a cross-platform, cross-architecture, multiple framework,
+tool for embedded systems development.")
+ (license license:asl2.0)))
+
(define-public python-psptool
(package
(name "python-psptool")
--
2.36.1
?