(name . Guix Patches)(address . guix-patches@gnu.org)
Hi,
here's patch for hcxtools: update + gexps.
----
Petr
From 751167feff404c81dfbfb5e447b854a5dbc44c89 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 7 Jun 2022 12:07:42 +0200
Subject: [PATCH 1/2] gnu: hcxtools: Use gexps.
* gnu/packages/networking.scm (hcxtools)[arguments]: Link libraries and use PREFIX instead of INSTALL_DIR.
[phases]: Use gexps.
Toggle diff (36 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index bfa956149d..5b82516812 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3232,16 +3232,20 @@ (define-public hcxtools
(base32 "0k2qlq9hz5zc21nyc6yrnfqzga7hydn5mm0x3rpl2fhkwl81lxcn"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
- (inputs
- (list curl libpcap openssl zlib))
+ (native-inputs (list pkg-config))
+ (inputs (list curl libpcap openssl zlib))
(arguments
- `(#:make-flags
- (list ,(string-append "CC=" (cc-for-target))
- (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
- #:tests? #f ; no test suite
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:make-flags
+ #~(list (string-append "CC="
+ #$(cc-for-target)) "LDFLAGS+=-lcrypto"
+ "LDFLAGS+=-lcurl" "LDFLAGS+=-lz"
+ (string-append "PREFIX="
+ #$output))
+ #:tests?
+ #f ;no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://github.com/ZerBea/hcxtools")
(synopsis "Capture wlan traffic to hashcat and John the Ripper")
(description
--
2.35.1
From 66dd167a01e0eec4a3d0064115e617ba155131ed Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 7 Jun 2022 12:05:54 +0200
Subject: [PATCH 2/2] gnu: hcxtools: Update to 6.2.7.
* gnu/packages/networking.scm (hcxtools): Update to 6.2.7.
Toggle diff (24 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5b82516812..ccb0ded0aa 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3221,7 +3221,7 @@ (define-public ubridge
(define-public hcxtools
(package
(name "hcxtools")
- (version "5.2.0")
+ (version "6.2.7")
(source
(origin
(method git-fetch)
@@ -3229,7 +3229,7 @@ (define-public hcxtools
(url "https://github.com/ZerBea/hcxtools")
(commit version)))
(sha256
- (base32 "0k2qlq9hz5zc21nyc6yrnfqzga7hydn5mm0x3rpl2fhkwl81lxcn"))
+ (base32 "0460dxbc04w60l3g06rk007yyb6qprgyii59y2zdki0vy7q63m8b"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs (list pkg-config))
--
2.35.1