guix pull fails on local channel

  • Open
  • quality assurance status badge
Details
3 participants
  • Kjartan Oli Agustsson
  • Liliana Marie Prikler
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Kjartan Oli Agustsson
Severity
normal
K
K
Kjartan Oli Agustsson wrote on 7 Jun 2022 02:20
(address . bug-guix@gnu.org)
GV1P193MB231058950024F1B6F79943AEDFA59@GV1P193MB2310.EURP193.PROD.OUTLOOK.COM
I recently installed the full Guix system, and after reading the
sections of the manual about channels I set one up for my personal
modifications to existing packages. Everything worked fine until I
committed changes to one of those package definitions and re-ran 'guix
pull' which fails with:
Toggle quote (4 lines)
> Updating channel 'kjartan' from Git repository at 'file:///home/kjartan/guix-custom'...
> Authenticating channel 'kjartan', commits 3bd6c82 to 6677083 (1 new commits)...
> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> #<unknown port>:5:1: unexpected end of input while searching for: )
If I delete the git repository and re-initialize it the pull is
successful, but once I commit any changes to this new repository the
problem re-appears. Does anyone have any clues as to what could be
wrong, or how I could go about debugging this?

If it helps the channel definition is:
(channel
(name 'kjartan)
(url "file:///home/kjartan/guix-custom")
(introduction
(make-channel-introduction
"3bd6c82a5bb588c35ead0458036aac0ef60f166a"
(openpgp-fingerprint
"4801 0D71 49C0 1DD6 E5FD 6AC9 D757 2FE3 605E E6B0"))))

--
Kjartan Óli Ágústsson

GPG Key fingerprint: 4801 0D71 49C0 1DD6 E5FD 6AC9 D757 2FE3 605E E6B0
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEESAENcUnAHdbl/WrJ11cv42Be5rAFAmKemjAXHGtqYXJ0YW5v
bGlAb3V0bG9vay5jb20ACgkQ11cv42Be5rBH4gwAvXeGAnsm9jpGb1fLaAMoLk0B
60lXbxWWrIj0BDhge86AtBGvTLZPbobGH8ReIvtrwczbl2M/QUWeAsfHeanPSevc
g0TMVHAsj2Unp2WibSh9z+pC6Y3TXgipED+0ph1BeAXZU7wbSaLnziIDnFyyqMjj
1P2emd28x/j0JRJ3frXtNpExu2Li6vqWgav+v2tP5fk7EM4swF5MjEmBuPZ7z/CP
ZyaXhRCJ823gtlJKEWwyE7NsI2zuTaBYQASXKIAXrH8yFuCwNcXzv8zdWDcB3EU/
7Mp1NncMgBkgJUmlwWtZfhKeh+RVvSSsfvMByVqctYsfxBbP7AebdVikddl9GIl3
l+mQOt1p0cyvD7Ktg1+jt9k9JpZRcCFebWztk933lVWpZ4Yd6wIupOdzSwk6wVKE
RwLEKle7pKrjeUcXvM5VLVH5lHz75LnKZoh5cR1a4ixxiBVDpjBnZ0EPZFQljZ/e
1TGVpVZyET3e+P4mwtFDR4oEu6HpJNeXJpaKbIlU
=2oE6
-----END PGP SIGNATURE-----


L
L
Liliana Marie Prikler wrote on 7 Jun 2022 08:32
0286bdb4fb92d3b234ecf73f0a26d9e20c539914.camel@ist.tugraz.at
Am Dienstag, dem 07.06.2022 um 00:20 +0000 schrieb Kjartan Oli
Agustsson:
Toggle quote (17 lines)
>
> I recently installed the full Guix system, and after reading the
> sections of the manual about channels I set one up for my personal
> modifications to existing packages.  Everything worked fine until I
> committed changes to one of those package definitions and re-ran
> 'guix pull' which fails with:
>
> > Updating channel 'kjartan' from Git repository at
> > 'file:///home/kjartan/guix-custom'...
> > Authenticating channel 'kjartan', commits 3bd6c82 to 6677083 (1 new
> > commits)...
> > ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> > #<unknown port>:5:1: unexpected end of input while searching for: )
> If I delete the git repository and re-initialize it the pull is
> successful, but once I commit any changes to this new repository the
> problem re-appears.  Does anyone have any clues as to what could be
> wrong, or how I could go about debugging this?
Chances are that the changes you're trying to commit are ill-formed.
Use an editor that highlights brackets such as Emacs to find out where
you are missing one. If it's in the middle of the file, marking the
whole file and pressing TAB once should make the fault visible – if
it's towards the end, enter closing parentheses until they are no
longer matched up with anything prior.

Cheers
T
T
Tobias Geerinckx-Rice wrote on 7 Jun 2022 11:34
Re: bug#55826: guix pull fails on local channel
(address . kjartanoli@outlook.com)(address . 55826@debbugs.gnu.org)
87tu8w6bjg@nckx
Hi!

Kjartan Oli Agustsson ???
Toggle quote (8 lines)
>> Updating channel 'kjartan' from Git repository at
>> 'file:///home/kjartan/guix-custom'...
>> Authenticating channel 'kjartan', commits 3bd6c82 to 6677083 (1
>> new commits)...
>> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
>> #<unknown port>:5:1: unexpected end of input while searching
>> for: )

Guile errors are quite literal-minded, most of the time. All the
world's a string, and parsing it an adventure.

This error means that you have a missing or mismatched closing )
somewhere, or didn't close a " so Guile doesn't see it, or…

It's impossible to say more without seeing the code.

Toggle quote (5 lines)
> If I delete the git repository and re-initialize it the pull is
> successful, but once I commit any changes to this new repository
> the
> problem re-appears.

It must be some specific change/file, not any change.

A quick and dirty

~/guix-custom$ guix repl -L. <each/scheme/file/in/turn.scm

might be enough: Guile will print all kinds of things to ignore,
but if you see the same error about searching for ), you'll know
that the problem is in that file.

But really…

Toggle quote (3 lines)
> Does anyone have any clues as to what could be
> wrong, or how I could go about debugging this?

…use an editor (like emacs, but other fine and graphical editors
are available) that balances or at least highlights brackets.
Manually counting them is madness and not how anybody writes Lisps
in real life.

Toggle quote (11 lines)
> If it helps the channel definition is:
> (channel
> (name 'kjartan)
> (url "file:///home/kjartan/guix-custom")
> (introduction
> (make-channel-introduction
> "3bd6c82a5bb588c35ead0458036aac0ef60f166a"
> (openpgp-fingerprint
> "4801 0D71 49C0 1DD6 E5FD 6AC9 D757 2FE3
> 605E E6B0"))))

This looks fine, but I was unable to clone the repository. :-)

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYp8hEw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15YT8BAI1CujwU7UkZfDpW2M41J5OuI6bXvF/MyNa0qcPC
5E6pAP9Clsep/VscdjbVJKk9C6DVWKUd+L2W28Omm5fG9stdBw==
=LGUw
-----END PGP SIGNATURE-----

K
K
Kjartan Oli Agustsson wrote on 8 Jun 2022 00:10
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 55826@debbugs.gnu.org)
GV1P193MB2310207AC70B1E5F86CD34BADFA59@GV1P193MB2310.EURP193.PROD.OUTLOOK.COM
Tobias Geerinckx-Rice <me@tobias.gr> writes:

Toggle quote (6 lines)
>> If I delete the git repository and re-initialize it the pull is
>> successful, but once I commit any changes to this new repository the
>> problem re-appears.
>
> It must be some specific change/file, not any change.

I just re-initialized the git repo, and changed the channel introduction
to use the initial commit on the new repo. A 'guix pull' ran just fine.
Then I committed a change that added a single newline at the end of a
file, the error came back.

Toggle quote (8 lines)
> A quick and dirty
>
> ~/guix-custom$ guix repl -L. <each/scheme/file/in/turn.scm
>
> might be enough: Guile will print all kinds of things to ignore, but
> if you see the same error about searching for ), you'll know that the
> problem is in that file.

I tried this, the only output I got was:
;;; note: source file ./kjartan/packages/emacs.scm
;;; newer than compiled /gnu/store/bgnnzx7qsiy22yggh3a0q4i0932n6hl7-kjartan/lib/guile/3.0/site-ccache/kjartan/packages/emacs.go

Toggle quote (10 lines)
> But really…
>
>> Does anyone have any clues as to what could be
>> wrong, or how I could go about debugging this?
>
> …use an editor (like emacs, but other fine and graphical editors are
> available) that balances or at least highlights brackets. Manually
> counting them is madness and not how anybody writes Lisps in real
> life.

I am well aware of this, everything I have written in every file of the
channel has been written in Emacs, which does not report any unmatched
'(' anywhere in either of the two files I currently have.

--
Kjartan Óli Ágústsson

GPG Key fingerprint: 4801 0D71 49C0 1DD6 E5FD 6AC9 D757 2FE3 605E E6B0
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEESAENcUnAHdbl/WrJ11cv42Be5rAFAmKfz8QXHGtqYXJ0YW5v
bGlAb3V0bG9vay5jb20ACgkQ11cv42Be5rCi6wv8Co976qX6Z9G0Hi6wp5jRCF8O
2lTK3vDU7avB4URw0hfowIMnI5Dn0TzJmjC0vwIcXRmuUdT56AQz4kqzeHVfOYfY
Nmoegl99bqsVqhCXT0NvFLno7kgPY6y+l6XjNyFDqfP+hY+sp81VJM8R/IXSO5ST
E/uqPCQLDJb9Y5/22ILF6Y7ZY6MxzPMqeiglTljpxjdJ3SEq5D4HxP4iqyIgZi3t
g/XcSahECcukVY4K3kwPPqcd8JdCUpRzcgomVS1NCsXkMooLTztyVNAYEU+SnHli
z3vxgNwIS/U3PtOxPPr2f5dXioPuAMVRkeoz37xNwmedMazGzQZPmNbKBM1s/jWv
WJqB4QsUYGgbY2snqb7vbFU40qVnfNGycGfo74vO9HtHaxXci3GlpTUVpgIjYLO8
NoEw8WzO+yWd0w2diS1sZEBGPb7Gs3cj5ONjkmNa8Ma7Wdez9PVOpNhpasjRNJpW
/q9oc/6A4LwDCby1gb0sS0BXcFIjd2JwaxXYpheV
=7tJx
-----END PGP SIGNATURE-----


?