Christopher Rodriguez wrote 3 years ago
(address . guix-patches@gnu.org)(name . Christopher Rodriguez)(address . yewscion@gmail.com)
---
Hey all,
I noticed today that `python-flake8` was failing to build, as one of its inputs
(`python-pyflakes`) had been bumped too high for the older version's `check`
phase. Tried to take the initiative and threw together this patch; It builds in
my local tree, and had been linted/styled/tested/etc. I believe I have done
everything by the book, but if I need to fix anything, let me know (I'm still
new to contributing)!
Thanks for Your time!
gnu/packages/python-xyz.scm | 54 ++++++++++++++++++-------------------
1 file changed, 26 insertions(+), 28 deletions(-)
Toggle diff (96 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0dfc6ca7e0..77f2c88235 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6443,23 +6443,21 @@ (define-public python-socksipychain
(define-public python-pycodestyle
(package
(name "python-pycodestyle")
- (version "2.7.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pycodestyle" version))
- (sha256
- (base32
- "1vqwmzmjdv331kmfq3q9j3as2x7r2r49lf83r9w4147pdg8c32f3"))))
+ (version "2.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycodestyle" version))
+ (sha256
+ (base32
+ "0zxyrg8029lzjhima6l5nk6y0z6lm5wfp9qchz3s33j3xx3mipgd"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
- (native-inputs
- (list python-pytest))
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda (#:keys input output tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest))
(home-page "https://pycodestyle.readthedocs.io/")
(synopsis "Python style guide checker")
(description "@code{pycodestyle} (formerly pep8) is a tool to check
@@ -10143,18 +10141,17 @@ (define-public python-pyflakes
(package
(name "python-pyflakes")
(version "2.4.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pyflakes" version))
- (sha256
- (base32
- "0k5jn8jpxni264wxf6cc3xcd1qckc0pww30bsd77mwzdf8l5ra05"))))
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyflakes" version))
+ (sha256
+ (base32
+ "0k5jn8jpxni264wxf6cc3xcd1qckc0pww30bsd77mwzdf8l5ra05"))))
(build-system python-build-system)
(home-page "https://github.com/PyCQA/pyflakes")
(synopsis "Passive checker of Python programs")
(description
- "Pyflakes statically checks Python source code for common errors.")
+ "Pyflakes statically checks Python source code for common errors.")
(license license:expat)))
(define-public python-pyflakes-2.2
@@ -10193,20 +10190,21 @@ (define-public python-mccabe
(define-public python-flake8
(package
(name "python-flake8")
- (version "3.9.2")
+ (version "4.0.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "0sspgh2ph7bb5fmf49mrdhi7n5m421kfkxk1n0vn4akgg20q6lh7"))))
+ "03c7mnk34wfz7a0m5zq0273y94awz69fy5iww8alh4a4v96h6vl0"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-v"))))))
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (if tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v")))))))
(propagated-inputs (list python-pycodestyle python-entrypoints
python-pyflakes python-mccabe))
(native-inputs (list python-mock python-pytest))
--
2.36.1