autogen: Use guile-3.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 6 Jun 2022 02:46
(address . guix-patches@gnu.org)
87ilpe4o09.fsf@contorta
Some relatively simply patches make autogen build with guile-3.0. Used
by both Debian an openSUSE, so already has a bit of field testing.

I'm not 100% sure that it wasn't just dumb luck, but it seemed like
building autogen with guile-3.0 was more likely to build reproducibly.

It did require adding automake and autoconf to inputs, seeming to detect
that something changed since configure was generated. Not sure if that
could be avoided by being cleverer, or if that is an acceptible change.


live well,
vagrant
From 9745d65234b70115a07d324f5514b125ad97369a Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Sun, 5 Jun 2022 16:05:02 -0700
Subject: [PATCH 3/3] gnu: autogen: Build with guile 3.0.

* gnu/packages/autogen.scm (autogen)[arguments]: Add 'support-guile-3.0 phase.
[inputs]: Remove guile-2.2 and add automake, autoconf and guile-3.0.
---
gnu/packages/autogen.scm | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index d0c8df17ec..7e22167be5 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -25,6 +25,7 @@ (define-module (gnu packages autogen)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages base)
@@ -49,7 +50,7 @@ (define-public autogen
"def_bf[MAXNAMELEN + 10]")))))
(build-system gnu-build-system)
(native-inputs (list pkg-config which))
- (inputs (list guile-2.2 perl)) ; for doc generator mdoc
+ (inputs (list automake autoconf guile-3.0 perl)) ; for doc generator mdoc
(arguments
'(#:configure-flags
;; XXX Needed to build 5.18.16. ./configure fails without it:
@@ -62,6 +63,21 @@ (define-public autogen
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'support-guile-3.0
+ ;; Upstream bug:
+ ;; https://sourceforge.net/p/autogen/bugs/196/
+ ;;
+ ;; Supported in Debian and openSUSE:
+ ;; https://salsa.debian.org/debian/autogen/-/blob/master/debian/patches/40_suse_04-guile-version.patch
+ (lambda _
+ (substitute*
+ "agen5/guile-iface.h"
+ (("#elif GUILE_VERSION < 203000") "#elif GUILE_VERSION < 301000"))
+ (substitute*
+ (list
+ "configure"
+ "config/guile.m4")
+ (("2.2 2.0 1.8") "3.0 2.2 2.0 1.8"))))
(add-before 'build 'set-man-page-date
;; Avoid embedding the current date for reproducible builds
(lambda _
--
2.35.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYp1OdwAKCRDcUY/If5cW
qghzAPsFJ2ZAjbBp62GBGGmNCRya4kedbd422xxjjlQThT6plwD6AktrPwRA1uNR
KeEwNwwunq5rE/2w2PDn4bZONm2aagI=
=/5Fn
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 10 Jun 2022 23:13
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)(address . 55813@debbugs.gnu.org)
871qvwz0fe.fsf@gnu.org
Hi!

Vagrant Cascadian <vagrant@reproducible-builds.org> skribis:

Toggle quote (6 lines)
> Some relatively simply patches make autogen build with guile-3.0. Used
> by both Debian an openSUSE, so already has a bit of field testing.
>
> I'm not 100% sure that it wasn't just dumb luck, but it seemed like
> building autogen with guile-3.0 was more likely to build reproducibly.

Nice. :-)

Toggle quote (4 lines)
> It did require adding automake and autoconf to inputs, seeming to detect
> that something changed since configure was generated. Not sure if that
> could be avoided by being cleverer, or if that is an acceptible change.

It could be avoided by changing just ‘configure’ (which this patch
already does actually), but it’s fine either way.

Toggle quote (8 lines)
> From 9745d65234b70115a07d324f5514b125ad97369a Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
> Date: Sun, 5 Jun 2022 16:05:02 -0700
> Subject: [PATCH 3/3] gnu: autogen: Build with guile 3.0.
>
> * gnu/packages/autogen.scm (autogen)[arguments]: Add 'support-guile-3.0 phase.
> [inputs]: Remove guile-2.2 and add automake, autoconf and guile-3.0.

[...]

Toggle quote (3 lines)
> + (substitute*
> + "agen5/guile-iface.h"

You can move that string to the previous line.

Toggle quote (6 lines)
> + (substitute*
> + (list
> + "configure"
> + "config/guile.m4")
> + (("2.2 2.0 1.8") "3.0 2.2 2.0 1.8"))))

Here you should either modify ‘config/guile.m4’, in which case
‘autoreconf’ will have to run (that should be automatic), or modify
‘configure’, in which case the dependency on Autotools is unnecessary.

The latter is a fine solution.

OK with a change along these lines!

Thanks,
Ludo’.
V
V
Vagrant Cascadian wrote on 14 Jun 2022 06:02
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 55813-done@debbugs.gnu.org)
87ilp3dh90.fsf@contorta
On 2022-06-10, Ludovic Courtès wrote:
Toggle quote (17 lines)
> Vagrant Cascadian <vagrant@reproducible-builds.org> skribis:
>
>> Some relatively simply patches make autogen build with guile-3.0. Used
>> by both Debian an openSUSE, so already has a bit of field testing.
>>
>> I'm not 100% sure that it wasn't just dumb luck, but it seemed like
>> building autogen with guile-3.0 was more likely to build reproducibly.
>
> Nice. :-)
>
>> It did require adding automake and autoconf to inputs, seeming to detect
>> that something changed since configure was generated. Not sure if that
>> could be avoided by being cleverer, or if that is an acceptible change.
>
> It could be avoided by changing just ‘configure’ (which this patch
> already does actually), but it’s fine either way.

Ah, that seems simpler, at least...

Toggle quote (15 lines)
>> From 9745d65234b70115a07d324f5514b125ad97369a Mon Sep 17 00:00:00 2001
>> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
>> Date: Sun, 5 Jun 2022 16:05:02 -0700
>> Subject: [PATCH 3/3] gnu: autogen: Build with guile 3.0.
>>
>> * gnu/packages/autogen.scm (autogen)[arguments]: Add 'support-guile-3.0 phase.
>> [inputs]: Remove guile-2.2 and add automake, autoconf and guile-3.0.
>
> [...]
>
>> + (substitute*
>> + "agen5/guile-iface.h"
>
> You can move that string to the previous line.

Done.

Toggle quote (12 lines)
>> + (substitute*
>> + (list
>> + "configure"
>> + "config/guile.m4")
>> + (("2.2 2.0 1.8") "3.0 2.2 2.0 1.8"))))
>
> Here you should either modify ‘config/guile.m4’, in which case
> ‘autoreconf’ will have to run (that should be automatic), or modify
> ‘configure’, in which case the dependency on Autotools is unnecessary.
>
> The latter is a fine solution.

Ok, that seems like a smaller change, and still works, so went with that.

Toggle quote (2 lines)
> OK with a change along these lines!

Thanks for the review!

Pushed as 3691e37eb14c5871d213646154b98f5aaa5dd2f1.


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYqgIbAAKCRDcUY/If5cW
qmJSAP9ahJvS+EWoDx0IZ1Bf11rE8dLUAowYFP6twe62ZScESAD+OeyDtNPcd7Hu
viZXP4iBHz8MX8DSQ7FYBcPFPR8Wjgw=
=mlw2
-----END PGP SIGNATURE-----

Closed
?