doc: Add debbugs-gnu-guix command for Emacs.

  • Open
  • quality assurance status badge
Details
One participant
  • Oleg Pykhalov
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 4 Jun 2022 14:32
(name . guix-patches)(address . guix-patches@gnu.org)
87leucmwwk.fsf@gmail.com
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (22 lines)
> Hi,
>
> Brian Cully <bjc@spork.org> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> If you are using Emacs, does debbugs.el have
>>> shortcomings that make it a problem to review patches?
>
> To be clear, the question was directed primarily at current committers.
>
>> 1) It’d be nice if ‘M-x debbug-guix’ existed. I (briefly) looked at
>> making such a command, thinking it’d be relatively straight-forward to
>> just copy ‘debbugs-gnu’ and tweak some variables, but when it looked
>> like it was going to take more than 10 minutes just to figure out how
>> it was all put together I gave up as I can’t really dedicate time to
>> it right now.
>
> Try: C-u M-x debbugs-gnu. From there you can choose ‘guix’,
> ‘guix-patches’, or anything else (info "(guix) Debbugs User
> Interfaces").

I have a command in my Emacs config, which is handy to skip those steps.
commit a603a7eeb06afa2ebd0c3015ece6fdb5ef43e95a
Author: Oleg Pykhalov <go.wigust@gmail.com>
Date: Sat Jun 4 03:42:43 2022 +0300

doc: Add debbugs-gnu-guix command for Emacs.
* doc/contributing.texi (Debbugs User Interfaces): Add debbugs-gnu-guix
command for Emacs.

Toggle diff (21 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index e1902f120f..bf77b6e774 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -1459,6 +1459,17 @@ For example, to list all open issues on @code{guix-patches}, hit:
@kbd{C-u} @kbd{M-x} debbugs-gnu @kbd{RET} @kbd{RET} guix-patches @kbd{RET} n y
@end example
+Additionally, @kbd{M-x debbugs-gnu-guix} command in (@pxref{Init File,,,
+emacs, The GNU Emacs Manual}) can be defined with:
+
+@lisp
+(defun debbugs-gnu-guix ()
+ "List Guix issues."
+ (interactive)
+ (debbugs-gnu '("serious" "important" "normal")
+ '("guix" "guix-patches")))
+@end lisp
+
@xref{Top,,, debbugs-ug, Debbugs User Guide}, for more information on
this nifty tool!
-----BEGIN PGP SIGNATURE-----

iQJIBAEBCgAyFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAmKbUOsUHGdvLndpZ3Vz
dEBnbWFpbC5jb20ACgkQFn+OpQAa+pw7TRAAjWpzMQ69n5Hd27g4sPcD85P2GWqw
0ga2mV2jTYqcyUffYZTn3dcev/wx/e0itYu9JVNIh2pIttkDy6qw1PbZVKh1zAOY
VrPi7bXswFkO72l8cUEr7dl1FryQw4tlE+MhotLxAycqyboknRBmGVYvAh4y9Gxa
y35d/XagzdYCumwZq5FDjB0d4NCCyEoTQ0nbiv+bIb1B9jQvi19jZwB5cJM4gVbj
4Ssf+p1OeNMGd0G18fhWAvs4a6tCRyWq7Ej8hVyFMvsRkUngChJ5WpKq8zIbA+BZ
vAncmYC8bzlKdlyI4X2GB0UPoWfGNZqZl1GFHYxc2/HUWqL6KUppETKPXRjtLcRZ
YG511DPCargp/YpQKU8MYrzAUHO/RmZoWVUKVmZ4gCkpkEJUjQsrnWQg8MNvoJaz
9y6IaUQfAVUq6OM+7rZNLP0+3oYCwcbuPS9HpI2hZB96RPnj6ZQD6LorqDPdjfot
U2lUic/XrVPaVPej2VvjVNlGZ4myz5YGjpDwmDNhWNdVXxNTFTo+XsPsLmXcyjjL
fYr7hMy/4Hs2MBdgiv6rxr7Hf8+Ilj97+oph6Xz5ITE5Ijket30Ugc57hvdOBx8i
Qx4F4Oz5pDsGmDzv/zeJ+T72tkELN32fDYkh9+bFdi6FK6yAhmq41q85BIvvOUCq
2OtdeVA2mCjqTTY=
=SA4H
-----END PGP SIGNATURE-----

?