[PATCH 0/1] Add chromium-web-store extension

  • Open
  • quality assurance status badge
Details
4 participants
  • burning2007
  • Liliana Marie Prikler
  • Maxime Devos
  • Skyler Ferris
Owner
unassigned
Submitted by
burning2007
Severity
normal
B
B
burning2007 wrote on 4 Jun 2022 03:02
(address . guix-patches@gnu.org)(name . Anthony)(address . anthony@example.com)
20220604010204.14054-1-burning2007@ya.ru
From: Anthony <anthony@example.com>

Hi, folks!

This patch adds chromium-web-store browser extension. Although I would like to
use Guix as well for installing chromium extensions, this is currently too
cumbersome. I've tried to "pack" a couple of extensions, some did work, some didn't.
So, I decided to fallback to Chrome Web Store for now. This chromium-web-store is
only missing part to do that.

P.S. A package built from this definition will be named `chromium-web-store-chromium`
due to the way `(make-chromium-extension ...)` names produced "extension packages".

Anthony (1):
gnu: browser-extensions: add chromium-web-store

gnu/packages/browser-extensions.scm | 35 +++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

--
2.35.3
B
B
burning2007 wrote on 4 Jun 2022 10:28
[PATCH 1/1] gnu: browser-extensions: add chromium-web-store
(address . 55790@debbugs.gnu.org)(name . Anthony)(address . anthony@example.com)
20220604082807.18555-1-burning2007@ya.ru
From: Anthony <anthony@example.com>

---
gnu/packages/browser-extensions.scm | 35 +++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index f305552076..a413da8beb 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -109,3 +109,38 @@ (define ublock-origin
(define-public ublock-origin/chromium
(make-chromium-extension ublock-origin "chromium"))
+
+(define chromium-web-store
+ (package
+ (name "chromium-web-store")
+ (version "1.4.4.3")
+ (home-page "https://github.com/NeverDecaf/chromium-web-store")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17jp05dpd8lk8k7fi56jdbhiisx4ajylr6kax01mzfkwfhkd0q9d"))))
+ (build-system copy-build-system)
+ (outputs '("chromium"))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively "src" (assoc-ref outputs "chromium")))))))
+ (synopsis "Allows adding extensions from chrome web store on ungoogled-chromium")
+ (description "This extension brings the following functionality to
+ungoogled-chromium (and other forks that lack web store support):
+@itemize
+@item Allows installing extensions directly from chrome web store.
+@item Automatically checks for updates to your installed extensions and displays
+them on the badge.
+@end itemize")
+ (license license:expat)))
+
+(define-public chromium-web-store/chromium
+ (make-chromium-extension chromium-web-store "chromium"))
--
2.35.3
L
L
Liliana Marie Prikler wrote on 4 Jun 2022 10:48
Re: [PATCH 0/1] Add chromium-web-store extension
(name . Anthony)(address . anthony@example.com)
ac544578ff8da709d3bf398299a5eadae5912590.camel@gmail.com
Am Samstag, dem 04.06.2022 um 03:02 +0200 schrieb burning2007@ya.ru:
Toggle quote (8 lines)
> From: Anthony <anthony@example.com>
>
> Hi, folks!
>
> This patch adds chromium-web-store browser extension. Although I would
> like to use Guix as well for installing chromium extensions, this is
> currently too cumbersome. I've tried to "pack" a couple of extensions,
> some did work, some didn't.
Do submit those that work.

Toggle quote (2 lines)
> So, I decided to fallback to Chrome Web Store for now. This chromium-
> web-store is only missing part to do that.
You can do that, but as for the inclusion in Guix, please refer to the
FSDG [1], particularly "The system should have no repositories for
nonfree software and no specific recipes for installation of particular
nonfree programs. Nor should the distribution refer to third-party
repositories that are not committed to only including free software;
even if they only have free software today, that may not be true
tomorrow." Our importer infrastructure is already bending that rule;
there's no need to break it.

Cheers

B
B
burning2007 wrote on 4 Jun 2022 13:28
(name . Anthony)(address . anthony@example.com)
2552121654341873@mail.yandex.ru
Attachment: file
B
B
burning2007 wrote on 4 Jun 2022 13:30
(name . Anthony)(address . anthony@example.com)
223771654342162@mail.yandex.ru
Attachment: file
M
M
Maxime Devos wrote on 4 Jun 2022 15:08
Re: [bug#55790] [PATCH 0/1] Add chromium-web-store extension
d221316e470b9977b6e875e83287a7febe735c05.camel@telenet.be
[Removed anthony@example.com from CC because it's not a valid e-mail address]

burning2007@ya.ru schreef op za 04-06-2022 om 14:30 [+0300]:
Toggle quote (6 lines)
> > refer to the FSDG [1], particularly "... no specific recipes for
> > installation of particular nonfree programs ..."
>  
> Does it mean that a package proposed for inclusion shouldn't provide
> a way to install other software from external "repository",

External repositories are ok I think, no need to remove pip from Python
or ContentDB from Minetest or channels or "guix build -f" from Guix or
cabal.

Toggle quote (2 lines)
> like Chrome Web Store?

Chrome Web Store is not just an external repository, it's a mostly non-
free repository (in contrast to, say, pypi, ContentDB), see my e-mail.

Greetings,
Maxime
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYptZURccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7qN6AP97DSuL/1QOib1Bw218Fv3riIqR
eX9q/tChTIT9loJLKQD+I802is5fw42GbL3pLOkNG43HRS8oh/42eL3TBgnVKwM=
=D59c
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 4 Jun 2022 15:09
a4c9a87847904d8235192fd96d057b3dd5723159.camel@telenet.be
* see my e-mail -> see my previous e-mail
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYptZcRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7jyRAQD2RjdZpsyh3101h88rH4Lug686
nzEet6MCHM0Ic816dwD+Mj1vkKiDlq77FF8gcgO5OolFwj1qkegFoofJTg6VEA8=
=rvj1
-----END PGP SIGNATURE-----


S
S
Skyler Ferris wrote on 11 Mar 20:39 +0100
[PATCH 0/1] Add chromium-web-store extension
(address . 55790@debbugs.gnu.org)
4db608bd-a791-41be-858d-44f0ac344bdf@protonmail.com
Hi all,

It looks like there's a disagreement between Liliana and Maxime which was never fully addressed, so it's not clear if this will ever be merge-able.

My take is that Maxime's example of pip is relevant because the [pypi terms of use](https://pypi.org/policy/terms-of-use/)only requires that a royalty-free license is present, and non-free licenses can be royalty-free (I am not a lawyer). However, based on Liliana's interpretation of the FSDG the conclusion is "pip should not be included" rather than "the webstore should be included". Of course, removing pip is likely to cause problems for people as pip is a widely used method of managing python code. I do not know if any of the people in this conversation so far are legal experts and I would want to have a high level of confidence before proposing such a controversial change.

Considering that this email came from an address that cannot be valid, I think it is also fair to be concerned that this email might have been sent in bad faith with the intent of creating conflict and disrupting the project. Since we don't have any reason to think that including pip is a violation of the FSDG other than presumably amateur analysis, pip is a high-profile package so it's not likely to have been overlooked, and the only person who has expressed interest in including the webstore has gone out of their way to obfuscate their identity, I think it would be fair to simply close this issue with no further discussion. But I do not feel comfortable taking that action unilaterally considering the sensitivity of the matters discussed.

Regards,
Skyler
Attachment: file
?