[PATCH 0/1] Add emacs-spaceleader.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Maxime Devos
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 3 Jun 2022 21:16
(name . Guix Patches)(address . guix-patches@gnu.org)
20220603141651.GB20852@gac
Hi Guixers,

Here's spaceleader, an implementation of the Spacemacs leader key functionality.


all best,

jgart

https://whereis.???/
J
J
jgart wrote on 3 Jun 2022 21:21
[PATCH 1/2] gnu: Add emacs-bind-map.
(address . 55786@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220603192135.22923-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-bind-map): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index edcd6a3f4b..4f35cf8a9c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30437,6 +30437,33 @@ (define-public emacs-iter2
original package.")
(license license:gpl3+)))
+(define-public emacs-bind-map
+ (let ((commit "510a24138d8de3b8df0783f1ac493a551fc9bd74")
+ (revision "0"))
+ (package
+ (name "emacs-bind-map")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/justbur/bind-map")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0crxjy1ykgb429z8ikjv5iy8vg5i0qn8n86p2lgri4glx45sxxx0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mohkale/bind-map")
+ (synopsis "Bind personal keymaps in multiple locations")
+ (description
+"@code{emacs-bind-map} provides a macro bind-map which can be used to
+make a keymap available across different leader keys including ones
+tied to evil states. It is essentially a generalization of the idea
+of a leader key as used in Vim or the @code{emacs-evil-leader} package,
+and allows for an arbitrary number of leader keys.")
+ (license license:gpl3+))))
+
(define-public emacs-promise
(package
(name "emacs-promise")
--
2.36.1
J
J
jgart wrote on 3 Jun 2022 21:21
[PATCH 2/2] gnu: Add emacs-spaceleader.
(address . 55786@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220603192135.22923-2-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-spaceleader): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4f35cf8a9c..f8396b199b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30464,6 +30464,36 @@ (define-public emacs-bind-map
and allows for an arbitrary number of leader keys.")
(license license:gpl3+))))
+(define-public emacs-spaceleader
+ (let ((commit "5e27c7c517f60beaf2bd2446957aec0ce55e11fe")
+ (revision "0"))
+ (package
+ (name "emacs-spaceleader")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mohkale/spaceleader")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ghdybh7rpyrzp02bw43ks009n9idck9sxpjfnbqpyr6j45l5wnh"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash
+ emacs-general
+ emacs-which-key
+ emacs-use-package
+ emacs-bind-map))
+ (home-page "https://github.com/mohkale/spaceleader")
+ (synopsis "Emacs leader-key implementation from Spacemacs")
+ (description
+"@code{emacs-spaceleader} implements the leader-key functionality from
+spacemacs.")
+ (license license:gpl3+))))
+
(define-public emacs-promise
(package
(name "emacs-promise")
--
2.36.1
M
M
Maxime Devos wrote on 3 Jun 2022 21:41
Re: [bug#55786] [PATCH 1/2] gnu: Add emacs-bind-map.
72dac9a0ac25a556f1986299d31a6d6184b17a30.camel@telenet.be
jgart via Guix-patches via schreef op vr 03-06-2022 om 14:21 [-0500]:
Toggle quote (9 lines)
> +               (url "https://github.com/justbur/bind-map")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> +           "0crxjy1ykgb429z8ikjv5iy8vg5i0qn8n86p2lgri4glx45sxxx0"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://github.com/mohkale/bind-map")

Both of these result in a 404 for me.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYppj0hccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7qmtAQCOJSpSVr4Gnay9GRLWrnCAY3hv
udt2vKY5DrpgOz23zgEAjYZ/1onv08KHMzyKMBhtIoJ2LIXZy8D+RZpYcUuvKQQ=
=8pQM
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 3 Jun 2022 21:43
Re: [bug#55786] [PATCH 2/2] gnu: Add emacs-spaceleader.
febb147a78b394484974cba57cabbd80afef9558.camel@telenet.be
jgart via Guix-patches via schreef op vr 03-06-2022 om 14:21 [-0500]:
Toggle quote (8 lines)
> +      (version (git-version "0.2" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/mohkale/spaceleader")
> +               (commit commit)))

A copy of the GPL is missing, while the GPL requires it:

4. Conveying Verbatim Copies.

You may convey verbatim copies of the Program's source code as you
receive it, in any medium, provided that [...]; and give all
recipients a copy of this License along with the Program.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYppkRxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7jbpAP9RNkjUYO0bygY3Uu7QEYYt7mHS
66JI2SbBa2C/MCnUDgEAkG535kE+8RVCgpctcD6SRWLCt41Gv/dhvGHfiH+YwgY=
=v9Db
-----END PGP SIGNATURE-----


T
T
Tobias Geerinckx-Rice wrote on 4 Jun 2022 23:32
Re: [bug#55786] [PATCH 1/2] gnu: Add emacs-bind-map.
(name . Maxime Devos)(address . maximedevos@telenet.be)
87y1ycgkan@nckx
Hi,

The GPL was added thanks to jgart[0], so I've pushed both of these
patches.

Maxime Devos ???
Toggle quote (2 lines)
> Both of these result in a 404 for me.

works for me.

I changed the base version of emacs-bind-map to 1.1.2 as the
commit we use postdates [1].

My guess is an incomplete copy-paste job led to both?

…or maybe not, since spaceleader states its version as 0.0.3. I
don't see where either 0.2 came from.

I took the liberty of moving both lonely source hash strings up a
line, because I can :o)

I also re-indented the packages and expanded the description of
emacs-spaceleader just a bit, based on the .el comment and our own
emacs-evil-leader package.

Thanks!

T G-R

[1]:
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYpvWQA0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15wdcA/2LLrGFXSRNOfWrfBMWg99B+xMPSL2o4oKvqpAPn
FL+pAP4+1O0fiSyw387DtEvov8Fni7chT/R2NKpZRZBW27RcAA==
=6JqT
-----END PGP SIGNATURE-----

Closed
?