[PATCH] gnu: emacs-direnv: Update to 2.31.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Ludovic Courtès
Owner
unassigned
Submitted by
jgart
Severity
normal

Debbugs page

jgart wrote 3 years ago
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220603052635.16455-1-jgart@dismail.de
* gnu/packages/shellutils.scm (emacs-direnv): Update to 2.31.0.
[arguments]: Remove trailing boolean in lambda block.
---
gnu/packages/shellutils.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index d0f4068062..ad674a3989 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -368,7 +368,7 @@ (define-public trash-cli
(define-public direnv
(package
(name "direnv")
- (version "2.28.0")
+ (version "2.31.0")
(source
(origin (method git-fetch)
(uri (git-reference
@@ -377,7 +377,7 @@ (define-public direnv
(file-name (git-file-name name version))
(sha256
(base32
- "0yk53jn7wafklixclka17wyjjs2g5giigjr2bd0xzy10nrzwp7c9"))))
+ "1c52izjzkdhmyrfx1gmbp34n0qpxyxw0s94f0vy3ldlg8xr36wmk"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/direnv/direnv"
@@ -405,8 +405,7 @@ (define-public direnv
(invoke "go" "test" "./...")
;; Clean up from the tests, especially so that the extra
;; direnv executable that's generated is removed.
- (invoke "make" "clean")))
- #t)))))
+ (invoke "make" "clean"))))))))
(native-inputs
(list go-github-com-burntsushi-toml go-github-com-direnv-go-dotenv
go-github-com-mattn-go-isatty go-golang-org-x-mod which))
--
2.36.1
jgart wrote 3 years ago
[PATCH v2] gnu: direnv: Update to 2.31.0.
(address . 55775@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220606031414.13676-1-jgart@dismail.de
* gnu/packages/shellutils.scm (direnv): Update to 2.31.0.
[arguments]: Remove trailing boolean in lambda block.

Hi Guixers,

This is direnv not emacs-direnv. Here is version 2 ;()

I forgot the page the lists the debbugs control codes in order to change
the title of this issue.

Should we document that page somewhere for other Guixers using mumi/debbugs?

all best,

jgart

https://whereis.みんな/
---
gnu/packages/shellutils.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index d0f4068062..ad674a3989 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -368,7 +368,7 @@ (define-public trash-cli
(define-public direnv
(package
(name "direnv")
- (version "2.28.0")
+ (version "2.31.0")
(source
(origin (method git-fetch)
(uri (git-reference
@@ -377,7 +377,7 @@ (define-public direnv
(file-name (git-file-name name version))
(sha256
(base32
- "0yk53jn7wafklixclka17wyjjs2g5giigjr2bd0xzy10nrzwp7c9"))))
+ "1c52izjzkdhmyrfx1gmbp34n0qpxyxw0s94f0vy3ldlg8xr36wmk"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/direnv/direnv"
@@ -405,8 +405,7 @@ (define-public direnv
(invoke "go" "test" "./...")
;; Clean up from the tests, especially so that the extra
;; direnv executable that's generated is removed.
- (invoke "make" "clean")))
- #t)))))
+ (invoke "make" "clean"))))))))
(native-inputs
(list go-github-com-burntsushi-toml go-github-com-direnv-go-dotenv
go-github-com-mattn-go-isatty go-golang-org-x-mod which))
--
2.36.1
Ludovic Courtès wrote 3 years ago
Re: bug#55775: [PATCH] gnu: emacs-direnv: Update to 2.31.0.
(name . jgart)(address . jgart@dismail.de)(address . 55775-done@debbugs.gnu.org)
875yl8z0mp.fsf_-_@gnu.org
Hi,

jgart <jgart@dismail.de> skribis:

Toggle quote (3 lines)
> * gnu/packages/shellutils.scm (direnv): Update to 2.31.0.
> [arguments]: Remove trailing boolean in lambda block.

Applied, thanks!

Toggle quote (5 lines)
> I forgot the page the lists the debbugs control codes in order to change
> the title of this issue.
>
> Should we document that page somewhere for other Guixers using mumi/debbugs?


When using Emacs debbugs.el, one doesn’t have to remember that, which
helps a bit (info "(debbugs-ug) Control Messages").

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55775@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55775
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help