[PATCH] gnu: Add emacs-color-theme-modern.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Liliana Marie Prikler
  • peter
Owner
unassigned
Submitted by
peter
Severity
normal
P
P
peter wrote on 1 Jun 2022 17:41
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
fc347a502d5755b72b90b92f9b6254c6312f950b.1654097985.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New variable.
---
gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 22d723c879..7612832173 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -109,6 +109,7 @@
;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2873,6 +2874,40 @@ (define-public emacs-auctex
or XEmacs.")
(license license:gpl3+)))
+(define-public emacs-color-theme-modern
+ (package
+ (name "emacs-color-theme-modern")
+ (version "20220506.858")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-jp/replace-colorthemes.git")
+ (commit "74ad69bbca6fcfff3c0960d888c7c9c1f9f3e2e8")))
+ (sha256
+ (base32
+ "13ff4s372wsl5x13vh4vywhi6qcc54gybhp6rxl0r1l4wxidanwn"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacs-jp/replace-colorthemes")
+ (synopsis "Over one hundred Emacs themes ported from color-theme")
+ (description "Over one hundred Emacs themes, including aalto-dark,
+aalto-light, aliceblue, andreas, arjen, beige-diff, beige-eshell,
+bharadwaj-slate, bharadwaj, billw, black-on-gray, blippblopp, blue-erc,
+blue-eshell, blue-gnus, blue-mood, blue-sea, calm-forest, charcoal-black,
+clarity, classic, cobalt, comidia, dark-blue, dark-blue2, dark-erc,
+dark-font-lock, dark-gnus, dark-green, dark-info, dark-laptop, deep-blue,
+desert, digital-ofs1, emacs-21, emacs-nw, euphoria, feng-shui, fischmeister,
+gnome, gnome2, goldenrod, gray1, gray30, greiner, gtk-ide, high-contrast,
+hober, infodoc, jb-simple, jedit-grey, jonadabian-slate, jonadabian, jsc-dark,
+jsc-light, jsc-light2, julie, katester, kingsajz, late-night, lawrence,
+ld-dark, lethe, marine, marquardt, matrix, midnight, mistyday, montz, oswald,
+parus, pierson, pok-wob, pok-wog, railscast, ramangalahy, raspopovic,
+renegade, resolve, retro-green, retro-orange, robin-hood, rotor, ryerson,
+salmon-diff, salmon-font-lock, scintilla, shaman, simple-1, sitaramv-nt,
+sitaramv-solaris, snow, snowish, standard-ediff, standard, subdued,
+subtle-blue, subtle-hacker, taming-mr-arneson, taylor, tty-dark, vim-colors,
+whateveryouwant, wheat, word-perfect, xemacs, xp")
+ (license license:gpl3+)))
+
(define-public emacs-autothemer
(package
(name "emacs-autothemer")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 2 Jun 2022 08:09
43bacbc2ae73f3326b9138f2585a036f2bc43f29.camel@ist.tugraz.at
Am Mittwoch, dem 01.06.2022 um 11:41 -0400 schrieb peter@polidoro.io:
Toggle quote (4 lines)
> +(define-public emacs-color-theme-modern
> +  (package
> +    (name "emacs-color-theme-modern")
> +    (version "20220506.858")
We don't do MELPA versions. Use "0.0.3" as base version, and...

Toggle quote (7 lines)
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://github.com/emacs-jp/replace-colorthemes.git")
> +                    (commit
> "74ad69bbca6fcfff3c0960d888c7c9c1f9f3e2e8")))
... use git-version for non-release commits. It's also always nice to
include a helpful message as to why you're building a non-release
commit, in this case that'd be "No release since October 2019."

Toggle quote (8 lines)
> +              (sha256
> +               (base32
> +               
> "13ff4s372wsl5x13vh4vywhi6qcc54gybhp6rxl0r1l4wxidanwn"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/emacs-jp/replace-colorthemes")
> +    (synopsis "Over one hundred Emacs themes ported from color-
> theme")
No ads.

Toggle quote (30 lines)
> +    (description "Over one hundred Emacs themes, including aalto-
> dark,
> +aalto-light, aliceblue, andreas, arjen, beige-diff, beige-eshell,
> +bharadwaj-slate, bharadwaj, billw, black-on-gray, blippblopp, blue-
> erc,
> +blue-eshell, blue-gnus, blue-mood, blue-sea, calm-forest, charcoal-
> black,
> +clarity, classic, cobalt, comidia, dark-blue, dark-blue2, dark-erc,
> +dark-font-lock, dark-gnus, dark-green, dark-info, dark-laptop, deep-
> blue,
> +desert, digital-ofs1, emacs-21, emacs-nw, euphoria, feng-shui,
> fischmeister,
> +gnome, gnome2, goldenrod, gray1, gray30, greiner, gtk-ide, high-
> contrast,
> +hober, infodoc, jb-simple, jedit-grey, jonadabian-slate, jonadabian,
> jsc-dark,
> +jsc-light, jsc-light2, julie, katester, kingsajz, late-night,
> lawrence,
> +ld-dark, lethe, marine, marquardt, matrix, midnight, mistyday,
> montz, oswald,
> +parus, pierson, pok-wob, pok-wog, railscast, ramangalahy,
> raspopovic,
> +renegade, resolve, retro-green, retro-orange, robin-hood, rotor,
> ryerson,
> +salmon-diff, salmon-font-lock, scintilla, shaman, simple-1,
> sitaramv-nt,
> +sitaramv-solaris, snow, snowish, standard-ediff, standard, subdued,
> +subtle-blue, subtle-hacker, taming-mr-arneson, taylor, tty-dark,
> vim-colors,
> +whateveryouwant, wheat, word-perfect, xemacs, xp")
No ads. Write something like "This package contains several themes
that were originally implemented with the venerable @code{color-themes}
package, ported to Emacs' built-in custom themes."

Cheers
P
P
peter wrote on 2 Jun 2022 19:28
[PATCH] gnu: Add emacs-color-theme-modern.
(address . 55753@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
0c50403e63f23e8ab35a282edb5b56d9c644eabf.1654190818.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ced6e1a482..bbf8b6c343 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -110,6 +110,7 @@
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8464,6 +8465,29 @@ (define-public emacs-ahungry-theme
dark background.")
(license license:gpl3+)))
+(define-public emacs-color-theme-modern
+ ;; building a non-release commit since no release since October 2019
+ (let ((commit "74ad69bbca6fcfff3c0960d888c7c9c1f9f3e2e8")
+ (revision "1"))
+ (package
+ (name "emacs-color-theme-modern")
+ (version (git-version "0.0.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-jp/replace-colorthemes.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13ff4s372wsl5x13vh4vywhi6qcc54gybhp6rxl0r1l4wxidanwn"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacs-jp/replace-colorthemes")
+ (synopsis "Collection of Emacs themes originally from the color-themes package")
+ (description "This package contains several themes that were originally implemented
+with the venerable @code{color-themes} package, ported to Emacs' built-in custom themes.")
+ (license license:gpl3+))))
+
(define-public emacs-gruvbox-theme
(package
(name "emacs-gruvbox-theme")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 4 Jun 2022 09:52
d1d2f09c6f9e4dcd7cfda93d13e1ff23387f25cc.camel@gmail.com
Am Donnerstag, dem 02.06.2022 um 13:28 -0400 schrieb peter@polidoro.io:
Toggle quote (4 lines)
> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New
> variable.
Pushed with minor changes in synopsis, description and git-version
comment.

Thanks
L
L
Liliana Marie Prikler wrote on 4 Jun 2022 10:34
10cb4bbdf4dfeb8d127d0081fe9d90f546d6165e.camel@gmail.com
Am Samstag, dem 04.06.2022 um 09:52 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (10 lines)
> Am Donnerstag, dem 02.06.2022 um 13:28 -0400 schrieb
> peter@polidoro.io:
> > From: Peter Polidoro <peter@polidoro.io>
> >
> > * gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New
> > variable.
> Pushed with minor changes in synopsis, description and git-version
> comment.
>
> Thanks
Forgot to mark as done.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55753@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55753
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch