[PATCH] gnu: parinfer-rust: Copy plugin files to output.

  • Done
  • quality assurance status badge
Details
2 participants
  • calum
  • Skyler Ferris
Owner
unassigned
Submitted by
calum
Severity
normal
C
C
calum wrote on 1 Jun 2022 07:47
(address . guix-patches@gnu.org)(name . calum)(address . calumirwin1@gmail.com)
20220601054710.17297-1-calumirwin1@gmail.com
* gnu/packages/text-editors.scm (parinfer-rust)[arguments]: Copy plugin files to output.
[home-page]: Use correct url.
---
gnu/packages/text-editors.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index cb86a907ff..011e3bbb65 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
+;;; Copyright © 2021,2022 Calum Irwin <calumirwin1@gmail.com>
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -274,10 +274,17 @@ (define-public parinfer-rust
("rust-serde-json" ,rust-serde-json-1)
("rust-serde-derive" ,rust-serde-derive-1)
("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
- ("rust-unicode-width" ,rust-unicode-width-0.1))))
+ ("rust-unicode-width" ,rust-unicode-width-0.1))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-extra
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "rc/parinfer.kak" (string-append out "/rc"))
+ (install-file "plugin/parinfer.vim" (string-append out "/plugin"))))))))
(inputs
(list clang))
- (home-page "https://github.com/justinbarclay/parinfer-rust")
+ (home-page "https://github.com/eraserhd/parinfer-rust")
(synopsis "Infer parentheses for Clojure, Lisp and Scheme")
(description
"Parinfer is a plugin for Kakoune, Vim, Neovim and Emacs that infers
--
2.36.0
C
S
S
Skyler Ferris wrote on 11 Mar 18:54 +0100
(address . 55746@debbugs.gnu.org)
90a37de1-3ec4-4dfb-a4df-1f8eccd3d1aa@protonmail.com
Trying to close this issue as the submitter indicated that it is a
duplicate of a different issue whose patch has been merged. I haven't
used the email interface in this way before, so hopefully I get it right. =)

user guix
close 55746
quit
S
S
Skyler Ferris wrote on 11 Mar 19:08 +0100
close 55746
(address . control@debbugs.gnu.org)
c1b2ac10-88e2-472c-b027-e02c36b3425f@protonmail.com
Trying again. I'm having some problems locating comprehensive
documentation for the email interface so I'm just manually reading mbox
files. If this doesn't work I'll stop guessing and ask for help. =)

user guix
close 55746
quit
?