[PATCH] gnu: Add python-musical-scales

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87ee0azt62.fsf@gmail.com
Hello,

this patch adds "musical-scales" Python module[1] under the name
"python-musical-scales".

References:
1. "Retrieve a scale based on a given mode and starting note."
From bdd66c0ec7cb5d19f6210cbda3b1d465322a7864 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 30 May 2022 22:57:49 +0300
Subject: [PATCH] gnu: Add python-musical-scales

* gnu/packages/python-xyz.scm (python-musical-scales): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acd5954fb6..1f106d0075 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31838,3 +31838,25 @@ profile. It supports:
Currently, Linux is the only platform supported by this library.")
(license license:expat)))
+
+(define-public python-musical-scales
+ (package
+ (name "python-musical-scales")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "musical-scales" version))
+ (sha256
+ (base32
+ "1ckn8n37i7b65h0i385ycn0w8sg9na0iabz0kmhxxc1wj0hddkw9"))))
+ (build-system python-build-system)
+ (native-inputs (list python-wheel))
+ (inputs (list python))
+ (home-page "https://github.com/hmillerbakewell/musical-scales")
+ (synopsis "Retrieve a scale based on a given mode and starting note")
+ (description
+ "Retrieve a scale based on a given mode and starting note.
+Information about these scales can be
+@url{https://en.wikipedia.org/wiki/List_of_musical_scales_and_modes, found on
+Wikipedia}.")
+ (license license:expat)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKVIpUACgkQ6cWi2QiY
oC8UdAf+JMcPAlnawaQvPAR7vfOKFtqPNu5Ih7yHD2lRj2PKhlMUmExXJu7cyIel
OPzUD9bpoNlgTGJnKpTn2+D1LsVCaQeyuol1pRTcQ9YDKNfpKRvSrNzGVQQGTuyX
8T5la2CxKv5H05Hibao/SeT3R2uU8k0J9B8j+h2YCnDO+mcX1J5L3iUgatbvZFBb
WBoO/l/b4Ivo8NrW70sLm/e4ffsrWjIRg0hBGHibEcXVHsQYW+IukOv0RwCwsxkb
5XonnIpQfYN9dQqGwNvW3lyjmlzHZ/tW1JNluD28758iCL06TNIG9Ip4ULOjehy+
XKlB+sg205TOoxG3XJUxOrtmN1bKnA==
=QI0t
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 55731-done@debbugs.gnu.org)
87h74zndwi.fsf@gnu.org
Hello Artyom,

Toggle quote (2 lines)
> + (inputs (list python))

I removed this implicit line and pushed.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55731@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55731
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help