[PATCH] gnu: Add r-diagrammersvg.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220530125341.18195-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-diagrammersvg): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5a8285b342..568882e701 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24078,6 +24078,26 @@ (define-public r-diagram
Francesca Mazzia (2012).")
(license license:gpl2+)))
+(define-public r-diagrammersvg
+ (package
+ (name "r-diagrammersvg")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DiagrammeRsvg" version))
+ (sha256
+ (base32 "0j2cm1mx3zrb2k3pcrb96z2z3kws61gyyjsjjv5rqcb5lzdgi65k"))))
+ (properties `((upstream-name . "DiagrammeRsvg")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-v8))
+ (home-page "https://github.com/rich-iannone/DiagrammeRsvg")
+ (synopsis "Export DiagrammeR graphviz graphs as svg")
+ (description
+ "This package allows exporting a @code{DiagrammeR Graphviz} objects to
+@code{SVG}.")
+ (license license:expat)))
+
(define-public r-lim
(package
(name "r-lim")

base-commit: 98e2f4fbebb8b08784401e2095123fcd3d3a32cb
--
2.36.0
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 55725@debbugs.gnu.org)
87czfv1811.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-diagrammersvg): New variable.

Thanks for the patch.

Unfortunately, we cannot merge it as is, because the package bundles
minified JavaScript. The bundled d3.js can easily be replaced, but I
don’t know about the other bundled JavaScript files.

--
Ricardo
Ricardo Wurmus wrote 2 years ago
(address . control@debbugs.gnu.org)
87o7tn54dl.fsf@elephly.net
tags 55725 moreinfo
tags 57135 moreinfo
thanks

--
Ricardo
Ricardo Wurmus wrote 1 years ago
(address . 55725-done@debbugs.gnu.org)
87a5spmurl.fsf@elephly.net
I’m closing this because there has been no response and we’ve got
r-diagrammersvg in the guix-science channel.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55725@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55725
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help