[PATCH] gnu: ocaml-ctypes: do not override install headers

  • Done
  • quality assurance status badge
Details
2 participants
  • David Arroyo
  • Julien Lepiller
Owner
unassigned
Submitted by
David Arroyo
Severity
normal

Debbugs page

David Arroyo wrote 3 years ago
(address . guix-patches@gnu.org)(name . David Arroyo)(address . david@aqwari.net)
20220529204234.657407-1-david@aqwari.net
Overriding INSTALL_HEADERS in the build prevents the "ocaml_integers.h"
header from being copied from the ocaml-integers package to ocaml-ctypes.
The header's absence breaks all dune-based projects which build cstubs
using the new (ctypes ...) stanza.

* gnu/packages/ocaml.scm:
[arguments]: remove INSTALL_HEADERS override.
---
gnu/packages/ocaml.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e6d6bc7a89..c7da5a2106 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4333,9 +4333,7 @@ (define-public ocaml-ctypes
"0ilzq9qzvwv9rc08cc9wchsx636zp870i7qvqmbigaa2qb812m0z"))))
(build-system ocaml-build-system)
(arguments
- `(#:make-flags
- (list (string-append "INSTALL_HEADERS = $(wildcard $($(PROJECT).dir)/*.h)"))
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-writable
(lambda _
--
2.36.1
Julien Lepiller wrote 3 years ago
(name . David Arroyo)(address . david@aqwari.net)(address . 55715-done@debbugs.gnu.org)
20220602075440.09a9127c@sybil.lepiller.eu
Le Sun, 29 May 2022 16:42:34 -0400,
David Arroyo <david@aqwari.net> a écrit :

Toggle quote (3 lines)
> * gnu/packages/ocaml.scm:
> [arguments]: remove INSTALL_HEADERS override.

Pushed to master as 21800bf8b98871c99c0a91d97690be1df07a2659 with a
small change to the commit message. Thanks for the patch and enjoy!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55715@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55715
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help