David Arroyo wrote 3 years ago
(address . guix-patches@gnu.org)(name . David Arroyo)(address . david@aqwari.net)
Overriding INSTALL_HEADERS in the build prevents the "ocaml_integers.h"
header from being copied from the ocaml-integers package to ocaml-ctypes.
The header's absence breaks all dune-based projects which build cstubs
using the new (ctypes ...) stanza.
* gnu/packages/ocaml.scm:
[arguments]: remove INSTALL_HEADERS override.
---
gnu/packages/ocaml.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
Toggle diff (17 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e6d6bc7a89..c7da5a2106 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4333,9 +4333,7 @@ (define-public ocaml-ctypes
"0ilzq9qzvwv9rc08cc9wchsx636zp870i7qvqmbigaa2qb812m0z"))))
(build-system ocaml-build-system)
(arguments
- `(#:make-flags
- (list (string-append "INSTALL_HEADERS = $(wildcard $($(PROJECT).dir)/*.h)"))
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-writable
(lambda _
--
2.36.1