[PATCH] gnu: quodlibet: Set GST_PLUGIN_SYSTEM_PATH.

  • Done
  • quality assurance status badge
Details
2 participants
  • Bassam Saeed
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Bassam Saeed
Severity
normal

Debbugs page

Bassam Saeed wrote 3 years ago
(address . guix-patches@gnu.org)
CAHeCkFXt+_H0WAY2pOOAtQTMTcgdNH4sW1Vwv7rxmg2f4SniDA@mail.gmail.com
Hi all,

Currently, quodlibet is unable to find a gstreamer audio sink when playing
audio unless the relevant gst-plugins is explicitly installed in your
profile. For me that's gst-plugins-good. Currently, existing packaged
applications such as Strawberry and Clementine explicitly set the
GST_PLUGIN_SYSTEM_PATH. I've adapted this for Quodlibet with my patch. I
suppose an alternative might be to include the gst plugins as
propagated-inputs but I'm not certain about that. I decided to just follow
the current practice.

Hope everything is right here. My first patch to guix.

Cheers,
Bassam
Attachment: file
From 1c0a33328b3475f39d10d9a668ba11f702b962dd Mon Sep 17 00:00:00 2001
Message-Id: <1c0a33328b3475f39d10d9a668ba11f702b962dd.1653839478.git.bassam.saeed@gmail.com>
From: Bassam Saeed <bassam.saeed@gmail.com>
Date: Sun, 29 May 2022 11:35:57 -0400
Subject: [PATCH] gnu: quodlibet: Set GST_PLUGIN_SYSTEM_PATH.

---
gnu/packages/music.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9011f262a4..b4ff2bef0e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6904,6 +6904,13 @@ (define-public quodlibet
,@%glib-or-gtk-build-system-modules)
#:phases
#~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/quodlibet")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))
+ #t)))
(add-before 'check 'pre-check
(lambda _
(setenv "HOME" (getcwd))))

base-commit: 9cd22702b87f873f7e307c99b406fb758e5a307c
--
2.36.1
Liliana Marie Prikler wrote 3 years ago
(name . Bassam Saeed)(address . bassam.saeed@gmail.com)(address . 55710-done@debbugs.gnu.org)
2e7c26c23f45dec49cc9b7c4c2c856f297dd35f8.camel@gmail.com
Am Sonntag, dem 29.05.2022 um 12:03 -0400 schrieb Bassam Saeed:
Toggle quote (12 lines)
> Hi all,
>
> Currently, quodlibet is unable to find a gstreamer audio sink when
> playing audio unless the relevant gst-plugins is explicitly installed
> in your profile. For me that's gst-plugins-good. Currently, existing
> packaged applications such as Strawberry and Clementine explicitly
> set the GST_PLUGIN_SYSTEM_PATH. I've adapted this for Quodlibet with
> my patch. I suppose an alternative might be to include the gst
> plugins as propagated-inputs but I'm not certain about that. I
> decided to just follow the current practice.
>
> Hope everything is right here. My first patch to guix.
Pushed a different patch that essentially does the same. Thanks for
pointing this out.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55710@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55710
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help