Bassam Saeed wrote 3 years ago
(address . guix-patches@gnu.org)
Hi all,
Currently, quodlibet is unable to find a gstreamer audio sink when playing
audio unless the relevant gst-plugins is explicitly installed in your
profile. For me that's gst-plugins-good. Currently, existing packaged
applications such as Strawberry and Clementine explicitly set the
GST_PLUGIN_SYSTEM_PATH. I've adapted this for Quodlibet with my patch. I
suppose an alternative might be to include the gst plugins as
propagated-inputs but I'm not certain about that. I decided to just follow
the current practice.
Hope everything is right here. My first patch to guix.
Cheers,
Bassam
From 1c0a33328b3475f39d10d9a668ba11f702b962dd Mon Sep 17 00:00:00 2001
Message-Id: <1c0a33328b3475f39d10d9a668ba11f702b962dd.1653839478.git.bassam.saeed@gmail.com>
From: Bassam Saeed <bassam.saeed@gmail.com>
Date: Sun, 29 May 2022 11:35:57 -0400
Subject: [PATCH] gnu: quodlibet: Set GST_PLUGIN_SYSTEM_PATH.
---
gnu/packages/music.scm | 7 +++++++
1 file changed, 7 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9011f262a4..b4ff2bef0e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6904,6 +6904,13 @@ (define-public quodlibet
,@%glib-or-gtk-build-system-modules)
#:phases
#~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/quodlibet")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))
+ #t)))
(add-before 'check 'pre-check
(lambda _
(setenv "HOME" (getcwd))))
base-commit: 9cd22702b87f873f7e307c99b406fb758e5a307c
--
2.36.1