[PATCH] gnu: wpa-supplicant: Add DBus service file.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Roman Riabenko
Owner
unassigned
Submitted by
Roman Riabenko
Severity
normal
R
R
Roman Riabenko wrote on 28 May 2022 18:30
(address . guix-patches@gnu.org)
fe9051323c1e7926a967f7c57291fea610d043d9.camel@riabenko.com
Hello

This patch adds DBus service file for wpa-supplicant. I was
investigating a different issue when noticed that dbus-system-services-
builder warns that it is missing. I reconfigured my system with these
changes to test. It seems that WiFi stopped dropping connection as I
had been experiencing occasionally before, but it may be a coincidence.

Roman
From 34f9918e53e4c540741dedb9dcd527eb59645a0b Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Sat, 28 May 2022 18:36:48 +0300
Subject: [PATCH] gnu: wpa-supplicant: Add DBus service file.

* gnu/packages/admin.scm (wpa-supplicant): Add DBus service file
for wpa-supplicant for dbus-system-services-builder to find.
---
gnu/packages/admin.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index af75dee697..b077aadb84 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2028,10 +2029,16 @@ (define-public wpa-supplicant
(add-after 'install-documentation 'install-dbus-conf
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/etc/dbus-1/system.d")))
- (mkdir-p dir)
+ (interfaces (string-append out "/etc/dbus-1/system.d"))
+ (services (string-append out
+ "/share/dbus-1/system-services")))
+ (mkdir-p interfaces)
(copy-file "dbus/dbus-wpa_supplicant.conf"
- (string-append dir "/wpa_supplicant.conf")))
+ (string-append interfaces "/wpa_supplicant.conf"))
+ (mkdir-p services)
+ (copy-file "dbus/fi.w1.wpa_supplicant1.service"
+ (string-append services
+ "/fi.w1.wpa_supplicant1.service")))
#t))))))))
(define-public wpa-supplicant-gui

base-commit: 6e9d99f97f15347f44df0518faa5e3b8b9d5184e
--
2.36.1
L
L
Ludovic Courtès wrote on 5 Jun 2022 23:17
(name . Roman Riabenko)(address . roman@riabenko.com)(address . 55691-done@debbugs.gnu.org)
87o7z6eroz.fsf@gnu.org
Hi,

Roman Riabenko <roman@riabenko.com> skribis:

Toggle quote (6 lines)
> This patch adds DBus service file for wpa-supplicant. I was
> investigating a different issue when noticed that dbus-system-services-
> builder warns that it is missing. I reconfigured my system with these
> changes to test. It seems that WiFi stopped dropping connection as I
> had been experiencing occasionally before, but it may be a coincidence.

Hmm it may be unrelated, but it’s a good idea anyway.

Toggle quote (8 lines)
> From 34f9918e53e4c540741dedb9dcd527eb59645a0b Mon Sep 17 00:00:00 2001
> From: Roman Riabenko <roman@riabenko.com>
> Date: Sat, 28 May 2022 18:36:48 +0300
> Subject: [PATCH] gnu: wpa-supplicant: Add DBus service file.
>
> * gnu/packages/admin.scm (wpa-supplicant): Add DBus service file
> for wpa-supplicant for dbus-system-services-builder to find.

Applied, thanks!

Ludo’.
Closed
?