gnu: Add r-scmap add r-googlevis.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
7c12946df28042ceb9b9a3b266551f55@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 2/2] gnu: Add r-scmap.
(address . 55679@debbugs.gnu.org)
20220527164013.4195-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-scmap): New variable.
---
gnu/packages/bioconductor.scm | 41 +++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4baa80dcb1..9c6526331e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5049,6 +5049,47 @@ (define-public r-scdblfinder
comprehensive scDblFinder method.")
(license license:gpl3)))
+(define-public r-scmap
+ (package
+ (name "r-scmap")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "scmap" version))
+ (sha256
+ (base32 "0pfwaa9pgml11b84rpf7afdkmg8kxb4srgpc56571vaz388xrv7l"))))
+ (properties `((upstream-name . "scmap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-biocgenerics
+ r-dplyr
+ r-e1071
+ r-ggplot2
+ r-googlevis
+ r-matrixstats
+ r-proxy
+ r-randomforest
+ r-rcpp
+ r-rcpparmadillo
+ r-reshape2
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/hemberg-lab/scmap")
+ (synopsis "Tool for unsupervised projection of single cell RNA-seq data")
+ (description
+ "@dfn{Single-cell RNA-seq} (scRNA-seq) is widely used to investigate the
+composition of complex tissues since the technology allows researchers to define
+cell-types using unsupervised clustering of the transcriptome. However, due to
+differences in experimental methods and computational analyses, it is often
+challenging to directly compare the cells identified in two different experiments.
+@code{scmap} is a method for projecting cells from a scRNA-seq experiment onto
+the cell-types or individual cells identified in a different experiment.")
+ (license license:gpl3)))
+
(define-public r-seqlogo
(package
(name "r-seqlogo")
--
2.36.0
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 1/2] gnu: Add r-googlevis.
(address . 55679@debbugs.gnu.org)
20220527164013.4195-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-googlevis): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0fdcfb3cb9..ae90e5f162 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -402,6 +402,33 @@ (define-public r-googledrive
(description "This package lets you manage Google Drive files from R.")
(license license:expat)))
+(define-public r-googlevis
+ (package
+ (name "r-googlevis")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "googleVis" version))
+ (sha256
+ (base32 "1s82xcs6zrlmnhay764bspzwvabfyi35nq6fwdrrk3v79q13c5jz"))))
+ (properties `((upstream-name . "googleVis")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-jsonlite))
+ (native-inputs (list r-knitr))
+ (home-page "https://mages.github.io/googleVis/")
+ (synopsis "R interface to Google Charts")
+ (description
+ "The @code{googleVis} package provides an interface between R and the
+Google Charts API. Google Charts offer interactive charts which can be embedded
+into web pages. The functions of the @code{googleVis} package allow the user to
+visualise data stored in @code{R} data frames with Google Charts without
+uploading the data to Google. The output of a @code{googleVis} function is
+@code{HTML} code that contains the data and references to JavaScript functions
+hosted by Google. @code{googleVis} makes use of the internal @code{R}
+@code{HTTP server} to display the output locally.")
+ (license license:gpl2+)))
+
(define-public r-guix-install
(package
(name "r-guix-install")

base-commit: 0e953f3332cc862b08ecb2342bdac9976dd6d08c
--
2.36.0
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 55679-done@debbugs.gnu.org)
87o7zhb7kx.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-googlevis): New variable.

I applied this and the patch for r-scmap after minor formatting
changes. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55679@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55679
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help