Erik Šabič wrote 3 years ago
(address . guix-patches@gnu.org)
* gnu/packages/emacs-xyz.scm (emacs-elm-mode): Update to 0.21.0-1.1e27768.
---
gnu/packages/emacs-xyz.scm | 43 +++++++++++++++++++-------------------
1 file changed, 22 insertions(+), 21 deletions(-)
Toggle diff (65 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f7fb6aac35..f62c733fb5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19692,26 +19692,27 @@ (define-public emacs-ibuffer-vc
(license license:gpl3+)))
(define-public emacs-elm-mode
- (package
- (name "emacs-elm-mode")
- (version "0.21.0")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/jcollard/elm-mode")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0iwk4fmw8hq3ry4ky1zc7lgl4cpbnrjyk74c2xzddfspi3ks41fd"))))
- (propagated-inputs
- (list emacs-dash emacs-f emacs-reformatter emacs-s))
- (build-system emacs-build-system)
- (home-page "https://github.com/jcollard/elm-mode")
- (synopsis "Emacs major mode for editing Elm source code")
- (description
- "This package provides a major mode for editing Elm source code, and
+ ;; Version tag 0.21.0 was made Jan 14 2020. It doesn't work with Emacs 28
+ ;; due to missing, now-mandatory "when" arg for obsolete function alias.
+ (let ((commit "1e277684d8a6681a2410cce2dd589ee30a998369"))
+ (package
+ (name "emacs-elm-mode")
+ (version (git-version "0.21.0" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcollard/elm-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gnr61ibzcznfqy5f8capmbz75rcfikwy106rjdmp45qz2jwp4di"))))
+ (propagated-inputs (list emacs-f emacs-reformatter emacs-s))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jcollard/elm-mode")
+ (synopsis "Emacs major mode for editing Elm source code")
+ (description
+ "This package provides a major mode for editing Elm source code, and
working with common core and third-party Elm tools. Its features are:
@itemize
@@ -19725,7 +19726,7 @@ (define-public emacs-elm-mode
@item Integration with elm-format
@item Integration with elm-test
@end itemize")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-helm-mode-manager
(package
base-commit: d37c7f7ad4134cc15d1558eb6c0bc4c59a0db1af
--
2.36.1