gnu: Add perl-http-daemon-ssl

  • Open
  • quality assurance status badge
Details
3 participants
  • Attila Lendvai
  • Christopher Baines
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 26 May 2022 15:03
[PATCH] gnu: perl-http-daemon: Update to 6.14.
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220526130335.27626-1-attila@lendvai.name
---
gnu/packages/web.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ffcb709e82..0186ac06e5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3462,18 +3462,19 @@ (define-public perl-http-cookies
(define-public perl-http-daemon
(package
(name "perl-http-daemon")
- (version "6.01")
+ (version "6.14")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Daemon-"
+ "mirror://cpan/authors/id/O/OA/OALDERS/HTTP-Daemon-"
version ".tar.gz"))
(sha256
(base32
- "1hmd2isrkilf0q0nkxms1q64kikjmcw9imbvrjgky6kh89vqdza3"))))
+ "079fkcq2vdrzdf0bml52kz73n9gdv1xg0qf72c9v505v7izpwxph"))))
(build-system perl-build-system)
(propagated-inputs
- (list perl-http-message perl-lwp-mediatypes))
+ (list perl-http-message perl-lwp-mediatypes perl-module-build-tiny
+ perl-test-needs))
(license license:perl-license)
(synopsis "Perl simple http server class")
(description
--
2.35.1
A
A
Attila Lendvai wrote on 26 May 2022 15:05
[PATCH 2/2] gnu: Add perl-http-daemon-ssl.
(address . 55656@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220526130543.28222-1-attila@lendvai.name
---
i've decided to send this patch together with the perl-http-daemon,
because they depend on each other. pardon the missing 1/2 annotation
on the first patch.

this will be needed by an upcoming ddclient update.

gnu/packages/web.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0186ac06e5..3d642aec26 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3483,6 +3483,33 @@ (define-public perl-http-daemon
IO::Socket::INET, so you can perform socket operations directly on it too.")
(home-page "https://metacpan.org/release/HTTP-Daemon")))
+(define-public perl-http-daemon-ssl
+ (package
+ (name "perl-http-daemon-ssl")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/A/AU/AUFFLICK/HTTP-Daemon-SSL-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "0bn2blg2dzbyqnvbxs4ch2chqnfn9xvmnl6kvy988k4k5m10bbky"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ (list perl-http-daemon perl-io-socket-ssl))
+ (arguments
+ ;; The tests want to connect to a local HTTPS server; see SSL_SERVER_ADDR.
+ `(#:tests? #f))
+ (home-page "https://metacpan.org/release/HTTP-Daemon-SSL")
+ (synopsis "Perl simple http server class with SSL support")
+ (description
+ "Instances of the HTTP::Daemon::SSL class are HTTP/1.1 servers that listen
+on a socket for incoming requests. The HTTP::Daemon::SSL is a sub-class of
+IO::Socket::SSL, so you can perform socket operations directly on it too.")
+ (license license:perl-license)))
+
(define-public perl-http-date
(package
(name "perl-http-date")
--
2.35.1
C
C
Christopher Baines wrote on 27 May 2022 11:47
(name . Attila Lendvai)(address . attila@lendvai.name)
87v8trs3ty.fsf@cbaines.net
Attila Lendvai <attila@lendvai.name> writes:

Toggle quote (49 lines)
> ---
> i've decided to send this patch together with the perl-http-daemon,
> because they depend on each other. pardon the missing 1/2 annotation
> on the first patch.
>
> this will be needed by an upcoming ddclient update.
>
> gnu/packages/web.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 0186ac06e5..3d642aec26 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -3483,6 +3483,33 @@ (define-public perl-http-daemon
> IO::Socket::INET, so you can perform socket operations directly on it too.")
> (home-page "https://metacpan.org/release/HTTP-Daemon")))
>
> +(define-public perl-http-daemon-ssl
> + (package
> + (name "perl-http-daemon-ssl")
> + (version "1.04")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "mirror://cpan/authors/id/A/AU/AUFFLICK/HTTP-Daemon-SSL-"
> + version
> + ".tar.gz"))
> + (sha256
> + (base32 "0bn2blg2dzbyqnvbxs4ch2chqnfn9xvmnl6kvy988k4k5m10bbky"))))
> + (build-system perl-build-system)
> + (propagated-inputs
> + (list perl-http-daemon perl-io-socket-ssl))
> + (arguments
> + ;; The tests want to connect to a local HTTPS server; see SSL_SERVER_ADDR.
> + `(#:tests? #f))
> + (home-page "https://metacpan.org/release/HTTP-Daemon-SSL")
> + (synopsis "Perl simple http server class with SSL support")
> + (description
> + "Instances of the HTTP::Daemon::SSL class are HTTP/1.1 servers that listen
> +on a socket for incoming requests. The HTTP::Daemon::SSL is a sub-class of
> +IO::Socket::SSL, so you can perform socket operations directly on it too.")
> + (license license:perl-license)))
> +
> (define-public perl-http-date
> (package
> (name "perl-http-date")

Looking at what Debian ship for this, I think they use
looks to still be very old, but maybe have some fixes over the 1.04
version.

Does that look like it could be sensible to use?
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmKQnplfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf9Kg/9FRoF6Dodc9XIad3Y8b4FgQDLN1yU9fzb
F9ASAVEKuEEpF27Iw12iKXQQ3KmHRjv9ld7uMuB3l5BQbFr80uT57c7dMIfT6SJ/
N1C+ILAcqHneaP+KzpoiCnoKXWE8FPh5XScDYRByqEnoRN0nKuJnkU04laweNFvs
F+gj2lk5DrOVmugjmDkd8Kvqon8HtC39Omadz84ARBNpS7i0GYUXgkzI9eg1h+la
n38mHM8+fNDfg2HMyWrpCOes3opuawnqomab7TkUfvltuOminTzfTsZciI6b+76L
HCFeMyqTEjm8lW6KU1OXtYRQc0vUUqalv6FwplLyD4io9LqWFRc9g373UhQkXRzk
IZsRHT+IkuCXocasD3uPMG2Tx533+9bOy6etTw/nPq4HBPLiSgr41j3CReV+9ijy
mFOmsS8SjUhALQ4CWHhy8EwPvUl6WCtuWKPs7OtZFB/cQtHaajQK5rWHhM2fEvj7
k9gAL4r3VtkaTFrngCtAeR/RNkhC2tJ++JRMnOPDUBvnpGvpd6m/NY3pQyYexrpq
05PjQyw2UZmNzzY15x6lFOKtct3RNLqGV7k33ReqI/PuNJ3PRTijypnpX0u/mw7L
d9CRG/bzOylvBKN6hMXq/fhuCovkpEKYiAdkXgGXMkaVk04eX20b7Lt/hGpdUaJ1
JRFkbbaH/xA=
=ln3u
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 27 May 2022 12:03
Re: [bug#55656] [PATCH] gnu: perl-http-daemon: Update to 6.14.
(name . Attila Lendvai)(address . attila@lendvai.name)(address . 55656@debbugs.gnu.org)
87r14fs30h.fsf@cbaines.net
Attila Lendvai <attila@lendvai.name> writes:

Toggle quote (33 lines)
> ---
> gnu/packages/web.scm | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index ffcb709e82..0186ac06e5 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -3462,18 +3462,19 @@ (define-public perl-http-cookies
> (define-public perl-http-daemon
> (package
> (name "perl-http-daemon")
> - (version "6.01")
> + (version "6.14")
> (source (origin
> (method url-fetch)
> (uri (string-append
> - "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Daemon-"
> + "mirror://cpan/authors/id/O/OA/OALDERS/HTTP-Daemon-"
> version ".tar.gz"))
> (sha256
> (base32
> - "1hmd2isrkilf0q0nkxms1q64kikjmcw9imbvrjgky6kh89vqdza3"))))
> + "079fkcq2vdrzdf0bml52kz73n9gdv1xg0qf72c9v505v7izpwxph"))))
> (build-system perl-build-system)
> (propagated-inputs
> - (list perl-http-message perl-lwp-mediatypes))
> + (list perl-http-message perl-lwp-mediatypes perl-module-build-tiny
> + perl-test-needs))
> (license license:perl-license)
> (synopsis "Perl simple http server class")
> (description

This looks good to me, but because this is an input to wget, which seems
to have a lot of dependent packages (~900), this probably needs to go to
the staging branch.

Unfortunately, staging is frozen at the moment, so I'm not sure if it's
the right time to push it.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmKQor5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfCvBAAsvDska3L3kDhZk/BiOQVQptGms4CJnQz
Es9EprSXGo5KE3cupHbZLZ6vJtHCmMwWBKcUKViWxKJ3rm2VeQRuA+s72pGDstbT
XAejcsXjEMYz6ytcItps2fFrN4P40GZZfoLmd3Ak7m5TEnaooeKCr40GnDnr/Y0d
e7FW1jqwljNpGrJuB1BH2l2uD2vLRBoQ/Grt32DW/0GGVrmnSvHhkOCjAklRWM8d
ZYVGMsTC/OqMSG3UUtRzsQ6bRfsLpEF5wbW9L2fLIUSHeAURB4WyoF8Z0BZfK10Q
NSz1wuGe0q+iK16IKDQ1OIzJAKSucG9SKVyJI9gRNXtIepLyOWusNiPDo0kNzheP
XGXiuebXpgXaodE7v7Q7L6P5sSFIMd1kfu1561teFX93g2IqmsMCWgbjTfGmq7k0
81n04hF1vG1YCHMQM/Y+yyRtk1aiBtEf3o2DFdHdrcL5Qd3Thp9JeVgY8ixNfLxY
7FL5CvXvnyeUW/MQmaAV0yafgvJZkYTTG2O9y0pfEJDTtSbwsbAygfGOHSz7wDpg
c0hcC9qiUURv/hpGOT8sW6Zfv7ndI4lVtGk6pxi/bQlZFyeWRLioBnOsXEw0z1SW
ouPYkl8KOW2RNtvzQduwRtS6tzz1bNrarfbNqZc0wRTSVBQE7+feoQJebd44UmZr
iz4OAf/rkTk=
=6sGC
-----END PGP SIGNATURE-----

A
A
Attila Lendvai wrote on 27 May 2022 13:44
Re: [bug#55656] [PATCH 2/2] gnu: Add perl-http-daemon-ssl.
(name . Christopher Baines)(address . mail@cbaines.net)
OW78jfx_f6MMH5iDOkCbmRlVmFldreXD-v9dNJ3pG-58x77THJ0HhiPDZAYP36W1IRDRC5m53lvUdJa6yUnLqwGqQnuVE98QXo2W2rfCp8g=@lendvai.name
Toggle quote (7 lines)
> Looking at what Debian ship for this, I think they use
> https://github.com/aufflick/p5-http-daemon-ssl as the source, which
> looks to still be very old, but maybe have some fixes over the 1.04
> version.
>
> Does that look like it could be sensible to use?

i cannot answer that, unfortunately. i needed this package to update ddclient, and just blindly ran `guix import cpan HTTP::Daemon::SSL`.

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
Life is too short to spend time with people who suck the happiness out of you.
V
V
Vagrant Cascadian wrote on 2 Sep 2023 02:08
Re: [bug#55656] [PATCH] gnu: perl-http-daemon: Update to 6.14.
(address . control@debbugs.gnu.org)
874jkdqvvy.fsf@wireframe
retitle 55656 gnu: Add perl-http-daemon-ssl
thanks

On 2022-05-26, Attila Lendvai wrote:
Toggle quote (11 lines)
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index ffcb709e82..0186ac06e5 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -3462,18 +3462,19 @@ (define-public perl-http-cookies
> (define-public perl-http-daemon
> (package
> (name "perl-http-daemon")
> - (version "6.01")
> + (version "6.14")

perl-http-daemon was updated in:

80d84f76cdcf8115ef6f659353131ce1dce58cc4 gnu: perl-http-daemon: Update to 6.14.
c888e9028db76e52a7f2fccef84d68a7e3564837 gnu: perl-http-daemon: Update to 6.14.

The remaining issue is "gnu: Add perl-http-daemon-ssl." so retitling
appropriately.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJ9EQAKCRDcUY/If5cW
qpO4AP4gVfCfxerFKuLV39rzPf9kAE+udBQ9nfsii3Tg4VRU5wEA6vOwIHVrx5y/
//2n8+6M5N3y+PEyYdaanqabuB2SqQE=
=qWQr
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 55656@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55656
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch