[PATCH] images: Fix hurd platform module import

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Morgan Smith
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB31632E0E1121E03CC8D5FE58C5D69@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* guix/platforms/images/hurd.scm: Fix hurd platform module import
---

guix pull was failing for me and I found that this was the culprit

gnu/system/images/hurd.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/system/images/hurd.scm b/gnu/system/images/hurd.scm
index 36b6f3a200..bbeeaa2ff3 100644
--- a/gnu/system/images/hurd.scm
+++ b/gnu/system/images/hurd.scm
@@ -19,11 +19,11 @@
(define-module (gnu system images hurd)
#:use-module (guix gexp)
+ #:use-module ((guix platforms x86) #:select (hurd))
#:use-module (gnu bootloader)
#:use-module (gnu bootloader grub)
#:use-module (gnu image)
#:use-module (gnu packages ssh)
- #:use-module (guix platforms hurd)
#:use-module (gnu services)
#:use-module (gnu services ssh)
#:use-module (gnu system)
--
2.36.1
Morgan Smith wrote 3 years ago
control message for bug #55629
(address . control@debbugs.gnu.org)
DM5PR03MB31631AD3B2D05EE11FFFE1F8C5D69@DM5PR03MB3163.namprd03.prod.outlook.com
close 55629
quit

Efraim beat me to this with commit be43625159de560b651d3a744db5b79b4f1fe55f
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55629@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55629
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help